X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Prevent firefox from using HTML5 player in Youtube.

Được đăng

How do I prevent firefox from using HTML5 player in youtube and use flash player instead? I am not sure what advantage HTML5 has over Flash. I noticed that Flash plays smoother than HTML5 and there is also a difference in quality of the video at low resolution. HTML5 does not seem to have smooth streaming compared to Flash. I may be wrong and I am ready to learn the advantage of HTML5 over Flash. But until then I wish to revert FF to its previous behavior of playing in flash.

If there is no way of bypassing this player (html5), how do I set it to ask before I allow it to play the video? I dislike videos playing automatically as soon as I open the link or any websites (reason why I set Flash player to 'ask to activate').

Thank you for your generous help. :)

How do I prevent firefox from using HTML5 player in youtube and use flash player instead? I am not sure what advantage HTML5 has over Flash. I noticed that Flash plays smoother than HTML5 and there is also a difference in quality of the video at low resolution. HTML5 does not seem to have smooth streaming compared to Flash. I may be wrong and I am ready to learn the advantage of HTML5 over Flash. But until then I wish to revert FF to its previous behavior of playing in flash. If there is no way of bypassing this player (html5), how do I set it to ask before I allow it to play the video? I dislike videos playing automatically as soon as I open the link or any websites (reason why I set Flash player to 'ask to activate'). Thank you for your generous help. :)

Giải pháp được chọn

John99 said

We are in a situation where continual changes are being made by both Mozilla & YouTube and some of these changes may be version & OS specific with regard to Firefox.

YouTube may be experimenting with different default players for different browsers and operating systems. I have both Firefox 36 Beta and Firefox 35 installed on the same Windows 7 computer. Back on January 31, the HTML5 player was the default for me in Firefox 36 Beta, while in Firefox 35.0.1 the Flash plugin was used. The other day, HTML5 was the default for both Firefox 35 and Firefox 36 Beta (the YouTube Flash Video Player add-on suggested by cor-el was the best fix I could find).

Today, Flash is being used on both Firefox 36 Beta 9 AND Firefox 35.0.1 even after removing the add-on, as well as in fresh new profiles. Also, https://www.youtube.com/html5 reports "The default player is currently used" with a blue button, "Request the HTML5 player" just as shown in the screenshot attached to this post.

Here are the test videos I used today: https://www.youtube.com/watch?v=BSqb6DvyGDs https://www.youtube.com/watch?v=u-nkRBlqHzA


By the way, "Ask to Activate" is working for me in both Firefox 35 and 36 .... I just have to reload the page sometimes, which was the workaround reported in /questions/1042082.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 16.0 r0

Ứng dụng

  • Firefox 36.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/36.0/WINNT/en-US/

Tiện ích mở rộng

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • IDM CC 7.3.93 (mozilla_cc@internetdownloadmanager.com)
  • User Agent Switcher 0.7.3 ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 397517aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-20-2014
  • driverDate2:
  • driverVersion: 9.17.10.3517
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
John99 971 giải pháp 13138 câu trả lời
Được đăng

That's easy to do on YouTube's settings page just toggle the setting

FlashPlayer is proprietary software, and although very commonly used does not even support some devices. FlashPlayer is also involved in quite a lot of Firefox issues and crashes. FlashPlayer has needed to be updated within the last day or so due to security issues.

HTML5 is open source, relatively new and covers a lot more than just video playing it is the new standard for the internet.

See also new Firefox HTML5 feature still in development

That's easy to do on YouTube's settings page just toggle the setting * Visit https://www.youtube.com/html5 FlashPlayer is proprietary software, and although very commonly used does not even support some devices. FlashPlayer is also involved in quite a lot of Firefox issues and crashes. FlashPlayer has needed to be updated within the last day or so due to security issues. * See [[Flash Plugin - Keep it up to date and troubleshoot problems]] HTML5 is open source, relatively new and covers a lot more than just video playing it is the new standard for the internet. * https://en.wikipedia.org/wiki/HTML5 See also new Firefox HTML5 feature still in development *[[Firefox Hello - video and voice conversations online]]

Người tạo câu hỏi

Hi, thank you for the reply. But there was no such option to toggle the option in that youtube page. I signed in to check. Same result. Provided the screenshot.

Also, how do I set hml5 player to ask me before getting activated by itself (if I choose to use it)?

Thanks and Regards. Seeker

Hi, thank you for the reply. But there was no such option to toggle the option in that youtube page. I signed in to check. Same result. Provided the screenshot. Also, how do I set hml5 player to ask me before getting activated by itself (if I choose to use it)? Thanks and Regards. Seeker
John99 971 giải pháp 13138 câu trả lời
Được đăng

Quick response from a phone UN tick the check box saying use html5 and it will use Flashplayer

Quick response from a phone UN tick the check box saying use html5 and it will use Flashplayer
cor-el
  • Top 10 Contributor
  • Moderator
17468 giải pháp 157871 câu trả lời
Được đăng

You can try to toggle media.mediasource.youtubeonly to false.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can try to toggle media.mediasource.youtubeonly to false. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Người tạo câu hỏi

Hello Sir, Thank you for trying to help.

None of the solution work. I tried toggling that option and setting webm to false in about:config. HTML5 kicks in no matter what. Guess, I have to adapt to this player. In the meantime, I shall dig further to find a solution.

Have a nice day. Regards

Hello Sir, Thank you for trying to help. None of the solution work. I tried toggling that option and setting webm to false in about:config. HTML5 kicks in no matter what. Guess, I have to adapt to this player. In the meantime, I shall dig further to find a solution. Have a nice day. Regards
John99 971 giải pháp 13138 câu trả lời
Được đăng

Hi again Ѕeeкɘя,

I have just tried with Windows & Firefox 35 and my method did not work.

It appears my information was out of date and that a change was made with Google YouTube proposing forcing Fx34 users to use HTML5 where available & enforcing this from Fx35 onwards.

Possibly switching user agent to FX33 will work. I have not tried that yet.

Hi again Ѕeeкɘя, I have just tried with Windows & Firefox 35 and my method did not work. It appears my information was out of date and that a change was made with Google YouTube proposing forcing Fx34 users to use HTML5 where available & enforcing this from Fx35 onwards. Possibly switching user agent to FX33 will work. I have not tried that yet.
John99 971 giải pháp 13138 câu trả lời
Được đăng

Câu trả lời hữu ích

I found info here

Update: Google seems to have delayed the change. Firefox 34 users can switch players right now on the site. .... <snip>

In fact must choose earlier than 33 so I used

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/32.0

Other add-ons are available I used

User Agent Quick Switch 5.0.2 

From https://addons.mozilla.org/firefox/addon/user-agent-quick-switch (It does not even report correct homesite)

View from Fx37 & View spoofing Fx32 attached


P.S. Left click thumbnails to view larger version. Modified January 31, 2015 2:10:40 PM BST by John99

I found info here * http://www.ghacks.net/2014/07/17/google-enforces-html5-youtube-firefox-33-newer/ <blockquote><snip> .... What this means is that Google will enforce the use of HTML5 video on YouTube for all Firefox users who use Firefox 33 or newer on their system to do so (Note this means Firefox Nightly currently, but on Tuesday also Firefox Aurora). Update: Google seems to have delayed the change. Firefox 34 users can switch players right now on the site. .... <snip></blockquote> In fact must choose earlier than 33 so I used ''Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/32.0'' Other add-ons are available I used User Agent Quick Switch 5.0.2 From https://addons.mozilla.org/firefox/addon/user-agent-quick-switch (It does not even report correct homesite) * A Search <s>[https://addons.mozilla.org/firefox/search /?q=user+agent+switch&appver=35&platform=WINNT]</s> * '''2nd edit''' fixed link [https://addons.mozilla.org/firefox/search/?q=user+agent+switch&appver=35&platform=WINNT] View from Fx37 & View spoofing Fx32 attached P.S. Left click thumbnails to view larger version. <sub>Modified January 31, 2015 2:10:40 PM BST by John99 </sub>

Được chỉnh sửa bởi John99 vào

AliceWyman
  • Moderator
240 giải pháp 2594 câu trả lời
Được đăng

Ѕeeкɘя said

How do I prevent firefox from using HTML5 player in youtube and use flash player instead? I am not sure what advantage HTML5 has over Flash.

I see you're using Firefox 36 Beta which I'm also testing. The 36.0beta releasenotes say,

HTML5 | Implemented a subset of the Media Source Extensions (MSE) API to allow native HTML5 playback on YouTube. Full support is on the way

These look to be the related bug reports:

  • Bug 778617 - (MSE) Tracking bug for Media Source Extensions API implementation

I haven't found a way to enable Flash on YouTube instead of HTML5 with Firefox 36 Beta. I tried setting media.mediasource.enabled to false with no luck. I also tried disabling the media.mediasource.mp4.enabled and media.mediasource.webm.enabled preferences, since they were mentioned in http://www.ghacks.net/2014/10/26/the-state-of-media-source-extensions-in-firefox/ but no luck there either.

You also asked,

If there is no way of bypassing this player (html5), how do I set it to ask before I allow it to play the video? I dislike videos playing automatically as soon as I open the link or any websites (reason why I set Flash player to 'ask to activate').

I also have Flash set to "Ask to Activate" fopr the same reason. However, according to bug 1112761 #c9, HTML5 is only enabled by default on YouTube. That's controlled by the preference media.mediasource.youtubeonly (setting it to false will enable it everywhere so you don't want to do that!) .

So far I haven't had too much trouble with YouTube videos starting when I use Firefox 36, since you do have to click on the link to the video for it to start. It's just a matter of getting used to not having to click the "Activate Adobe Flash" icon before it starts playing. Then again, Firefox 35 is my default browser (I have both installed in separate program folders) and I also use the SeaMonkey browser (which is based on Firefox 35) quite a bit.

''Ѕeeкɘя [[#question-1044212|said]]'' <blockquote> How do I prevent firefox from using HTML5 player in youtube and use flash player instead? I am not sure what advantage HTML5 has over Flash. </blockquote> I see you're using Firefox 36 Beta which I'm also testing. The [https://www.mozilla.org/en-US/firefox/36.0beta/releasenotes/ 36.0beta releasenotes] say, HTML5 | Implemented a subset of the Media Source Extensions (MSE) API to allow native HTML5 playback on YouTube. Full support is on the way These look to be the related bug reports: *[https://bugzilla.mozilla.org/show_bug.cgi?id=778617 Bug 778617] - (MSE) Tracking bug for Media Source Extensions API implementation *[https://bugzilla.mozilla.org/show_bug.cgi?id=1112761 Bug 1112761] - Restrict MSE support to youtube.com domain for Firefox 36 I haven't found a way to enable Flash on YouTube instead of HTML5 with Firefox 36 Beta. I tried setting media.mediasource.enabled to false with no luck. I also tried disabling the media.mediasource.mp4.enabled and media.mediasource.webm.enabled preferences, since they were mentioned in http://www.ghacks.net/2014/10/26/the-state-of-media-source-extensions-in-firefox/ but no luck there either. You also asked, <blockquote>If there is no way of bypassing this player (html5), how do I set it to ask before I allow it to play the video? I dislike videos playing automatically as soon as I open the link or any websites (reason why I set Flash player to 'ask to activate'). </blockquote> I also have Flash set to "Ask to Activate" fopr the same reason. However, according to [https://bugzilla.mozilla.org/show_bug.cgi?id=1112761#c9 bug 1112761 #c9], HTML5 is only enabled by default on YouTube. That's controlled by the preference ''media.mediasource.youtubeonly'' (setting it to false will enable it everywhere so you don't want to do that!) . So far I haven't had too much trouble with YouTube videos starting when I use Firefox 36, since you do have to click on the link to the video for it to start. It's just a matter of getting used to not having to click the "Activate Adobe Flash" icon before it starts playing. Then again, Firefox 35 is my default browser (I have both installed in separate program folders) and I also use the [http://www.seamonkey-project.org/ SeaMonkey] browser (which is based on Firefox 35) quite a bit.
John99 971 giải pháp 13138 câu trả lời
Được đăng

Câu trả lời hữu ích

Thanks for all the background info Alice. Presumably you agree spoofing Fx32 is a suitable workaround and solves the issue by allowing Windows7 Firefox Release (fx35) & Beta (fx36) to select FlashPlayer on YouTube.


Seeker Does that work ok for you ?


Update cor-el's workaround is better, use the add-on

Thanks for all the background info Alice. Presumably you agree spoofing Fx32 is a suitable workaround and solves the issue by allowing Windows7 Firefox Release (fx35) & Beta (fx36) to select FlashPlayer on YouTube. ------ Seeker Does that work ok for you ? ------- Update ''cor-el'''s workaround is better, use the add-on * ''YouTube Flash Video Player 35.1'' from https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Được chỉnh sửa bởi John99 vào

AliceWyman
  • Moderator
240 giải pháp 2594 câu trả lời
Được đăng

Hi, John.

I was hoping to find a way to enable Flash on YouTube without resorting to an add-on.

I installed the UserAgentSwitcher add-on in Firefox 36 and created a Firefox 35 user agent,

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 

That allowed Flash to play on YouTube. Flash also started without prompting after trying a YouTube video link. EDIT: I had Firefox 36 set to Always Activate. It seems that "Ask to Activate" for Adobe Flash no longer works for me in Firefox 35 or Firefox 36. (it still does in SeaMonkey, which is my main browser right now). More on Adobe Flash "Ask to Activate" issues here: /questions/1042082

It's a workaround but it isn't a great one since exiting then reopening Firefox resets the UA to the default User Agent (Firefox 36). You have to reselect the Firefox 35 user agent at every startup.

Hi, John. I was hoping to find a way to enable Flash on YouTube without resorting to an add-on. I installed the [https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/ UserAgentSwitcher] add-on in Firefox 36 and created a Firefox 35 user agent, Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 That allowed Flash to play on YouTube. Flash also started without prompting after trying a YouTube video link. <sub>EDIT: I had Firefox 36 set to Always Activate. It seems that "Ask to Activate" for Adobe Flash no longer works for me in Firefox 35 or Firefox 36. (it still does in SeaMonkey, which is my main browser right now). More on Adobe Flash "Ask to Activate" issues here: [/questions/1042082] </sub> It's a workaround but it isn't a great one since exiting then reopening Firefox resets the UA to the default User Agent (Firefox 36). You have to reselect the Firefox 35 user agent at every startup.

Được chỉnh sửa bởi AliceWyman vào

cor-el
  • Top 10 Contributor
  • Moderator
17468 giải pháp 157871 câu trả lời
Được đăng

What happens if you disable MSE by toggling some media.mediasource.* prefs related to enabling (mp4) features on the about:config page? media.mediasource.enabled media.mediasource.youtubeonly media.mediasource.mp4.enabled


YouTube Flash Video Player:

What happens if you disable MSE by toggling some media.mediasource.* prefs related to enabling (mp4) features on the <b>about:config</b> page? media.mediasource.enabled media.mediasource.youtubeonly media.mediasource.mp4.enabled ----- YouTube Flash Video Player: *https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Người tạo câu hỏi

Hello Everyone,

I would like to inform you all that Firefox is function the way I had expected it to be i.e it is now playing YouTube videos with Flash Player. I did not change anything in configuration page except that I had disabled media.gmp-gmpopenh264.provider.enabled i.e set it to 'False'. (Same configuration before it started using HTML5)

YouTube html5 page is now showing the option that John99 was talking about. (Screenshot attached.)

@Cor-el : I did not try toggling the options you mentioned. It worked with the defaults and I wanted FF to work with their defaults intact like earlier. Now its working without touching those options. (Screenshot attached)

Developers might have changed or fixed the problem I don't know but its all good now. I am using Firefox 36 Beta 9 as of now.

Edit: Sorry, I was wrong maybe. It didn't solve.

Hello Everyone, I would like to inform you all that Firefox is function the way I had expected it to be i.e it is now playing YouTube videos with Flash Player. I did not change anything in configuration page except that I had disabled '''''media.gmp-gmpopenh264.provider.enabled''''' i.e set it to ''''''False''''''. (Same configuration before it started using HTML5) YouTube html5 page is now showing the option that '''John99''' was talking about. (''Screenshot attached''.) @'''Cor-el''' : I did not try toggling the options you mentioned. It worked with the defaults and I wanted FF to work with their defaults intact like earlier. Now its working without touching those options. (''Screenshot attached'') Developers might have changed or fixed the problem I don't know but its all good now. I am using '''Firefox 36 Beta 9''' as of now. Edit: Sorry, I was wrong maybe. It didn't solve.

Được chỉnh sửa bởi Ѕeeкɘя vào

John99 971 giải pháp 13138 câu trả lời
Được đăng

What happened with the earlier workarounds do they still work

  1. Spoofing an earlier version such as Fx31
  2. Using the add-on https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/
What happened with the earlier workarounds do they still work # Spoofing an earlier version such as Fx31 #Using the add-on https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Người tạo câu hỏi

Hello John99,

I did not try the workaround #1 because as AliceWyman mentioned, the user agent resets itself after restart. I did not try #2 because, I don't want an extra addon to use in firefox just to play video with flash on youtube.

I tried cor-el's suggestion though today. Did not work.

It would be nice to have a straightforward simple tweak/option inbuilt in FF to do so. If you could please pass this request to the developers that would be great.

By the way FF is acting strange lately. I mean I thought the problem had solved without me doing anything but it surfaced again. The same video started playing in HTML5 later today. Now, it is playing in flash again but I have to refresh the page twice to load the plugin again sometimes. I am not sure however, how long this would stay like this.

But as I said, an easier option would be nice. Does not matter if its in about:config.

Hello John99, I did not try the workaround #1 because as AliceWyman mentioned, the user agent resets itself after restart. I did not try #2 because, I don't want an extra addon to use in firefox just to play video with flash on youtube. I tried cor-el's suggestion though today. Did not work. It would be nice to have a straightforward simple tweak/option inbuilt in FF to do so. If you could please pass this request to the developers that would be great. By the way FF is acting strange lately. I mean I thought the problem had solved without me doing anything but it surfaced again. The same video started playing in HTML5 later today. Now, it is playing in flash again but I have to refresh the page twice to load the plugin again sometimes. I am not sure however, how long this would stay like this. But as I said, an easier option would be nice. Does not matter if its in about:config.
John99 971 giải pháp 13138 câu trả lời
Được đăng

Hi Ѕeeкɘя,

You may not like the method suggested but at least they serve as troubleshooting methods showing what may be the problem. The fact that the add-ons may be easily enabled and disabled allows comparison & testing in the alternative states.

I am not sure why things may be changing for you now. Last time I looked in Windows Firefox Youtube by default Played in HTML but spoofing worked to get a FlashPlayer option. (I prefer HTML5)

You are using Beta and that is making some differences in this situation.

  • See https://www.mozilla.org/en-US/firefox/36.0beta/releasenotes/
    HTML5
    Implemented a subset of the Media Source Extensions (MSE) API to allow native HTML5 playback on YouTube. Full support is on the way
    [also initially]
    Changed
    The Flash protected-mode sandbox is disabled * on Windows, to evaluate the stability impact of protected mode

We are in a situation where continual changes are being made by both Mozilla & YouTube and some of these changes may be version & OS specific with regard to Firefox.

Hi Ѕeeкɘя, You may not like the method suggested but at least they serve as troubleshooting methods showing what may be the problem. The fact that the add-ons may be easily enabled and disabled allows comparison & testing in the alternative states. I am not sure why things may be changing for you now. Last time I looked in Windows Firefox Youtube by default Played in HTML but spoofing worked to get a FlashPlayer option. (I prefer HTML5) You are using Beta and that is making some differences in this situation. * See https://www.mozilla.org/en-US/firefox/36.0beta/releasenotes/ <blockquote> HTML5 <br /> Implemented a subset of the Media Source Extensions (MSE) API to allow native HTML5 playback on YouTube. Full support is on the way <br /> [also initially] <br /> Changed <br /> The Flash protected-mode sandbox is disabled [https://quality.mozilla.org/2015/01/disabling-protected-mode-in-firefox-36-beta/ *] on Windows, to evaluate the stability impact of protected mode </blockquote> We are in a situation where continual changes are being made by both Mozilla & YouTube and some of these changes may be version & OS specific with regard to Firefox.
AliceWyman
  • Moderator
240 giải pháp 2594 câu trả lời
Được đăng

Giải pháp được chọn

John99 said

We are in a situation where continual changes are being made by both Mozilla & YouTube and some of these changes may be version & OS specific with regard to Firefox.

YouTube may be experimenting with different default players for different browsers and operating systems. I have both Firefox 36 Beta and Firefox 35 installed on the same Windows 7 computer. Back on January 31, the HTML5 player was the default for me in Firefox 36 Beta, while in Firefox 35.0.1 the Flash plugin was used. The other day, HTML5 was the default for both Firefox 35 and Firefox 36 Beta (the YouTube Flash Video Player add-on suggested by cor-el was the best fix I could find).

Today, Flash is being used on both Firefox 36 Beta 9 AND Firefox 35.0.1 even after removing the add-on, as well as in fresh new profiles. Also, https://www.youtube.com/html5 reports "The default player is currently used" with a blue button, "Request the HTML5 player" just as shown in the screenshot attached to this post.

Here are the test videos I used today: https://www.youtube.com/watch?v=BSqb6DvyGDs https://www.youtube.com/watch?v=u-nkRBlqHzA


By the way, "Ask to Activate" is working for me in both Firefox 35 and 36 .... I just have to reload the page sometimes, which was the workaround reported in /questions/1042082.

''John99 [[#answer-692471|said]]'' <blockquote> We are in a situation where continual changes are being made by both Mozilla & YouTube and some of these changes may be version & OS specific with regard to Firefox. </blockquote> YouTube may be experimenting with different default players for different browsers and operating systems. I have both Firefox 36 Beta and Firefox 35 installed on the same Windows 7 computer. Back on January 31, the HTML5 player was the default for me in Firefox 36 Beta, while in Firefox 35.0.1 the Flash plugin was used. The other day, HTML5 was the default for both Firefox 35 and Firefox 36 Beta (the [https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ YouTube Flash Video Player] add-on suggested by cor-el was the best fix I could find). Today, Flash is being used on both Firefox 36 Beta 9 AND Firefox 35.0.1 even after removing the add-on, as well as in fresh new profiles. Also, https://www.youtube.com/html5 reports "The default player is currently used" with a blue button, "Request the HTML5 player" just as shown in the [https://support.cdn.mozilla.net/media/uploads/images/2015-02-16-12-49-09-44a50f.png screenshot] attached to [https://support.mozilla.org/en-US/questions/1044212#answer-691523 this post]. Here are the test videos I used today: https://www.youtube.com/watch?v=BSqb6DvyGDs https://www.youtube.com/watch?v=u-nkRBlqHzA ----- <sub>By the way, "Ask to Activate" is working for me in both Firefox 35 and 36 .... I just have to reload the page sometimes, which was the workaround reported in [/questions/1042082]. </sub>

Người tạo câu hỏi

John99 said

You may not like the method suggested but at least they serve as troubleshooting methods showing what may be the problem. The fact that the add-ons may be easily enabled and disabled allows comparison & testing in the alternative states.

I am sorry. I just didn't want a temporary workaround or put extra stuff on browser. But I understood you. I shall try to apply future workarounds just to test. ______________________________________________________________________________

I am not sure why things may be changing for you now.

You guessed it with your last para and AliceWyman explained it later on his post. ______________________________________________________________________________

By the way, "Ask to Activate" is working for me in both Firefox 35 and 36 .... I just have to reload the page sometimes, which was the workaround reported in /questions/1042082.

Thanks for that follow up thread. Guess, I am not alone with the problem and that explains why I had to refresh the page. That should be considered as a bug though. ______________________________________________________________________________ Now, that everything is getting clear to me as to who is responsible for this problem, I am not sure if I could remain stubborn to use flash exclusively in youtube. But I could very well wish that firefox would help us keep both the options open to use until flash is altogether ditched. An option to control the player just like flash would also be nice i.e ask to activate. There are some notorious websites that plays flash videos without permission and I am afraid they might use html5 to do the same.

So, should this thread be closed?

''John99 [[#answer-692471|said]]'' <blockquote> You may not like the method suggested but at least they serve as troubleshooting methods showing what may be the problem. The fact that the add-ons may be easily enabled and disabled allows comparison & testing in the alternative states.</blockquote> I am sorry. I just didn't want a temporary workaround or put extra stuff on browser. But I understood you. I shall try to apply future workarounds just to test. ______________________________________________________________________________ <blockquote> I am not sure why things may be changing for you now. </blockquote> You guessed it with your last para and AliceWyman explained it later on his post. ______________________________________________________________________________ <blockquote>By the way, "Ask to Activate" is working for me in both Firefox 35 and 36 .... I just have to reload the page sometimes, which was the workaround reported in /questions/1042082. </blockquote> Thanks for that follow up thread. Guess, I am not alone with the problem and that explains why I had to refresh the page. That should be considered as a bug though. ______________________________________________________________________________ Now, that everything is getting clear to me as to who is responsible for this problem, I am not sure if I could remain stubborn to use flash exclusively in youtube. But I could very well wish that firefox would help us keep both the options open to use until flash is altogether ditched. An option to control the player just like flash would also be nice i.e ask to activate. There are some notorious websites that plays flash videos without permission and I am afraid they might use html5 to do the same. So, should this thread be closed?
AliceWyman
  • Moderator
240 giải pháp 2594 câu trả lời
Được đăng

Ѕeeкɘя said

So, should this thread be closed?

Is Firefox is now using the Flash Player for you on YouTube? If so, you should mark a reply (even your own) as "solves the problem" .

I checked mozillazine and there's a similar topic where people have posted about YouTube changing the default player to HTML5 then, within the last two days, back to Flash, if you want to read through it: http://forums.mozillazine.org/viewtopic.php?f=38&t=2914601

''Ѕeeкɘя [[#answer-692619|said]]'' <blockquote>So, should this thread be closed? </blockquote> Is Firefox is now using the Flash Player for you on YouTube? If so, you should mark a reply (even your own) as "solves the problem" . I checked mozillazine and there's a similar topic where people have posted about YouTube changing the default player to HTML5 then, within the last two days, back to Flash, if you want to read through it: http://forums.mozillazine.org/viewtopic.php?f=38&t=2914601

Người tạo câu hỏi

Yes, Firefox is currently using Flash Player on YouTube. However, the bug discussed in this thread /questions/1042082 exist. Refreshing needs to be done. Not a big problem though.

I would mark one of the reply as solved. But I hope, developers (if you including others here are one) take note of it and possibly do the needful.

Thanks all for sharing your valuable time and resources.

Regards Seeker.

Yes, Firefox is currently using Flash Player on YouTube. However, the bug discussed in this thread [/questions/1042082] exist. Refreshing needs to be done. Not a big problem though. I would mark one of the reply as solved. But I hope, developers (if you including others here are one) take note of it and possibly do the needful. Thanks all for sharing your valuable time and resources. Regards Seeker.