X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

YouTube functions not working properly!

Được đăng

So in the past 2-3 weeks Firefox has been really been frustrating to deal with on YouTube.

These are the issues I am having: - When in "My Subscriptions" and trying to hide videos from clicking the arrow in the top right corner, nothing happens. - Using the "Watch Later" button that appears in the lower right corner of the thumbnail does not work. - When in "Watch Later" list cannot rearrange videos by dragging on the three dots on the left of the video tab. - When in "Watch Later" list cannot remove videos by clicking the x in the top right corner of the video tab.

Yesterday only it worked for like a few minutes and then it was back to not working. Is anybody else experiencing these issues? In Chrome it works without a problem. I've been even considering moving to Chrome cause of this which I would hate to do. I thought the new update that came out today would fix this but nope, still nothing.

And on the side note: When will Firefox implement 60 FPS video playing on YouTube? Come on now Mozilla, you're slacking.

So in the past 2-3 weeks Firefox has been really been frustrating to deal with on YouTube. These are the issues I am having: - When in "My Subscriptions" and trying to hide videos from clicking the arrow in the top right corner, nothing happens. - Using the "Watch Later" button that appears in the lower right corner of the thumbnail does not work. - When in "Watch Later" list cannot rearrange videos by dragging on the three dots on the left of the video tab. - When in "Watch Later" list cannot remove videos by clicking the x in the top right corner of the video tab. Yesterday only it worked for like a few minutes and then it was back to not working. Is anybody else experiencing these issues? In Chrome it works without a problem. I've been even considering moving to Chrome cause of this which I would hate to do. I thought the new update that came out today would fix this but nope, still nothing. And on the side note: When will Firefox implement 60 FPS video playing on YouTube? Come on now Mozilla, you're slacking.

Giải pháp được chọn

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Battlelog Game Launcher (2.6.2)
  • Battlelog Game Launcher (2.5.1)
  • Google Update
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 16.0 r0
  • 5.1.31211.0
  • VLC media player Web Plugin 2.1.3
  • iTunes Detector Plug-in

Ứng dụng

  • Firefox 35.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

Tiện ích mở rộng

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Download Manager (S3) 3.08 (s3download@statusbar)
  • InstantFox 2.9.11 (searchy@searchy)
  • ProxMate - Proxy on steroids! 2.3.3 (jid1-QpHD8URtZWJC2A@jetpack)
  • Snap Links Plus 2.4.2 (snaplinks@snaplinks.mozdev.org)
  • YouTube High Definition 35.1 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})
  • Avast Online Security 10.0.2502.149 (wrc@avast.com) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: NVIDIA GeForce GTX 970
  • adapterDescription2:
  • adapterDeviceID: 0x13c2
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterSubsysID: 31601462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-13-2014
  • driverDate2:
  • driverVersion: 9.18.13.4709
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 970 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
cor-el
  • Top 10 Contributor
  • Moderator
17565 giải pháp 158874 câu trả lời
Được đăng

Câu trả lời hữu ích

You need a Firefox version that has enabled MSE (Media Source Extensions) to make YouTube offer 60 FPS. This works by default in the current 36 beta release that has a specific pref for YouTube (media.mediasource.youtubeonly) to allow this and you can see 1080p60 and 720p60 being available.

You can enable MSE in the current release, but this may not always work properly. MSE is still disabled in the current beta, so the YouTube HTML5 settings page still shows that MSE is disabled.

I don't know how "My Subscriptions" and "Watch Later" work. You can try to clear the YouTube cookies and also check whether Flash or an HTML5 media player is used to see if that has effect.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

.

You need a Firefox version that has enabled MSE (Media Source Extensions) to make YouTube offer 60 FPS. This works by default in the current 36 beta release that has a specific pref for YouTube (media.mediasource.youtubeonly) to allow this and you can see 1080p60 and 720p60 being available. *https://www.mozilla.org/en-US/firefox/beta/ *https://www.mozilla.org/en-US/firefox/beta/all/ You can enable MSE in the current release, but this may not always work properly. MSE is still disabled in the current beta, so the YouTube HTML5 settings page still shows that MSE is disabled. * http://www.youtube.com/html5/ I don't know how "My Subscriptions" and "Watch Later" work. You can try to clear the YouTube cookies and also check whether Flash or an HTML5 media player is used to see if that has effect. Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" .

Được chỉnh sửa bởi cor-el vào

Người tạo câu hỏi

I tried clearing the cache and cookies but the issue still remains.

On the FPS note: I don't really want to use beta. I'm guessing it will eventually arrive to the stable release. Hopefully sooner than later.

I tried clearing the cache and cookies but the issue still remains. On the FPS note: I don't really want to use beta. I'm guessing it will eventually arrive to the stable release. Hopefully sooner than later.
FredMcD
  • Top 10 Contributor
4266 giải pháp 59807 câu trả lời
Được đăng

You may have a corrupt cookies.sqlite file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file. Then rename or delete it. Restart Firefox.


Separate Issue; Your System Details shows;

Installed Plug-ins

Battlelog Game Launcher (2.6.2) Battlelog Game Launcher (2.5.1)

Having more than one version of a program may cause issues.

You may have a corrupt '''cookies.sqlite''' file. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''cookies.sqlite''' file. Then rename or delete it. Restart Firefox. -------------------- Separate Issue; Your System Details shows; Installed Plug-ins Battlelog Game Launcher (2.6.2) Battlelog Game Launcher (2.5.1) Having more than one version of a program may cause issues.

Được chỉnh sửa bởi FredMcD vào

Người tạo câu hỏi

Deleting cookies.sqlite didn't help.

I doubt that deleting Battlelog Game Launcher will help.

Deleting cookies.sqlite didn't help. I doubt that deleting Battlelog Game Launcher will help.

Người tạo câu hỏi

Bump! Anybody?

Bump! Anybody?
FredMcD
  • Top 10 Contributor
4266 giải pháp 59807 câu trả lời
Được đăng

FredMcD said

Separate Issue; Your System Details shows; Installed Plug-ins Battlelog Game Launcher (2.6.2) Battlelog Game Launcher (2.5.1) Having more than one version of a program may cause issues.
''FredMcD [[#answer-682683|said]]'' <blockquote> Separate Issue; Your System Details shows; Installed Plug-ins Battlelog Game Launcher (2.6.2) Battlelog Game Launcher (2.5.1) '''Having more than one version of a program may cause issues.''' </blockquote>

Người tạo câu hỏi

Removing Battlelog Game Launcher didn't help. Still have the problem.

Removing Battlelog Game Launcher didn't help. Still have the problem.
FredMcD
  • Top 10 Contributor
4266 giải pháp 59807 câu trả lời
Được đăng

While Battlelog Game may not be causing this issue, it can still led to other problems. Just ask any programer.

Security issue: Update your Flash Player v16.0.0.296
https://www.adobe.com/products/flashplayer/distribution3.html


Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. Including Java (not JavaScript).


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow. Including Java (not JavaScript).

While Battlelog Game may not be causing this issue, it can still led to other problems. Just ask any programer. Security issue: Update your Flash Player '''v16.0.0.296<br>https://www.adobe.com/products/flashplayer/distribution3.html''' -------------------- Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' Including Java (not JavaScript). -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' Including Java (not JavaScript).

Người tạo câu hỏi

Don't know what issues Battlelog Game Launcher has but how else am I supposed to play Battlefield... I updated the Flash Player. All my plugins are set to Ask, a couple Always. Only Java Deployment Toolkit is set to Never (Disabled) since it says "Known to be vulnerable. Use with Caution." All permissions are set to Use Default. Switching everything to Ask, and Allow didn't change anything.

Don't know what issues Battlelog Game Launcher has but how else am I supposed to play Battlefield... I updated the Flash Player. All my plugins are set to Ask, a couple Always. Only Java Deployment Toolkit is set to Never (Disabled) since it says "Known to be vulnerable. Use with Caution." All permissions are set to Use Default. Switching everything to Ask, and Allow didn't change anything.
FredMcD
  • Top 10 Contributor
4266 giải pháp 59807 câu trả lời
Được đăng

Câu trả lời hữu ích

rade155 said

Don't know what issues Battlelog Game Launcher has but how else am I supposed to play Battlefield...

Remove both programs, then reinstall the current version.


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

''rade155 [[#answer-683550|said]]'' <blockquote> Don't know what issues Battlelog Game Launcher has but how else am I supposed to play Battlefield... </blockquote> Remove both programs, then reinstall the current version. ------------------------ '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? ----------------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Người tạo câu hỏi

That is what I did with Battlelog. Ok so starting Firefox in Safe Mod solved the issue. I did not need to turn off Use Hardware Acceleration for it to work. I could hide videos in YouTube without it turned off. So we are getting somewhere.

That is what I did with Battlelog. Ok so starting Firefox in Safe Mod solved the issue. I did not need to turn off Use Hardware Acceleration for it to work. I could hide videos in YouTube without it turned off. So we are getting somewhere.
cor-el
  • Top 10 Contributor
  • Moderator
17565 giải pháp 158874 câu trả lời
Được đăng

Giải pháp được chọn

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Người tạo câu hỏi

So I did just that and it looks like it is Adblock Plus. After disabling it, YouTube functions work again. But this is very unfortunate as I cannot use Firefox without Adblock Plus. I tried reinstalling it but it does not help. Is there any way to make it work?

So I did just that and it looks like it is Adblock Plus. After disabling it, YouTube functions work again. But this is very unfortunate as I cannot use Firefox without Adblock Plus. I tried reinstalling it but it does not help. Is there any way to make it work?
cor-el
  • Top 10 Contributor
  • Moderator
17565 giải pháp 158874 câu trả lời
Được đăng

Try to ask advice at the Adblock Plus forum.

Try to ask advice at the Adblock Plus forum. * https://adblockplus.org/forum/

Người tạo câu hỏi

Alright I will do that. Thanks for all the help guys.

Alright I will do that. Thanks for all the help guys.
FredMcD
  • Top 10 Contributor
4266 giải pháp 59807 câu trả lời
Được đăng

Go to the web site. Click the arrow next to the AdBlock icon. In the menu, select Disable On WebSite

Go to the web site. Click the arrow next to the AdBlock icon. In the menu, select '''Disable On ''WebSite'''''

Người tạo câu hỏi

Yeah but Adblock is very much most important on YouTube.

Yeah but Adblock is very much most important on YouTube.