X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

search bar stopped working

Được đăng

since the last FF update (35), the search bar stopped working.

since the last FF update (35), the search bar stopped working.

Giải pháp được chọn

You say it works in safe mode then you have to try your add-ons till you find which one is not working.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Citrix Online App Detector Plugin
  • Facebook Video Calling Plugin
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Google Update
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151
  • 5.1.30514.0
  • Windows Activation Technologies Plugin for Mozilla

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

Thông tin chi tiết

user669794 59 giải pháp 672 câu trả lời
Được đăng

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Open Firefox ''Options'' window (''Preferences'' on Mac or Linux) as follows: #* In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]] and select ''Options'' for Windows or ''Preferences'' on Mac or Linux. #* In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. #In the Firefox Options (or Preferences) window, click the ''Advanced'' tab, then select ''General''. #In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. #Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

Người tạo câu hỏi

Disabling graphics hardware acceleration did not solve the problem. My graphics drivers are up-to-date. Restarting FF in safe mode got the search bar to work again, but a regular restart brought the problem back. Obviously I don't want to work in safe mode all the time... Any ideas? Thanks!

Disabling graphics hardware acceleration did not solve the problem. My graphics drivers are up-to-date. Restarting FF in safe mode got the search bar to work again, but a regular restart brought the problem back. Obviously I don't want to work in safe mode all the time... Any ideas? Thanks!
user669794 59 giải pháp 672 câu trả lời
Được đăng

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: After resetting Firefox, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Reset Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Reset Firefox" that looks like this: Button reset . Click on it.
  3. Firefox will close and reset. After it is done, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Hello, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' After resetting Firefox, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Reset Firefox – easily fix most problems]] article for more information. To Reset Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Reset Firefox" that looks like this: [[Image:Button reset]]. Click on it. #Firefox will close and reset. After it is done, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen. Did this fix the problem? Please report back to us! Thank you.

Người tạo câu hỏi

I honestly prefer not to do a reset. I'll wait and see if the next FF upgrade will solve the problem. Thanks anyway.

I honestly prefer not to do a reset. I'll wait and see if the next FF upgrade will solve the problem. Thanks anyway.
Gnospen 233 giải pháp 1920 câu trả lời
Được đăng

Giải pháp được chọn

You say it works in safe mode then you have to try your add-ons till you find which one is not working.

You say it works in safe mode then you have to try your add-ons till you find which one is not working.

Người tạo câu hỏi

I updated a few addons, problem solved! Thanks everybody!

I updated a few addons, problem solved! Thanks everybody!
Rrtid54 1 giải pháp 12 câu trả lời
Được đăng

Câu trả lời hữu ích

in my case, FF 35.0, Win7 Home SP1, updating Tab Mix Plus to Version 0.4.1.6, corrected the problem. my troubleshooting, other than disabling hardware acceleration for graphics, was to disable add-ons and restart as needed; when search started working again, I re-enabled add-ons one by one, until search stopped working, narrowing it down to Tab Mix Plus.

hth, Rick

in my case, FF 35.0, Win7 Home SP1, updating Tab Mix Plus to Version 0.4.1.6, corrected the problem. my troubleshooting, other than disabling hardware acceleration for graphics, was to disable add-ons and restart as needed; when search started working again, I re-enabled add-ons one by one, until search stopped working, narrowing it down to Tab Mix Plus. hth, Rick
lwfrederick 0 giải pháp 4 câu trả lời
Được đăng

orengreen said

since the last FF update (35), the search bar stopped working.

I am having this problem- when I put it in safe mode the problem is not corrected. What do I do?

''orengreen [[#question-1041925|said]]'' <blockquote> since the last FF update (35), the search bar stopped working. </blockquote> I am having this problem- when I put it in safe mode the problem is not corrected. What do I do?
Rrtid54 1 giải pháp 12 câu trả lời
Được đăng

lwfrederick said

orengreen said
since the last FF update (35), the search bar stopped working. was the problem

I am having this problem- when I put it in safe mode the problem is not corrected. What do I do?

other than running in safe mode, have you tried the other solutions listed above? my troubleshooting approach was to disable all add-ons, verify that the search then worked, and then re-enable the add-ons one at a time, testing after each one. I finally found that, in my case, Tab Mix Plus was the problem, and needed to be updated.

hth, Rick

''lwfrederick [[#answer-709095|said]]'' <blockquote> ''orengreen [[#question-1041925|said]]'' <blockquote> since the last FF update (35), the search bar stopped working. was the problem </blockquote> I am having this problem- when I put it in safe mode the problem is not corrected. What do I do? </blockquote> other than running in safe mode, have you tried the other solutions listed above? my troubleshooting approach was to disable all add-ons, verify that the search then worked, and then re-enable the add-ons one at a time, testing after each one. I finally found that, in my case, Tab Mix Plus was the problem, and needed to be updated. hth, Rick
lwfrederick 0 giải pháp 4 câu trả lời
Được đăng

I do not currently have an add-ons enabled. So there aren't any to disable. Under add-ons, extensions it simply says "You don't have any add-ons of this type installed"

I do not currently have an add-ons enabled. So there aren't any to disable. Under add-ons, extensions it simply says "You don't have any add-ons of this type installed"
lwfrederick 0 giải pháp 4 câu trả lời
Được đăng

I have tried uninstalling, restarting the computer, and re-installing Firefox.

I have tried uninstalling, restarting the computer, and re-installing Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17584 giải pháp 159079 câu trả lời
Được đăng

Câu trả lời hữu ích

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.


You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder.

If not then you need to reinstall Firefox. You can find the full version of the current Firefox 36.0.4 release in all languages and for all operating systems here:

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the currently used Firefox profile folder:

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window. ---- You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder. If not then you need to reinstall Firefox. You can find the full version of the current Firefox 36.0.4 release in all languages and for all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.
lwfrederick 0 giải pháp 4 câu trả lời
Được đăng

cor-el said

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder.

If not then you need to reinstall Firefox. You can find the full version of the current Firefox 36.0.4 release in all languages and for all operating systems here:

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the currently used Firefox profile folder:

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

Thank you- the disabling the compatibility mode worked!

''cor-el [[#answer-709168|said]]'' <blockquote> Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window. ---- You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder. If not then you need to reinstall Firefox. You can find the full version of the current Firefox 36.0.4 release in all languages and for all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder. </blockquote> Thank you- the disabling the compatibility mode worked!
jscher2000
  • Top 10 Contributor
8797 giải pháp 71955 câu trả lời
Được đăng

Hi lwfrederick, many Windows XP users are reporting that they had selected Windows 98 compatibility to resolve some other issue, and now it is crippling Firefox 36. If you can recall where you got that (bad) advice, please let us know.

Hi lwfrederick, many Windows XP users are reporting that they had selected Windows 98 compatibility to resolve some other issue, and now it is crippling Firefox 36. If you can recall where you got that (bad) advice, please let us know.
kyleamc 0 giải pháp 2 câu trả lời
Được đăng

jscher2000 said

Hi lwfrederick, many Windows XP users are reporting that they had selected Windows 98 compatibility to resolve some other issue, and now it is crippling Firefox 36. If you can recall where you got that (bad) advice, please let us know.

https://support.mozilla.org/en-US/questions/1009562

''jscher2000 [[#answer-709188|said]]'' <blockquote> Hi lwfrederick, many Windows XP users are reporting that they had selected Windows 98 compatibility to resolve some other issue, and now it is crippling Firefox 36. If you can recall where you got that (bad) advice, please let us know. </blockquote> https://support.mozilla.org/en-US/questions/1009562
jscher2000
  • Top 10 Contributor
8797 giải pháp 71955 câu trả lời
Được đăng

Hi kyleamc, maybe we can "demote" that solution somehow and replace it with a better one.

Hi kyleamc, maybe we can "demote" that solution somehow and replace it with a better one.
kyleamc 0 giải pháp 2 câu trả lời
Được đăng

Hello jscher2000,

It appears that the solution for that question (1009562) was "demoted" by the moderator today. The fix for me for this question (1041925) was what cor-el suggested on 3/25/15 at 3:32 PM (above)(Firefox was running in compatibility mode).

Hello jscher2000, It appears that the solution for that question (1009562) was "demoted" by the moderator today. The fix for me for this question (1041925) was what cor-el suggested on 3/25/15 at 3:32 PM (above)(Firefox was running in compatibility mode).
FF RSC 0 giải pháp 10 câu trả lời
Được đăng

Except for re installing I think I tried all the suggestions here. I'm using Firefox 38.0.5 on Win7 Pro SP 1. Just for grins I tried the search in IE. It worked in IE. Not in Firefox. I'm pretty sure it worked yesterday.

Except for re installing I think I tried all the suggestions here. I'm using Firefox 38.0.5 on Win7 Pro SP 1. Just for grins I tried the search in IE. It worked in IE. Not in Firefox. I'm pretty sure it worked yesterday.
jscher2000
  • Top 10 Contributor
8797 giải pháp 71955 câu trả lời
Được đăng

Hi FF RSC, are you saying that your search bar does not work in Safe Mode either?

If you haven't tried that, here's how:

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If you have the same problem in Safe Mode, then the cause of your issue is different than the one in this solved thread. I suggest starting a new question at the following link. Scroll down past the suggestions to continue submitting your question: https://support.mozilla.org/questions/new/desktop/fix-problems

Hi FF RSC, are you saying that your search bar does not work in Safe Mode either? If you haven't tried that, here's how: ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). If you have the same problem in Safe Mode, then the cause of your issue is different than the one in this solved thread. I suggest starting a new question at the following link. Scroll down past the suggestions to continue submitting your question: https://support.mozilla.org/questions/new/desktop/fix-problems
FF RSC 0 giải pháp 10 câu trả lời
Được đăng

Yes that is exactly what I'm saying. I just tried again to make sure. I will start a new thread as you suggested.

Yes that is exactly what I'm saying. I just tried again to make sure. I will start a new thread as you suggested.