Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Why is silverlight being blocked ver 34

  • 4 trả lời
  • 10 gặp vấn đề này
  • 12697 lượt xem
  • Trả lời mới nhất được viết bởi Fred

more options

I have Silverlight installed, the latest version, installed Click to Play and it reports Silverlight plugin is NULL, so it will not run. Do I need to go back to an older version?

Giải pháp được chọn

One possible reason for an installed plugin not to apppear on the Add-ons page is if Firefox is set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page again, success?

If Firefox is set to scan but still does not find Silverlight Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins. As a side effect, any plugins you have disabled on the Add-ons page probably will be re-enabled, so you'll need to go back to that page one more time.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is Silverlight finally there?


If all else fails, you could check your installation by visiting the following page in Firefox:

http://www.microsoft.com/getsilverlight/get-started/install/default.aspx

Look for a purple "Click to Install" button.

Đọc câu trả lời này trong ngữ cảnh 👍 3

Tất cả các câu trả lời (4)

more options

Your "More System Details" doesn't show the usual entry for Silverlight, which is a 4-part version number starting with 5. Can you make sure it is not set to "Never Activate"?

You can open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then make sure Silverlight is set to "Always Activate" or, if you want to give sites permission on a case-by-case basis, "Ask to Activate."

I don't use the Click-to-Play Manager extension, so if that takes over this setting, you may need to go into its settings.

While you're on the Add-ons page, in the left column, click Extensions. Then check whether that one has an Options button where you can make sure Silverlight isn't completely blocked.

Any luck?

Được chỉnh sửa bởi jscher2000 vào

more options

Silverlight does not show up in my add-ons.

When I try to update Silverlight it shows I have the latest version.

When I go to Click to Play Manager the website that wants it "www.freestockcharts.com" has "null" under the Plugin heading.

It is like the plugin is not being loaded. I have been using the website for over a year, this just happened lately.

more options

Giải pháp được chọn

One possible reason for an installed plugin not to apppear on the Add-ons page is if Firefox is set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page again, success?

If Firefox is set to scan but still does not find Silverlight Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins. As a side effect, any plugins you have disabled on the Add-ons page probably will be re-enabled, so you'll need to go back to that page one more time.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is Silverlight finally there?


If all else fails, you could check your installation by visiting the following page in Firefox:

http://www.microsoft.com/getsilverlight/get-started/install/default.aspx

Look for a purple "Click to Install" button.

more options

Stupid me, I keep forgetting I am dealing with a genuine Microsoft product, written by genuine Microsoft engineers. Not only close all the windows, but uninstall and reinstall the offender. That finally cured the problem.

All the good tips you offered were either set correctly as you said they should be or didn't fix the problem.

But in the end you got me to where I needed to be.

Thanks, Fred