Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

YouTube HTML5 player problems (recent)

  • 5 trả lời
  • 18 gặp vấn đề này
  • 25351 lượt xem
  • Trả lời mới nhất được viết bởi gogogadgetpants

more options

Hi. Recently, playing YouTube content using the HTML5 player has become impossible due to playback problems (sound/video are choppy, content loading becomes extremely slow, browser becomes unresponsive).

Playback with Chrome, no issues. Reverting to Flash playback, no issues. Browser cache has been wiped, didn't fix the issue.

So it seems to be a problem with one of the last Firefox updates or perhaps some recent change on the YT site. Any ideas?

  • Sorry, I just noticed there's another topic further below similar to this one. If at all possible, feel free to merge.

Được chỉnh sửa bởi gogogadgetpants vào

Giải pháp được chọn

The Cisco OpenH264 plugin is currently only used with WebRTC and not for playing videos.

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • default toolbar layout is used
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (5)

more options

The issue may be because of your corrupted cookie file (cookies.sqlite)

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

You can also check if DOM Storage is enabled.

more options

Sorry, unfortunately, that didn't solve the problem (deleted all cookie-related files, DOM storage is enabled in the config).

Any other ideas?

more options

Running without add-ons solves the issue. I'm thinking maybe this is the problem?

http://blogs.cisco.com/collaboration/ciscos-openh264-now-part-of-firefox/

more options

Giải pháp được chọn

The Cisco OpenH264 plugin is currently only used with WebRTC and not for playing videos.

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • default toolbar layout is used
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
more options

Hello, thanks for your reply!

Disabling hardware acceleration seems to have solved the problem.