Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

.swf files opening issues

  • 6 trả lời
  • 19 gặp vấn đề này
  • 20374 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Upon opening .swf files I get open or save as options. I have tried all the fixes I could locate nothing is helping. I have even tried to reinstall the flash player program. I can play the files from the site but after downloading them I can no longer play the files from my desktop without getting the open or save as options like it is trying to re-download the same file. This repeats non-stop. I have checked the options in tools however I can't seem to change or reset any of the things for .swf files. One of the options for the file targets shockwave flash, which I have installed but the other says always ask. I can't change it to firefox, if I set it to IE it repeats the open or save as options like it does in firefox. I can't seem to locate any program to open the file in firefox.

Before the last few updates I use to just be able to click on a .swf file and it'd open in firefox without issue. I'm not sure what has changed within the last few updates but now I can't open .swf files unless I do so from the site I downloaded the file from.

Giải pháp được chọn

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (6)

more options

Hello,

If your settings for SWF files are set correctly in your options, then it is probably the swf files:

  • Tools (or New Fx Menu) > Options > Applications

Some swf files probably have checks to make sure that they are run on the correct website, etc. and if they are not, then some other event, such as the one you are facing, happens in order to protect them from being run in scenarios they weren't intended to by the author.

Được chỉnh sửa bởi CoryMH vào

more options

Giải pháp được chọn

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

@ CoryMH, the only things located in the content tab of the options is the following: Block pop ups, Fonts& colors, and languages. There is no options within the content tab of tools>options>content. Even though your advice was not helpful to me in any way I still thank you for trying to help resolve this matter.

@ cor-el, I have just managed to find the mimeTypes.rdf file took me a few hours as it was not where those links said it would be. For my system it was C:/users/username/appdata(hidden folder)/local/mozilla Sadly the links said it's be %APPDATA%\mozilla\ upon which is an invalid address on my windows 7 system. Not sure why it's different but I found it. I am hoping now that I located the file that your advice fixes the problem.

Edit 1: cor-el upon restarted after removing the file you mentioned did in fact reset everything. All of my flashes are asking what I want them to open with once more. Upon opening them on Firefox I can see them instead of the open with or save as options. So your advice did indeed work. Thank you.

Được chỉnh sửa bởi SaliosNoctin vào

more options

Sorry, made a typo, I meant check the Applications tab in the Options menu.

more options

CoryMh it happens, however I tried that route. cor-el's advice did help and fix the problem, thanks anyways.

more options

The main profile folder should be in AppData\Roaming and not in AppData\Local. The latter is where the disk cache and other caches should be and not the main profile folder with your personal data.

Did you ever create a profile yourself with using the Profile Manager?