Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Chủ đề này đã đóng và được lưu lại. Vui lòng hỏi một câu hỏi mới nếu bạn cần giúp đỡ.

Shockwave Flash is CONSTANTLY not responding and crashing

  • 56 trả lời
  • 646 gặp vấn đề này
  • 81 lượt xem
  • Trả lời mới nhất được viết bởi NoahSUMO

more options

Hello there,

I've had this problem for a long time, and I've done most everything suggested in other forums regarding this matter. I've disabled "disabled protected mode, disabled hardware acceleration, made sure everything is updated, and nothing works. Unfortunately, this makes Firefox so unusable that I've had to switch to another browser for the time being, but it's having it's own issues. Very frustrating! I like Firefox and would like to have it working, but this "shockwave flash plugin" problem has been a persistent problem for the last year.

I've seen many other users who have not been able to fix the problem via the above suggestions, so--what's the verdict? Is there something else I can try?

Cheers

Hello there, I've had this problem for a long time, and I've done most everything suggested in other forums regarding this matter. I've disabled "disabled protected mode, disabled hardware acceleration, made sure everything is updated, and nothing works. Unfortunately, this makes Firefox so unusable that I've had to switch to another browser for the time being, but it's having it's own issues. Very frustrating! I like Firefox and would like to have it working, but this "shockwave flash plugin" problem has been a persistent problem for the last year. I've seen many other users who have not been able to fix the problem via the above suggestions, so--what's the verdict? Is there something else I can try? Cheers

Giải pháp được chọn

I fixed it. I found a Flash bypass alternative extension in Firefox Add-ons, called "Video WithOut Flash" https://addons.mozilla.org/en-US/firefox/addon/video-without-flash/ installed it, and disabled Flash. No more problems. I know, sounds to good to be true, but there it is.

Now, if only there was a more solid alternative for Flash, or heaven forbid, Adobe get's there sh*t together.

Cheers--I hope this fix helps a few people!

Đọc câu trả lời này trong ngữ cảnh 👍 33

Tất cả các câu trả lời (20)

more options

Are you sure this isn't a problem with Flash Player? So many people appear to have this problem--however on second thought, this does NOT happen in Chrome, so there is a compatibility issue here somewhere!

more options

Right now I am cruising this forum on Adobe--and this definitely seems to be a problem between Firefox and Adobe Shockwave flash. Many thousands of people have seemingly tried many fixes to no avail.

Cheers

more options
more options

Chrome uses a custom player (Pepper Flash), IE uses an ActiveX control, and Firefox uses a "Netscape-style" plugin. So it's something about Flash in Firefox, but it's very hard to use experience in other browsers to figure out where the problem lies...

Some users have run into problems when disabling Flash local storage (Flash local storage objects or LSOs are sometimes called Flash cookies or supercookies). However, I don't know whether that is relevant to YouTube. You can manage your storage setting on this page (Macromedia is the original developer of Flash, so this site is legit):

more options

What should I do to the settings?

Thanks!

more options

I think the default is to allow up to 100KB of storage for any site. If you have changed this setting, you could try restoring the default.

You also could go to the second page and flush what has been stored so far. This could negatively affect Flash games, since useful objects might be stored locally, but most of the other data probably is just for tracking. Also, please note that this is cross-browser storage, so if you are actively using Flash in a different browser, something strange could happen.

more options

Nope, I've certainly never changed it, because I has no idea that was an option until today! So, I've never touched it. Hmm. I'm looking into other possibilities with extensions--it was suggested that Real Player has issues with Shockwave Flash, but I don't have Real Player, just VLC. So, I'm updating that and if that doesn't do anything, I'll disable it. If that doesn't do anything...well, I"m going to have to install another browser, unfortunately. Firefox is pretty useless to me if this issue persists.

Cheers

more options

FYI: I have just upgraded Firefox to the new BETA version, and so far this issue is non existent in it. I will let you know if this winds up being the cure to Shockwave Flash problems.

Cheers!

more options

Well,

Sadly, everything was great in the BETA update for about a day...and then the hanging and freezing and error messages came back. :( Seriously, I wish Mozilla would address this issue once and for all, as it is difficult to solve and makes using the browser at the very least irritating, and at the most, unusable. Too bad.

Cheers.

more options

Giải pháp được chọn

I fixed it. I found a Flash bypass alternative extension in Firefox Add-ons, called "Video WithOut Flash" https://addons.mozilla.org/en-US/firefox/addon/video-without-flash/ installed it, and disabled Flash. No more problems. I know, sounds to good to be true, but there it is.

Now, if only there was a more solid alternative for Flash, or heaven forbid, Adobe get's there sh*t together.

Cheers--I hope this fix helps a few people!

more options

I have found a good solution to this that seems to work every time:

1) Close all Firefox browsers.

2) Uninstall Flash from the Add / Remove Programs in Control Panel.

3) Download the Adobe Flash Extended support release from halfway down this page... Flash extended support release

The extended support release has all the security updates of the newest release but with a far higher compatibility level with Firefox.

Note when installing, make sure you unselect automatic updates otherwise it will be overwritten with the newest version.

4) Restart Firefox and you are all done.

Được chỉnh sửa bởi Ph001 vào

more options

Ah, found the solution. For me, at least, you can consider this one solved. I disabled the extension "One Click You Tube Video Downloader 2.3.7" and all Shockwave and Flash Plugin issues went away. This also happened with another video downloader program I had tried. Does anyone have a Firefox compatible video downloader, as in one that does not conflict? Two that currently appear in the Firefox "Find Add Ons" conflict and fail miserably.

more options

gforcewarp9 said

Hello there, I've had this problem for a long time, and I've done most everything suggested in other forums regarding this matter. I've disabled "disabled protected mode, disabled hardware acceleration, made sure everything is updated, and nothing works. Unfortunately, this makes Firefox so unusable that I've had to switch to another browser for the time being, but it's having it's own issues. Very frustrating! I like Firefox and would like to have it working, but this "shockwave flash plugin" problem has been a persistent problem for the last year. I've seen many other users who have not been able to fix the problem via the above suggestions, so--what's the verdict? Is there something else I can try? Cheers
more options

Thanks for the post and suggestion. Shockwave is making my computer unusable. Would it work to go back to an older version of Firefox until the problem is fixed?

more options

I don't know because I have tried all the solutions, settings changes,removal tools and virus scans too. The only thing that made a significant difference, and made Shockwave usable again, was removing/disabling all video down loader add ons.

more options

My fix: Go to http://nightly.mozilla.org/ download 64bit version, no specific place of installation required. Open browser by the 'nightly' icon at your desktop. It opens using cache/history etc of your standard x86 version.

My dell xps 12 usually froze while playing flash games and when i tried stopping youtube videos (with touch screen). Now, after a year.. problems are gone.

Text me if i helped or you need additional info.

Được chỉnh sửa bởi mrOnion vào

more options

i see this is a while ago, but for future users with the same issue, here's the solution: basically, the problem id that it can happen that you run 2 conflicting versions of Shockwave Flash. One is the native one, the version you had probably been running all the time without even noticing. Somewhere along the way though you have picked up a plugin version of Flash, and that now blocks every page that runs Flash for the first 10-20 seconds. While it's a drag to find that out, the fix is extremely easy. Simply go to the menu in the top right corner of Firefox, the menu that looks like 3 horizontal bars, then go to "Add-Ons", and from there to "Plugins", where you then disable the Flash Plugin with the push of a button. Restart Firefox and enjoy your silky smooth high speed browser.

more options

Thank you for the simple fix. Odd that Plug Ins suggests a flawed Flash Plug In at all. Some advertising windows don't display but that is actually good. But why would Mozilla allow such a defective Add On to remain available?

more options

This fix is perfect. Disabling the Firefox Flash Addon and requiring it to ask for permission causes all the embedded advertisements, on every page, to lock up. Selecting Ask For Approval adds one step but makes everything better. They no longer annoy because they no longer appear. Obviously the Firefox Addon was ONLY needed to run their video advertising spots and programs. Videos work perfectly now and never freeze. Mozilla has made a very serious error here.

more options

glad i could have been of assistance, as i myself repeatedly came close to smashing my wireless keyboard over this. as an avid forumite on different sites, who often reloads more than once a minute, this bug was a complete nerve wrecker.

  1. 1
  2. 2
  3. 3