X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Every time I open a new FireFox window or tab Bing opens instead of my home page.

Được đăng

How do I stop Bing from opening everytime I start FireFox, open a new window or tab in FireFox? When FireFox starts I have my options set to open with my homepage.

How do I stop Bing from opening everytime I start FireFox, open a new window or tab in FireFox? When FireFox starts I have my options set to open with my homepage.

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 15.0 r0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • 5.1.30514.0
  • NPWLPG
  • iTunes Detector Plug-in

Ứng dụng

  • Firefox 31.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Tiện ích mở rộng

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Anti-Banner 14.0.0.4939 (anti_banner@kaspersky.com) (không hoạt động)
  • Dangerous Websites Blocker 14.0.0.4939 (content_blocker@kaspersky.com) (không hoạt động)
  • Kaspersky URL Advisor 14.0.0.4939 (url_advisor@kaspersky.com) (không hoạt động)
  • Safe Money 14.0.0.4939 (online_banking@kaspersky.com) (không hoạt động)
  • Virtual Keyboard 14.0.0.4939 (virtual_keyboard@kaspersky.com) (không hoạt động)
  • YouTube Downloader and Converter 3.8 ({b9bfaf1c-a63f-47cd-0829-29526ced3775}) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0152
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 1-22-2014
  • driverDate2:
  • driverVersion: 10.18.10.3412
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Thay đổi cài đặt

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.newtab.url: http://www-search.net/?s=E97ztrpdu03TRS,dc38b92c-1edb-4601-8517-1578b65f18b5,&fnt=1
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • browser.tabs.drawInTitlebar: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Có
cor-el
  • Top 10 Contributor
  • Moderator
17479 giải pháp 157962 câu trả lời
Được đăng

Câu trả lời hữu ích

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.


Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program. ---- Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware

Người tạo câu hỏi

Thank you for your help, I check the target line in the Firefox desktop shortcut (right-click: Properties) and found there was an appended after the path to the Firefox program. I deleted it and Foxfire opened perfect. However, the next time I started up my computer it was back. It keeps adding this http://www-search.net/?s=E97ztrpdu03TRS,dc38b92c-1edb-4601-8517-1578b65f18b5,&pi=1 I ran my Kaspersky but it didn't find anything, I tried running Windows Defender but it is deactivated due to my Kaspersky .

Thank you for your help, I check the target line in the Firefox desktop shortcut (right-click: Properties) and found there was an appended after the path to the Firefox program. I deleted it and Foxfire opened perfect. However, the next time I started up my computer it was back. It keeps adding this http://www-search.net/?s=E97ztrpdu03TRS,dc38b92c-1edb-4601-8517-1578b65f18b5,&pi=1 I ran my Kaspersky but it didn't find anything, I tried running Windows Defender but it is deactivated due to my Kaspersky .
cor-el
  • Top 10 Contributor
  • Moderator
17479 giải pháp 157962 câu trả lời
Được đăng

Giải pháp được chọn

See also; *http://malwaretips.com/blogs/remove-www-search-net-virus/

Người tạo câu hỏi

Thank you. It worked. I did all 5 steps from http://malwaretips.com/blogs/remove-www-search-net-virus/ They were easy to follow and removed everything I couldn't find. Thank you again!!!

Thank you. It worked. I did all 5 steps from http://malwaretips.com/blogs/remove-www-search-net-virus/ They were easy to follow and removed everything I couldn't find. Thank you again!!!
OrtoNNortH 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

d812b said

How do I stop Bing from opening everytime I start FireFox, open a new window or tab in FireFox? When FireFox starts I have my options set to open with my homepage.

The URL setting on new tab opening can be found in two places. I'm assuming that you are using Windows 7 or 8 installed on the C: drive and Firefox version 34 or newer.

You need to open Windows Explorer (or Computer from Start Menu) and go to following location:

C:\Users\YourProfileName\AppData\Roaming\Mozilla\Firefox\Profiles\

where YourProfileName is the name of your local Windows or Active Directory user account.

Inside this folder you'll find another sub-folder that will be called qzreq7dr.default or something similar with .default at the end of the folder name. Open this folder and find following two files:

  • prefs.js
  • user.js

Don't worry if you can't find user.js I'll explain that in a minute. Please close your Firefox web Browser and open prefs.js using Notepad or similar text editor. Scroll it down until you find following line:

user_pref("browser.newtab.url", "HERE IS BING URL");

you'll find your annoying BING URL between the quotation marks. Please delete the URL from the user preference setting. Now your line should look exactly like this:

user_pref("browser.newtab.url", "");

this will open a blank tab every time you click the new tab button. You can also enter another URL if you want your new tab to open a website rather than be blank, but for now let's leave it blank and test it.

Save the changes you've made to prefs.js and run Firefox. Open new tab. Working? If yes, then it's sorted. No? Still see the BING website? Here is what to do next.

If the Bing website still showing on each new tab go back to the folder with prefs.js file. Right click prefs.js and select "Properties". On the "General" tab select "Read Only" option and then click "Apply" and OK to close the window.

Open the prefs.js file in Notepad and change the line again so it be user_pref("browser.newtab.url", ""); without Bing URL.

Start Firefox and test it. Working? Yeeeah! Well not quite. Close the Firefox and go back to the folder with prefs.js, you'll find few new files like prefs1.js prefs2.js ... This may be because something that is putting the Bing URL back to user_pref("browser.newtab.url", ""); setting is trying to overwrite the prefs,js file but it cannot as you've set it up as read only. Please remove the "read only" restriction from the prefs.js properties.

The thing that is making changes to prefs.js may be a command inside user.js (the file I've mentioned at the beginning of this post) or a malware, Firefox add-on or a third-party application.

If the user.js exists please rename it to user.js.old. Open Notepad or other text editor and enter (copy/paste) following code:

user_pref("browser.newtab.url", "");

now save it as user.js

(please make sure that your text editor won't save it with the .txt file extension as it won't work. You may want to remove tick from the following Windows setting: Control Panel/Folder Options/View (2nd tab)/Hide extensions for known file types to ensure that file extension is always what you want it to be. )

Run the Firefox and test it again. Working? It should be fine now as user.js overwrites prefs.js just before the Firefox start, so even if something is making changes to the prefs.js your user.js will change it back to what you want it to be. Controlling Firefox settings using user.js is also very handy for the Firefox deployment in AD as you can use GPO to set up home page, tool bars, proxy etc. but that's a different story.

So, if the new tab is opening without Bing it's time to run malware and AV system scan to ensure that your Windows is not infected. I'm personally using Malwarebytes and Kaspersky Virus Removal Tool. Both tools are free and both scan your system for different threats, just set them up for deepest scan and leave it running for all local drives over the night as it will take a good few hours to scan everything.

I hope that helps. Good luck.

''d812b [[#question-1019383|said]]'' <blockquote> How do I stop Bing from opening everytime I start FireFox, open a new window or tab in FireFox? When FireFox starts I have my options set to open with my homepage. </blockquote> The URL setting on new tab opening can be found in two places. I'm assuming that you are using Windows 7 or 8 installed on the C: drive and Firefox version 34 or newer. You need to open Windows Explorer (or Computer from Start Menu) and go to following location: C:\Users\''YourProfileName''\AppData\Roaming\Mozilla\Firefox\Profiles\ where ''YourProfileName'' is the name of your local Windows or Active Directory user account. Inside this folder you'll find another sub-folder that will be called ''qzreq7dr.default'' or something similar with '''.default''' at the end of the folder name. Open this folder and find following two files: * prefs.js * user.js Don't worry if you can't find user.js I'll explain that in a minute. Please close your Firefox web Browser and open prefs.js using Notepad or similar text editor. Scroll it down until you find following line: user_pref("browser.newtab.url", "HERE IS BING URL"); you'll find your annoying BING URL between the quotation marks. Please delete the URL from the user preference setting. Now your line should look exactly like this: user_pref("browser.newtab.url", ""); this will open a blank tab every time you click the new tab button. You can also enter another URL if you want your new tab to open a website rather than be blank, but for now let's leave it blank and test it. Save the changes you've made to prefs.js and run Firefox. Open new tab. Working? If yes, then it's sorted. No? Still see the BING website? Here is what to do next. If the Bing website still showing on each new tab go back to the folder with prefs.js file. Right click prefs.js and select "Properties". On the "General" tab select "Read Only" option and then click "Apply" and OK to close the window. Open the prefs.js file in Notepad and change the line again so it be user_pref("browser.newtab.url", ""); without Bing URL. Start Firefox and test it. Working? Yeeeah! Well not quite. Close the Firefox and go back to the folder with prefs.js, you'll find few new files like prefs1.js prefs2.js ... This may be because something that is putting the Bing URL back to user_pref("browser.newtab.url", ""); setting is trying to overwrite the prefs,js file but it cannot as you've set it up as read only. Please '''remove the "read only" restriction''' from the prefs.js properties. The thing that is making changes to prefs.js may be a command inside user.js (the file I've mentioned at the beginning of this post) or a malware, Firefox add-on or a third-party application. If the user.js exists please rename it to user.js.old. Open Notepad or other text editor and enter (copy/paste) following code: user_pref("browser.newtab.url", ""); now save it as user.js (please make sure that your text editor won't save it with the .txt file extension as it won't work. You may want to '''remove tick''' from the following Windows setting: ''Control Panel/Folder Options/View (2nd tab)/Hide extensions for known file types'' to ensure that file extension is always what you want it to be. ) Run the Firefox and test it again. Working? It should be fine now as user.js overwrites prefs.js just before the Firefox start, so even if something is making changes to the prefs.js your user.js will change it back to what you want it to be. Controlling Firefox settings using user.js is also very handy for the Firefox deployment in AD as you can use GPO to set up home page, tool bars, proxy etc. but that's a different story. So, if the new tab is opening without Bing it's time to run malware and AV system scan to ensure that your Windows is not infected. I'm personally using Malwarebytes and Kaspersky Virus Removal Tool. Both tools are free and both scan your system for different threats, just set them up for deepest scan and leave it running for all local drives over the night as it will take a good few hours to scan everything. I hope that helps. Good luck.