Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Ho to stop Firefox always being my preferred browser?

  • 7 trả lời
  • 2 gặp vấn đề này
  • 1353 lượt xem
  • Trả lời mới nhất được viết bởi Stevekir

more options

I use Safari as my main browser (it suits me). Sometimes I want to use Firefox because sometimes Safari does not work with some sites (Safari is an Apple product and not all sites work with it). Every time I click on a web address and Firefox is available to run, it starts up and somewhere cheekily tells me that it is my preferred browser but I can't find anywhere to stop it. It is very annoying and if I can't find a solution I will have to delete Firefox from my system.

Any ideas please?

Giải pháp được chọn

Did you try to change the default browser in the Safari settings?

  • Safari > Preferences > General > Default Web Browser > "Default web browser"
Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (7)

more options

To add to my Original Post, my Firefox (V. 31) does not have the square button (like the one in Firefox help on this subject) at Preferences > Advanced.

Apple Mac, OS10.9.4 (Mavericks).

more options

You normally make this choice in Preferences > Advanced > General

  • Firefox > Preferences > Advanced > General: System Defaults: "Always check to see if Firefox is the default browser on startup"

You can also achieve this by setting the browser.shell.checkDefaultBrowser pref to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thanks. But when I went to browser.shell.checkDefaultBrowser, it was already set to false. I was able to change it to true but I returned it to false before quitting about:config.

Any other suggestions please?

more options

You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

more options

Tried it all. Nothing works. And anyway it is all too complicated and techie. What non-computer geek has the time to continue wading through this link and that link and another link, only to find that an instruction is given to quit Firefox which leads to all these linked pages disappearing and needing a return to square one.

I managed to delete the prefs.js file. No solution. I will now ditch Firefox as being unusable in my Mac (2011 model, current OS software, no dodgy utilities).

What a waste of time! But thanks for trying.

more options

Giải pháp được chọn

Did you try to change the default browser in the Safari settings?

  • Safari > Preferences > General > Default Web Browser > "Default web browser"
more options

Wow! It worked. The last time I looked at that it was for an older version of Safari and I don't think it was there. Having set the pref. in Safari to make Safari my default browser, I tested it by asking it to load a web page, and it did, inside Safari. So problem solved.

However, while Safari was loading the page, Firefox opened and (for the first time ever) asked me if I would like to make it my default browser. I set it at "no" of course. I had previously deleted the prefs.js file, as advised here, several times with no effect. This last time, Firefox woke up and asked me. Here is its message:

https://support.cdn.mozilla.net/media/uploads/images/2014-08-30-13-32-14-08c1b7.png

Many thanks.