Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

My website has an SSL and is showing as secure in Safari, but Firefox gives a grey triangle warning?

  • 5 trả lời
  • 9 gặp vấn đề này
  • 225 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Hi,

My website has an SSL from Dreamhost and is forcing SSL in Wordpress. The web address is set to HTTPS. Everything works perfectly in Safari and the lock icon is showing up. In Firefox however, the "Gray Warning Triangle" shows up in the address bar. When I click the triangle and "Page Info", it shows I have a certificate. How do I make the lock icon show? I have a Wordpress site and will be selling product on it, so it needs to show as secure.

Thanks.

Hi, My website has an SSL from Dreamhost and is forcing SSL in Wordpress. The web address is set to HTTPS. Everything works perfectly in Safari and the lock icon is showing up. In Firefox however, the "Gray Warning Triangle" shows up in the address bar. When I click the triangle and "Page Info", it shows I have a certificate. How do I make the lock icon show? I have a Wordpress site and will be selling product on it, so it needs to show as secure. Thanks.

Giải pháp được chọn

thanks, got it. you have a few image elements at the page which aren't loaded through https and which will break the secure connection indicator. in firefox you can press ctrl+shift+k to open the web console - in there make sure that you're logging security notices. then it will show you which elements are affected while you re/load a page...

Đọc câu trả lời này trong ngữ cảnh 👍 3

Tất cả các câu trả lời (5)

more options

hello, can you provide a url for the site?

edit: Gray warning triangle

Được chỉnh sửa bởi philipp vào

more options

Set you a private message. We're not ready for the world to see the site yet, so I didn't want to post it. Thanks.

more options

Giải pháp được chọn

thanks, got it. you have a few image elements at the page which aren't loaded through https and which will break the secure connection indicator. in firefox you can press ctrl+shift+k to open the web console - in there make sure that you're logging security notices. then it will show you which elements are affected while you re/load a page...

more options

Thank you so much! I changed all my images from "http://www..." to just "/wp-content/uploads/2014/03/example.jpg" and it fixed it. You're a life saver!

more options

Note that you can also leave out the protocol name (https or http) and only leave the two slashes (//www.xxx) to make browser apply the currently used protocol.