X
Tap here to go to the mobile version of the site.

Support Forum

FF 31 cannot do on-line banking with Bank of Montreal, not even in Safe Mode

Posted

I can log on to my bank account using FF (version 31) but at any moment I may be cut off with the message "Session has expired or you're not logged on properly." The dreaded message will certainly appear when clicking the button to finalize a payment. My (few) add-ons have nothing to do with this malfunction, in Safe Mode too I'm cut off before long. No problem with IE or Chrome, which I have started using. For your further information, I have experienced this problem with FF on different computers (all running W7) and different home networks.

I can log on to my bank account using FF (version 31) but at any moment I may be cut off with the message "Session has expired or you're not logged on properly." The dreaded message will certainly appear when clicking the button to finalize a payment. My (few) add-ons have nothing to do with this malfunction, in Safe Mode too I'm cut off before long. No problem with IE or Chrome, which I have started using. For your further information, I have experienced this problem with FF on different computers (all running W7) and different home networks.

Chosen solution

There may be something (a setting or program) on one but not the other. If it works......

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • VLC media player Web Plugin 2.1.3
  • Google Update
  • 5.1.30514.0
  • GEPlugin
  • Picasa plugin
  • PDF-XChange Viewer Netscape Gecko Plugin
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Google Updater pluginhttp://pack.google.com/
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

guigs2
  • Top 10 Contributor
  • Administrator
  • Moderator
662 solutions 7515 answers

Hi J_C_R1, Thank you for your question, I understand that the logged in session of your bank's website expires after a certain period of time and that this does not happen on other network or browsers.

Please check the following options in the browser: Options/Preferences > Privacy > History and select custom settings in order to see the cookies options. Change keep cookies to "I close firefox' may keep it going for the session.

It is possible that the cookies.sqlite file that stores the cookies is corrupted if clearing cookies doesn't work.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

   * Bulleted list itemhttp://kb.mozillazine.org/Cookies
Hi J_C_R1, Thank you for your question, I understand that the logged in session of your bank's website expires after a certain period of time and that this does not happen on other network or browsers. Please check the following options in the browser: Options/Preferences > Privacy > History and select custom settings in order to see the cookies options. Change keep cookies to "I close firefox' may keep it going for the session. It is possible that the cookies.sqlite file that stores the cookies is corrupted if clearing cookies doesn't work. Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted. * Bulleted list item[http://kb.mozillazine.org/Cookies]
cor-el
  • Top 10 Contributor
  • Moderator
12275 solutions 113676 answers

You should clear the cache as well.

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

You can check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You should clear the cache as well. *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" You can check the connection settings. *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can ---- You can check for problems with preferences. Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences

Question owner

Thanks. It seems cookies were the problem indeed. All I did is change to "Keep cookies till I close Firefox" and I could visit my account again and make payments like I used to. I'm relieved, I tell you. I keep all respondents' recommendations on file though just in case. Thanks again!

Thanks. It seems cookies were the problem indeed. All I did is change to "Keep cookies till I close Firefox" and I could visit my account again and make payments like I used to. I'm relieved, I tell you. I keep all respondents' recommendations on file though just in case. Thanks again!

Modified by J_C_R1

FredMcD
  • Top 10 Contributor
874 solutions 13024 answers

That's good to hear. As a test, please change the setting back and see if the problem continues.

That's good to hear. As a test, please change the setting back and see if the problem continues.

Question owner

There's good news and bad. The good news (for you) is, I changed back to the following settings and the problem recurred.

  • Use custom settings for history
  • Checked: Always use private browsing mode
  • Checked: Accept cookies from sites
  • Accept 3rd party cookies: Never

All other boxes are grayed out with these settings. The recurrence means you're vindicated. I have of course now re-applied the settings that work for me:

  • Checked: Remember my browsing and download history
  • Checked: Accept cookies from sites
  • Accept 3rd party cookies: Never
  • Keep until: I close Firefox
  • Checked: Clear history when Firefox closes

However, all this concerns my desktop PC (W7). Once my desktop PC's FF was working properly again with BMO, I had the bad idea of trying to use the BMO website from the FF31 on my laptop (also a W7 machine and on the same home network). This FF31 still had the above-specified configuration with "Always use private browsing mode" so logically the "Session terminated" message should have appeared before long. Not so. I could do a transfer between accounts and browse the site's pages without a problem.

I'll leave the FF configurations of the two machines as they are now because they seem to work. During September I'll divide my on-line banking between the two machines and let's see what happens.

(Sorry, I noticed too late you can attach images. Would have shortened the talking.)

There's good news and bad. The good news (for you) is, I changed back to the following settings and the problem recurred. * Use custom settings for history * Checked: Always use private browsing mode * Checked: Accept cookies from sites * Accept 3rd party cookies: Never All other boxes are grayed out with these settings. The recurrence means you're vindicated. I have of course now re-applied the settings that work for me: * Checked: Remember my browsing and download history * Checked: Accept cookies from sites * Accept 3rd party cookies: Never * Keep until: I close Firefox * Checked: Clear history when Firefox closes However, all this concerns my desktop PC (W7). Once my desktop PC's FF was working properly again with BMO, I had the bad idea of trying to use the BMO website from the FF31 on my laptop (also a W7 machine and on the same home network). This FF31 still had the above-specified configuration with "Always use private browsing mode" so logically the "Session terminated" message should have appeared before long. Not so. I could do a transfer between accounts and browse the site's pages without a problem. I'll leave the FF configurations of the two machines as they are now because they seem to work. During September I'll divide my on-line banking between the two machines and let's see what happens. (Sorry, I noticed too late you can attach images. Would have shortened the talking.)
FredMcD
  • Top 10 Contributor
874 solutions 13024 answers

Chosen Solution

There may be something (a setting or program) on one but not the other. If it works......

There may be something (a setting or program) on one but not the other. If it works'''......'''
cor-el
  • Top 10 Contributor
  • Moderator
12275 solutions 113676 answers

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted. *Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookies files like <b>cookies.sqlite-journal</b> in the Firefox profile folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)