X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes

Posted

When Firefox crashes it displays a dialog, I give permission to send a report to Mozilla, and the dialog says there was a problem submitting the report.

Firefox page "about:crashes" lists 2 crashes today, 2 crashes a few days ago, and some older ones.

When I click a crash ID for example db81f3f6-cd44-4ce8-8268-de23913c35d9 (https://crash-stats.mozilla.com/about/throttling) it gets a "Page not found" (https://crash-stats.mozilla.com/about/throttling).

Upgrading from Firefox 30 to Firefox 31 did not change the frequency of crashes.

Submitted Crash Reports Report ID Date Submitted db81f3f6-cd44-4ce8-8268-de23913c35d9 2014/08/06 12:33 286aeecd-71e3-41ca-ab9b-784439ceba97 2014/08/06 12:31 ae650186-1937-487d-b07d-34b5adf70690 2014/08/03 10:36 7815703a-97a9-41e6-8d30-6926998d6dc9 2014/08/03 9:39 bp-8b68bdca-3c55-4ce1-996e-221582140730 2014/07/30 17:32 bp-d1d8974b-fd8b-4ab9-94e5-c16422140729 2014/07/30 7:59 5a488610-3497-4bd1-a7a4-8657e31f5e2e 2014/07/27 15:16 077e5047-1525-472e-b550-3dd3fc19e368 2014/07/19 9:14 cd0c8327-5e80-44fa-958c-4ee24d475933 2014/07/16 18:50 ce16d124-586b-43f5-8e5c-ad74a203fd98 2014/07/13 7:34 7d3beb50-124d-471d-8500-4d3d6b9a9b48 2014/07/09 14:04 142f4292-767d-4abd-b5e7-37919fe61dcd 2014/07/06 12:14

When Firefox crashes it displays a dialog, I give permission to send a report to Mozilla, and the dialog says there was a problem submitting the report. Firefox page "about:crashes" lists 2 crashes today, 2 crashes a few days ago, and some older ones. When I click a crash ID for example db81f3f6-cd44-4ce8-8268-de23913c35d9 (https://crash-stats.mozilla.com/about/throttling) it gets a "Page not found" (https://crash-stats.mozilla.com/about/throttling). Upgrading from Firefox 30 to Firefox 31 did not change the frequency of crashes. Submitted Crash Reports Report ID Date Submitted db81f3f6-cd44-4ce8-8268-de23913c35d9 2014/08/06 12:33 286aeecd-71e3-41ca-ab9b-784439ceba97 2014/08/06 12:31 ae650186-1937-487d-b07d-34b5adf70690 2014/08/03 10:36 7815703a-97a9-41e6-8d30-6926998d6dc9 2014/08/03 9:39 bp-8b68bdca-3c55-4ce1-996e-221582140730 2014/07/30 17:32 bp-d1d8974b-fd8b-4ab9-94e5-c16422140729 2014/07/30 7:59 5a488610-3497-4bd1-a7a4-8657e31f5e2e 2014/07/27 15:16 077e5047-1525-472e-b550-3dd3fc19e368 2014/07/19 9:14 cd0c8327-5e80-44fa-958c-4ee24d475933 2014/07/16 18:50 ce16d124-586b-43f5-8e5c-ad74a203fd98 2014/07/13 7:34 7d3beb50-124d-471d-8500-4d3d6b9a9b48 2014/07/09 14:04 142f4292-767d-4abd-b5e7-37919fe61dcd 2014/07/06 12:14

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 14.0 r0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Phần mở rộng

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 8400M GS
  • adapterDescription2:
  • adapterDeviceID: 0x0427
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 128
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 5-19-2014
  • driverDate2:
  • driverVersion: 9.18.13.3788
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 17
  • numTotalWindows: 17
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 8400M GS Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1407296040
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1407315575

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
12014 solutions 111603 answers

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

Question owner

I figured out that a few of the crashes succeeded in uploading their dumps. The reason for crashing is running out of memory. Even under 64-bit Windows with more than 4GB of RAM and many GB of pagefiles available, Firefox runs in a 32-bit process with limited virtual address space.

I have around 50 tabs open to ordinary information sites. At home I have a tab open to Youtube playing music, but at work I don't. I don't know how these tabs use more than 1.5GB of virtual RAM. But they do, and Firefox gets confused.

I read that Bugzilla already has OOM (out of memory) marked as a big reason for crashes, and Mozilla's volunteers marked it as WONTFIX.

I understand that Mozilla's volunteers are volunteers and I can't complain about WONTFIX. But the attitude is equally offensive as Microsoft, blaming users when the maker's bugs are the maker's bugs.

I figured out that a few of the crashes succeeded in uploading their dumps. The reason for crashing is running out of memory. Even under 64-bit Windows with more than 4GB of RAM and many GB of pagefiles available, Firefox runs in a 32-bit process with limited virtual address space. I have around 50 tabs open to ordinary information sites. At home I have a tab open to Youtube playing music, but at work I don't. I don't know how these tabs use more than 1.5GB of virtual RAM. But they do, and Firefox gets confused. I read that Bugzilla already has OOM (out of memory) marked as a big reason for crashes, and Mozilla's volunteers marked it as WONTFIX. I understand that Mozilla's volunteers are volunteers and I can't complain about WONTFIX. But the attitude is equally offensive as Microsoft, blaming users when the maker's bugs are the maker's bugs.
FredMcD
  • Top 10 Contributor
797 solutions 11519 answers

Java Script is mentioned in the crash report.

Java Script is mentioned in the crash report.
Debapriya Bhattacharya 58 solutions 634 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu: *In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. *In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on ''Help'' (or click on ''Help'' in the Menu bar, if you don't have a Firefox button) then click on ''Restart with Add-ons Disabled''. If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode".<br> [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

I clicked the menu button, clicked the help button, and clicked to restart Firefox with Add-ons Disabled. The Firefox Safe Mode dialog came up. I clicked the button to Start in Safe Mode.

Strangely, web sites that depend on JavaScript (such as Yahoo e-mail) were working properly.

I clicked on the Help menu - Firefox Health Report. It says 1 Add-on is enabled and 0 Add-ons are disabled.

This is safe mode?

The Add-ons Manager (about:addons), left-hand tab for Extensions, says "! All add-ons have been disabled by safe mode." Troubleshooter 1.1a is disabled. There are clickable buttons for Disable and Remove, but no button for Enable.

So which add-on is enabled? I don't know how to find it.

Appearance, Default 31.0, is also disabled. I wouldn't have guessed by looking at the Firefox windows; I only noticed when looking through the Add-ons Manager.

I clicked the menu button, clicked the help button, and clicked to restart Firefox with Add-ons Disabled. The Firefox Safe Mode dialog came up. I clicked the button to Start in Safe Mode. Strangely, web sites that depend on JavaScript (such as Yahoo e-mail) were working properly. I clicked on the Help menu - Firefox Health Report. It says 1 Add-on is enabled and 0 Add-ons are disabled. This is safe mode? The Add-ons Manager (about:addons), left-hand tab for Extensions, says "! All add-ons have been disabled by safe mode." Troubleshooter 1.1a is disabled. There are clickable buttons for Disable and Remove, but no button for Enable. So which add-on is enabled? I don't know how to find it. Appearance, Default 31.0, is also disabled. I wouldn't have guessed by looking at the Firefox windows; I only noticed when looking through the Add-ons Manager.

Question owner

Windows Task Manager says that 4 processes are executing instances of FlashPlayerPlugin: C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerPlugin_14_0_0_145.exe

Oh yeah, the Add-ons Manager tab for Plugins says that Flash will always execute instead of asking to execute.

So even in safe mode, Flash is enabled instead of asking?

I don't see any mention of JavaScript in the Add-ons Manager. An unrelated plugin named Java was updated from U65 to U67, but that one isn't even running since it's set to Ask to Activate and I haven't been asked. I don't know how to find if a JavaScript extension exists and is enabled when it's not supposed to be.

Windows Task Manager says that 4 processes are executing instances of FlashPlayerPlugin: C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerPlugin_14_0_0_145.exe Oh yeah, the Add-ons Manager tab for Plugins says that Flash will always execute instead of asking to execute. So even in safe mode, Flash is enabled instead of asking? I don't see any mention of JavaScript in the Add-ons Manager. An unrelated plugin named Java was updated from U65 to U67, but that one isn't even running since it's set to Ask to Activate and I haven't been asked. I don't know how to find if a JavaScript extension exists and is enabled when it's not supposed to be.

Question owner

Good news is that this setting seems to be helping, though I don't really understand it since Flash is active. After restarting in safe mode, Firefox has run for more than 3 hours of CPU time and has occupied more than 2,000,000 KB[*], and yet has not crashed.

I still don't know what's occupying most of that memory. At home I'm playing music on Youtube, which takes its share of CPU time, but apparently not much memory. At work I don't do that, but tabs displaying ordinary information still occupy nearly 2 GB and Firefox's crashes are probably due to out-of-memory.

[* I nominate the word "disunit" for memory occupancy shown by Windows Task Manager. 2 * 1024 * 1024 * 1024 would be 2GB in binary units, 2 * 1000 * 1000 * 1000 would be 2GB in decimal units, and 2 * 1000 * 1000 * 1024 is Microsoft's disunited combination.]

Good news is that this setting seems to be helping, though I don't really understand it since Flash is active. After restarting in safe mode, Firefox has run for more than 3 hours of CPU time and has occupied more than 2,000,000 KB[*], and yet has not crashed. I still don't know what's occupying most of that memory. At home I'm playing music on Youtube, which takes its share of CPU time, but apparently not much memory. At work I don't do that, but tabs displaying ordinary information still occupy nearly 2 GB and Firefox's crashes are probably due to out-of-memory. [* I nominate the word "disunit" for memory occupancy shown by Windows Task Manager. 2 * 1024 * 1024 * 1024 would be 2GB in binary units, 2 * 1000 * 1000 * 1000 would be 2GB in decimal units, and 2 * 1000 * 1000 * 1024 is Microsoft's disunited combination.]

Question owner

Firefox 31.0 crashed while running in safe mode too. Before crashing, it reported errors with two JavaScript scripts, so it looks like JavaScript runs in safe mode too, without asking.

Firefox 31.0 crashed while running in safe mode too. Before crashing, it reported errors with two JavaScript scripts, so it looks like JavaScript runs in safe mode too, without asking.
FredMcD
  • Top 10 Contributor
797 solutions 11519 answers

Java, Flash and some others are in the add-ons manager under Plugins. Go there and Disable Everything as a test.

Java, Flash and some others are in the add-ons manager under '''Plugins.''' Go there and '''Disable Everything''' as a test.

Question owner

Java was not running. Firefox 31.0, running in safe mode before crashing, reported errors with two JAVASCRIPT scripts, so it looks like JAVASCRIPT runs in safe mode too, without asking.

In the add-ons manager I see a setting for Firefox to ask before activating JAVA, which is set by default and I have not changed it. I have never been asked and I assume JAVA has not run at all.

In the add-ons manager I do not see any setting for JAVASCRIPT.

In the add-ons manager I see a setting for Firefox to run Flash without asking, which is set by default and I have not changed it. I understand your suggestion to change it. I have mixed feelings about whether to try it.

I think you're blaming Flash for a problem with Firefox's JavaScript.

If you can say how to disable JavaScript (both in safe mode and normal mode), I will try it.

Java was not running. Firefox 31.0, running in safe mode before crashing, reported errors with two JAVASCRIPT scripts, so it looks like JAVASCRIPT runs in safe mode too, without asking. In the add-ons manager I see a setting for Firefox to ask before activating JAVA, which is set by default and I have not changed it. I have never been asked and I assume JAVA has not run at all. In the add-ons manager I do not see any setting for JAVASCRIPT. In the add-ons manager I see a setting for Firefox to run Flash without asking, which is set by default and I have not changed it. I understand your suggestion to change it. I have mixed feelings about whether to try it. I think you're blaming Flash for a problem with Firefox's JavaScript. If you can say how to disable JavaScript (both in safe mode and normal mode), I will try it.
FredMcD
  • Top 10 Contributor
797 solutions 11519 answers

In safe mode, only add-on extensions and user setting are disabled. Plugins are not unless you disable them.

In safe mode, only add-on extensions and user setting are disabled. Plugins are not unless you disable them.
FredMcD
  • Top 10 Contributor
797 solutions 11519 answers

https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages JavaScript settings and preferences for interactive web pages This article describes what JavaScript is and how to allow or block it on certain websites.


Please post your latest crash reports. Note: If the report does not have BP in front of the numbers, click it and select Submit.

'''https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages''' JavaScript settings and preferences for interactive web pages This article describes what JavaScript is and how to allow or block it on certain websites. ----------------------------- Please post your latest crash reports. '''Note:''' If the report does not have BP in front of the numbers, click it and select''' Submit.'''
cor-el
  • Top 10 Contributor
  • Moderator
12014 solutions 111603 answers

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (localstore-safe.rdf file)
  • JavaScript JIT compilers are disabled (about:config page: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (localstore-safe.rdf file) *JavaScript JIT compilers are disabled (about:config page: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected

Question owner

I looked at page https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages

NoScript is described as an extension. All extensions are disabled when Firefox is running in safe mode, right?

The Plugins tab does not include JavaScript in the list.

Is there some way to disable JavaScript in Firefox? If there is a way, I will try it as an experiment.

I looked at page https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages NoScript is described as an extension. All extensions are disabled when Firefox is running in safe mode, right? The Plugins tab does not include JavaScript in the list. Is there some way to disable JavaScript in Firefox? If there is a way, I will try it as an experiment.

Question owner

I understand the suggestion to disable hardware acceleration in Firefox, but again it seems odd. When video drivers crash they ordinarily give BSODs, or more recently Windows 7 can restart a bug-ridden video driver instead of BSOD.

I think more likely the problem is in Firefox's implementation of JavaScript. As someone else pointed out, JavaScript is mentioned in the crash dumps, and there is a JavaScript bug listed in Bugzilla with status of WONTFIX.

---

"In Firefox Safe mode these changes are effective:

   all extensions are disabled (about:addons)"

Yes, I noticed that.

"JavaScript JIT compilers are disabled (about:config page: javascript.options.*jit)"

That does not seem to be true. I'm running in safe mode now. javascript.options.baselinejit;true That is the only jit option.

I understand the suggestion to disable hardware acceleration in Firefox, but again it seems odd. When video drivers crash they ordinarily give BSODs, or more recently Windows 7 can restart a bug-ridden video driver instead of BSOD. I think more likely the problem is in Firefox's implementation of JavaScript. As someone else pointed out, JavaScript is mentioned in the crash dumps, and there is a JavaScript bug listed in Bugzilla with status of WONTFIX. --- "In Firefox Safe mode these changes are effective: all extensions are disabled (about:addons)" Yes, I noticed that. "JavaScript JIT compilers are disabled (about:config page: javascript.options.*jit)" That does not seem to be true. I'm running in safe mode now. javascript.options.baselinejit;true That is the only jit option.
cor-el
  • Top 10 Contributor
  • Moderator
12014 solutions 111603 answers

The prefs aren't modified if you enter safe mode as this disabling is done internally. You would only notice a difference on JavaScript intensive pages that benefit from using the compiler to speed up the execution.

The prefs aren't modified if you enter safe mode as this disabling is done internally. You would only notice a difference on JavaScript intensive pages that benefit from using the compiler to speed up the execution.

Question owner

"The prefs aren't modified if you enter safe mode as this disabling is done internally."

OK, BUT: Even when running in safe mode, Firefox gave 2 errors about JavaScript scripts before Firefox crashed. That means that Firefox was running JavaScript instead of disabling it, even in safe mode, right?

I manually toggled it in about:conf so it is now: javascript.options.baselinejit;false

I restarted Firefox in safe mode again. We'll see what happens.

"The prefs aren't modified if you enter safe mode as this disabling is done internally." OK, BUT: Even when running in safe mode, Firefox gave 2 errors about JavaScript scripts before Firefox crashed. That means that Firefox was running JavaScript instead of disabling it, even in safe mode, right? I manually toggled it in about:conf so it is now: javascript.options.baselinejit;false I restarted Firefox in safe mode again. We'll see what happens.

Question owner

Even in safe mode, the crash dump lists JavaScript: https://crash-stats.mozilla.com/report/index/f7777dab-e408-43a3-b00d-c6ac32140816

Even in safe mode, the crash dump lists JavaScript: https://crash-stats.mozilla.com/report/index/f7777dab-e408-43a3-b00d-c6ac32140816
cor-el
  • Top 10 Contributor
  • Moderator
12014 solutions 111603 answers

JavaScript runs normally in safe mode unless you would disable it by setting javascript.enabled = false on the about:config page. Only the JavaScript compilers are disabled that speed up the execution, so JavaScript runs slower.

JavaScript runs normally in safe mode unless you would disable it by setting javascript.enabled = false on the <b>about:config</b> page. Only the JavaScript compilers are disabled that speed up the execution, so JavaScript runs slower.

Question owner

OK, I changed this one: javascript.enabled;false

Now Yahoo Mail doesn't work.

I'll reenable JavaScript again.

I'll leave basejit disabled and we'll see if it helps.

OK, I changed this one: javascript.enabled;false Now Yahoo Mail doesn't work. I'll reenable JavaScript again. I'll leave basejit disabled and we'll see if it helps.