X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

One word search in address bar not working.

Được đăng

I've been away from my desktop for a week and now the searches in the address bar are not working. For example, I used to just type 'test' into the search bar and the tab would show a list of Google searches. Two words work though. Any and all help would be deeply appreciated. I've tried Search Reset, changing the keyword and fixup in about:config.

I've been away from my desktop for a week and now the searches in the address bar are not working. For example, I used to just type 'test' into the search bar and the tab would show a list of Google searches. Two words work though. Any and all help would be deeply appreciated. I've tried Search Reset, changing the keyword and fixup in about:config.

Giải pháp được chọn

Thanks for the paste. Looks like this service based in Malaysia: http://midas.nervesis.com/ (http://www.nervesis.com.my/). Does it seem plausible that your ISP is using this service?? Even if it is, it should not be able to override the new way that address bar search works in Firefox 33.

I think the question of a bad extension was raised before. Have you tested in Firefox's Safe Mode to rule that out? It's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 14.0 r0
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.10
  • 2.3.0
  • 0.3
  • VLC media player Web Plugin 2.0.0-rc
  • 0.70.4

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Thông tin chi tiết

Chandan_Baba 35 giải pháp 369 câu trả lời
Được đăng

Did you check this setting in your Browser config browser.urlbar.autocomplete.enabled the default value is True . You can also check for Google settings for Google Instant Predictions here you check point in Always show Instant result from settings.

Let us know if this work !!

Did you check this setting in your Browser config '''browser.urlbar.autocomplete.enabled ''' the default value is '''True''' . You can also check for Google settings for '''Google Instant Predictions''' here you check point in '''Always show Instant result''' from settings. Let us know if this work !!

Người tạo câu hỏi

Both methods didn't work. I just want to point out that I did not have this problem a week ago when I last shutdown my computer as I was leaving. Today, I opened Firefox and encountered this problem.

Both methods didn't work. I just want to point out that I did not have this problem a week ago when I last shutdown my computer as I was leaving. Today, I opened Firefox and encountered this problem.

Được chỉnh sửa bởi Lurker vào

Người tạo câu hỏi

Bump, really appreciate any help guys and gals.

Bump, really appreciate any help guys and gals.
philipp
  • Top 25 Contributor
  • Moderator
5291 giải pháp 23374 câu trả lời
Được đăng
this will change in upcoming firefox 33: http://msujaws.wordpress.com/2014/08/01/faster-and-snappier-searches-now-in-firefox-aurora/

Người tạo câu hỏi

Wait, so what you're saying is that a recent update broke it ? And there's no way to fix the problem until the next update comes out ?

Wait, so what you're saying is that a recent update broke it ? And there's no way to fix the problem until the next update comes out ?
cor-el
  • Top 10 Contributor
  • Moderator
17416 giải pháp 157354 câu trả lời
Được đăng

In current Firefox releases Firefox will first try to resolve a one word search via a DNS look up and do an URL fixup if this is enabled via their prefs. Firefox 33 will use a different approach and only search locally or possibly check the cache (?) and not on internet, so this is a lot faster.

You can always use a (one letter) keyword search to specify to use a specific search engine to search for one word or multi word terms to skip this look up.


In current Firefox releases Firefox will first try to resolve a one word search via a DNS look up and do an URL fixup if this is enabled via their prefs. Firefox 33 will use a different approach and only search locally or possibly check the cache (?) and not on internet, so this is a lot faster. You can always use a (one letter) keyword search to specify to use a specific search engine to search for one word or multi word terms to skip this look up. ---- *http://www-archive.mozilla.org/docs/end-user/domain-guessing.html *http://www-archive.mozilla.org/docs/end-user/internet-keywords.html

Người tạo câu hỏi

So, which version of Firefox doesnt do this then ? Like I said it was still 1 fine 1 week before.

Also, you said 'You can always use a (one letter) keyword search to specify to use a specific search engine to search for one word or multi word terms to skip this look up.' How do I do that ? If possible I'd like all terms typed in to the address bar to be searched.

So, which version of Firefox doesnt do this then ? Like I said it was still 1 fine 1 week before. Also, you said 'You can always use a (one letter) keyword search to specify to use a specific search engine to search for one word or multi word terms to skip this look up.' How do I do that ? If possible I'd like all terms typed in to the address bar to be searched.
cor-el
  • Top 10 Contributor
  • Moderator
17416 giải pháp 157354 câu trả lời
Được đăng

You can set a keyword to installed search engines if you click the search engine icon on the search bar and click "Manage Search Engines". You can do the same to a bookmark in the Bookmarks Manager (Library; Show All Bookmarks; click the More button at the bottom right) or in the Bookmarks Sidebar (View > Sidebars; Ctrl+B) via the right-click context menu (Properties).

You can set a keyword to installed search engines if you click the search engine icon on the search bar and click "Manage Search Engines". You can do the same to a bookmark in the Bookmarks Manager (Library; Show All Bookmarks; click the ''More'' button at the bottom right) or in the Bookmarks Sidebar (View > Sidebars; Ctrl+B) via the right-click context menu (Properties).

Người tạo câu hỏi

It seems that inputting the keyword in the search engine would only redirect you to said search engine. It doesn't automatically performs the search ? And I'm sorry but I don't understand what you meant with the bookmarks ? I just want Firefox to perform a search for whatever I have typed in to the address bar. Just what changed ? Like why cant I do that now ?

Sorry if I sound angry but this is getting very frustrating.

It seems that inputting the keyword in the search engine would only redirect you to said search engine. It doesn't automatically performs the search ? And I'm sorry but I don't understand what you meant with the bookmarks ? I just want Firefox to perform a search for whatever I have typed in to the address bar. Just what changed ? Like why cant I do that now ? Sorry if I sound angry but this is getting very frustrating.
Talha 23 giải pháp 89 câu trả lời
Được đăng

Hello,

I am really sorry that you are facing this problem. Lets try to fix it.

Try this: https://addons.mozilla.org/en-US/firefox/addon/searchreset/

The above add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Hope it helps.

Hello, I am really sorry that you are facing this problem. Lets try to fix it. Try this: https://addons.mozilla.org/en-US/firefox/addon/searchreset/ The above add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page. Hope it helps.

Người tạo câu hỏi

Hi, Talha.

I've did that before as stated in my main post but I just tried it again and no luck.

Hi, Talha. I've did that before as stated in my main post but I just tried it again and no luck.

Người tạo câu hỏi

Bump.

Bump.

Người tạo câu hỏi

Bump again.

Bump again.

Người tạo câu hỏi

Bumps.

Bumps.

Người tạo câu hỏi

Bump.

Bump.
cor-el
  • Top 10 Contributor
  • Moderator
17416 giải pháp 157354 câu trả lời
Được đăng

You can enter the keyword in the location/address bar and add a space followed by the search terms that you want to send to the search page. E.g. to search on Google for firefox if g is the keyword for Google, you enter in the location bar: g firefox

You can enter the keyword in the location/address bar and add a space followed by the search terms that you want to send to the search page. E.g. to search on Google for ''firefox'' if ''g'' is the keyword for Google, you enter in the location bar: <i>g firefox</i>

Được chỉnh sửa bởi cor-el vào

Người tạo câu hỏi

But that's not my point here. I never needed to set keywords to search from the address bar. I kept stressing this : It worked before. So why isn't it working now ? And how or what can I do to fix this ?

But that's not my point here. I never needed to set keywords to search from the address bar. I kept stressing this : It worked before. So why isn't it working now ? And how or what can I do to fix this ?
cor-el
  • Top 10 Contributor
  • Moderator
17416 giải pháp 157354 câu trả lời
Được đăng

Is keyword.enabled set to true on the about:config page?

Is <b>keyword.enabled</b> set to true on the <b>about:config</b> page?

Người tạo câu hỏi

Yes, it is.

Yes, it is.

Người tạo câu hỏi

Bump.

Bump.