Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Changes to 3rd party cookies options are not saved

  • 3 trả lời
  • 3 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I want to change Cookies setting to allow 3rd party cookies because an important website that I access

frequently says that my browser (Firefox) does not accept these cookies.

I am following the Firefox Support instructions @ https://support.mozilla.org/en-US/kb/enable-and-disable-cookies-website-preferences#w_how-do-i-change-

cookie-settings

Select Options > Privacy tab I change the History setting from "Remember history" to "Use custom setting for history" "Remember my browsing and download history" is checked "Remember search and form history" is checked

"Accept cookies from sites" is checked Accept third-party cookies:" is set to Always and keep until: they expire

There is no Save button so I click OK

I close Options then reselect it and I am back to "Remember history" and there is nothing visible for "Accept

Cookies" and my important website is still won't open.

It is obvious that my Option changes have not been saved. This seems like you have a bug that needs fixing.

I want to change Cookies setting to allow 3rd party cookies because an important website that I access frequently says that my browser (Firefox) does not accept these cookies. I am following the Firefox Support instructions @ https://support.mozilla.org/en-US/kb/enable-and-disable-cookies-website-preferences#w_how-do-i-change- cookie-settings Select Options > Privacy tab I change the History setting from "Remember history" to "Use custom setting for history" "Remember my browsing and download history" is checked "Remember search and form history" is checked "Accept cookies from sites" is checked Accept third-party cookies:" is set to Always and keep until: they expire There is no Save button so I click OK I close Options then reselect it and I am back to "Remember history" and there is nothing visible for "Accept Cookies" and my important website is still won't open. It is obvious that my Option changes have not been saved. This seems like you have a bug that needs fixing.

Giải pháp được chọn

Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.

If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".

  • "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark.

Note that if you clear the cookie settings that such changes only apply to new cookies, so you need to clear existing cookies to make Firefox create new cookies.

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.
Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (3)

more options

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can get to the profile folder below:

  • Help > Troubleshooting Information > Profile Directory > Show Folder

or

  • Go to about:support and click Show Folder next to Profile Directory.
more options

Still can't get cookies accepted

more options

Giải pháp được chọn

Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.

If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".

  • "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark.

Note that if you clear the cookie settings that such changes only apply to new cookies, so you need to clear existing cookies to make Firefox create new cookies.

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.