Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

تلاش سپورٹ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF 116 Scrollbar Buttons Gone

  • 8 جواب دیں
  • 0 میں یہ مسئلہ ہے
  • 27 دیکھیں
  • آخری جواب بذریعہ crxssi

more options

Prior to Firefox 116, I could have the normal scrollbar up and down buttons showing by making:

widget.non-native-theme.gtk.scrollbar.allow-buttons True

But now it seems to have no effect. This is under Linux/Mint/Cinnamon. Also, now long-pressing is doing smooth scrolling (I never want smooth scrolling anywhere) and can't find a way to stop that.

I have these set from before:

widget.gtk.overlay-scrollbars.enabled false widget.non-native-theme.gtk.scrollbar.round-thumb false widget.non-native-theme.gtk.scrollbar.thumb-size .85 widget.non-native-theme.scrollbar.size 14 widget.non-native-theme.scrollbar.size.override 14 general.smoothScroll false general.smoothScroll.other false general.smoothScroll.lines false general.smoothScroll.pages false general.smoothScroll.pixels false general.smoothScroll.mouseWheel false mousewheel.system_scroll_override.enabled false toolkit.scrollbox.smoothScroll false ui.scrollToClick 0

Any suggestions appreciated.

Seems like it is always a fight retaining usable scrollbars in Firefox that do not hide, do not change size on mouse-over, do not "warp" on left click, do warp on center click, have a thumb that shows page size, have a background that is not white, and are not microscopic in size! Just call me "traditional"  :)

Thanks

Prior to Firefox 116, I could have the normal scrollbar up and down buttons showing by making: widget.non-native-theme.gtk.scrollbar.allow-buttons True But now it seems to have no effect. This is under Linux/Mint/Cinnamon. Also, now long-pressing is doing smooth scrolling (I never want smooth scrolling anywhere) and can't find a way to stop that. I have these set from before: widget.gtk.overlay-scrollbars.enabled false widget.non-native-theme.gtk.scrollbar.round-thumb false widget.non-native-theme.gtk.scrollbar.thumb-size .85 widget.non-native-theme.scrollbar.size 14 widget.non-native-theme.scrollbar.size.override 14 general.smoothScroll false general.smoothScroll.other false general.smoothScroll.lines false general.smoothScroll.pages false general.smoothScroll.pixels false general.smoothScroll.mouseWheel false mousewheel.system_scroll_override.enabled false toolkit.scrollbox.smoothScroll false ui.scrollToClick 0 Any suggestions appreciated. Seems like it is always a fight retaining usable scrollbars in Firefox that do not hide, do not change size on mouse-over, do not "warp" on left click, do warp on center click, have a thumb that shows page size, have a background that is not white, and are not microscopic in size! Just call me "traditional" :) Thanks

منتخب شدہ حل

To get scrollbar buttons on my Linux system, I had to add the following to the file ~/.config/gtk-3.0/gtk.css. I'm using KDE so the file may be elsewhere on your DE. If you don't have it, you can create it. I think you would have to restart the browser at least and probably log out or reboot after making the change.

scrollbar {
-GtkScrollbar-has-backward-stepper: true;
-GtkScrollbar-has-forward-stepper: true;
}
اس جواب کو سیاق و سباق میں پڑھیں 👍 1

تمام جوابات (8)

more options

Did you miss this pref?

more options

cor-el said

Did you miss this pref?
  • widget.non-native-theme.gtk.scrollbar.allow-buttons = true

That was the first one I listed in my question :)

more options

OK, I missed that and only looked at the list further down. Your Firefox version might be overriding these settings.

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

more options

منتخب شدہ حل

To get scrollbar buttons on my Linux system, I had to add the following to the file ~/.config/gtk-3.0/gtk.css. I'm using KDE so the file may be elsewhere on your DE. If you don't have it, you can create it. I think you would have to restart the browser at least and probably log out or reboot after making the change.

scrollbar {
-GtkScrollbar-has-backward-stepper: true;
-GtkScrollbar-has-forward-stepper: true;
}
more options

cor-el said

OK, I missed that and only looked at the list further down. Your Firefox version might be overriding these settings. You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

I am using the official vanilla version. https://ftp.mozilla.org/pub/firefox/releases/

more options

Terry said

To get scrollbar buttons on my Linux system, I had to add the following to the file ~/.config/gtk-3.0/gtk.css. [...]

Bingo/Excellent! Thanks for that. I decided to go a bit further and researched and then did this:

scrollbar, scrollbar button, scrollbar slider {

 -GtkScrollbar-has-backward-stepper: true;
 -GtkScrollbar-has-forward-stepper: true;
 min-width: 10px;
 min-height: 10px;
 border-radius: 0;

}

Restarting just Firefox worked! As a bonus, this fixed things better in LibreOffice as well. They certainly don't make this stuff very easy or straight-forward for users.

more options

crxssi said

Also, now long-pressing is doing smooth scrolling (I never want smooth scrolling anywhere)

This has been fixed in version 117 which is currently in Beta (Bug 1847716).

more options

zeroknight said

crxssi said

Also, now long-pressing is doing smooth scrolling (I never want smooth scrolling anywhere)

This has been fixed in version 117 which is currently in Beta (Bug 1847716).

Wow, indeed you are correct:

https://bugzilla.mozilla.org/show_bug.cgi?id=1847716

Glad to know I am not the only one who found/noticed the problem, and that it is already fixed. Some of us really, really hate smooth scrolling and other animation. It goes beyond just annoying because it can also greatly slow down responsiveness when running applications remotely. It is a shame that such settings can't reliably be applied universally in Linux, but it is kinda the nature of having choice in so many aspects (desktop, window manager, toolkits, applications, etc). Thanks