تلاش سپورٹ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening Excel docs in Office instead of the browser app.

more options

I used to be able to click on an Excel doc from a web page and it would open Excel on my desktop, and the browser page would remain intact. Lately when I click on an Excel spreadsheet online, it opens the Excel app in the browser, in the current window despite the application setting in Firefox (proper file path confirmed). If I choose to open in a new tab or window this opens correctly in Excel, but also opens a blank tab/window with nothing in it. I often open several docs at once, leaving a bunch of blank tabs/windows open. I have tested this on multiple PC's and websites and get the same results, only when using Firefox. How can I prevent this from happening?

I used to be able to click on an Excel doc from a web page and it would open Excel on my desktop, and the browser page would remain intact. Lately when I click on an Excel spreadsheet online, it opens the Excel app in the browser, in the current window despite the application setting in Firefox (proper file path confirmed). If I choose to open in a new tab or window this opens correctly in Excel, but also opens a blank tab/window with nothing in it. I often open several docs at once, leaving a bunch of blank tabs/windows open. I have tested this on multiple PC's and websites and get the same results, only when using Firefox. How can I prevent this from happening?

تمام جوابات (7)

more options

Sounds like file association problems or something messed up how it set. You need to check your file association setting options from Office or if Windows File Association setting.

more options

WestEnd said

Sounds like file association problems or something messed up how it set. You need to check your file association setting options from Office or if Windows File Association setting.

Definitely not a file association issue. I have confirmed this already. Does not happen when using other browsers.

more options

Are you able to give a link that your having issue with so others can see if they are affected like what your saying?

more options

WestEnd said

Are you able to give a link that your having issue with so others can see if they are affected like what your saying?

I cannot share the specific link externally, but I have verified this is affecting other Firefox users on both Windows 7 and 10 in our office. It seems to do this on any Excel doc, regardless of domain, windows version or file association.

more options

Hi dunnd, Firefox can't handle XLS or XLSX formats on its own, you would just see a bunch of garbage on screen, unless the file is opened through a site like Office Online that can render the file as HTML for normal browsers. Is that what appears to be happening?

Opening the link in a new tab may avoid the problem by bypassing scripts attached to a link. As a workaround, you could try dragging the link up and dropping it on the address bar to see whether that triggers the Open/Save dialog. That's not convenient, but could also bypass scripts attached to that link.

You also could check your application settings on Firefox's Options page, if the script theory is wrong:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

If you scroll down to the "Files and Applications" section, you should find a box that lists Firefox's custom behaviors for different content types. Is Excel listed anywhere?

more options

jscher2000 said

Hi dunnd, Firefox can't handle XLS or XLSX formats on its own, you would just see a bunch of garbage on screen, unless the file is opened through a site like Office Online that can render the file as HTML for normal browsers. Is that what appears to be happening? Opening the link in a new tab may avoid the problem by bypassing scripts attached to a link. As a workaround, you could try dragging the link up and dropping it on the address bar to see whether that triggers the Open/Save dialog. That's not convenient, but could also bypass scripts attached to that link. You also could check your application settings on Firefox's Options page, if the script theory is wrong:
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
If you scroll down to the "Files and Applications" section, you should find a box that lists Firefox's custom behaviors for different content types. Is Excel listed anywhere?

It appears the files are opening in "Microsoft Excel Web App" when clicked on directly (only in Firefox). If I choose "edit workbook" I have the option to "edit in Excel" or "edit in Excel web app", when choosing to edit in Excel, it opens the desktop app and restores the web page where the doc is located. If I drag to the address bar it opens directly in the desktop version, as it used to with a simple left click, Leaving the web page intact. I do not get any open/save dialog at all. Opening in a new tab/window leaves a blank tab/window open in Firefox, but opens the desktop version.

I have confirmed that the "files and applications" behavior is set to open Excel files with Microsoft excel and the correct file path exists.

I cannot find anything in Excel that would allow me to set behavior for web based Excel docs.

This is kind of petty, but frustrating as I have no clue what caused this change...

more options

dunnd said

It appears the files are opening in "Microsoft Excel Web App" when clicked on directly (only in Firefox). If I choose "edit workbook" I have the option to "edit in Excel" or "edit in Excel web app", when choosing to edit in Excel, it opens the desktop app and restores the web page where the doc is located.

I'm pretty sure the link behavior is determined by the platform, maybe it's Sharepoint, and not by your personal Excel application settings. Are there any Sharepoint (or Office365 or other platform) settings you can check? What's odd is getting different behavior in Firefox vs. the other browsers you tested. Why.....