تلاش سپورٹ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Changing default colors to a dark grey background, can no longer see gmail buttons.

  • 7 جواب دیں
  • 2 میں یہ مسئلہ ہے
  • 104 دیکھیں
  • آخری جواب بذریعہ Aleksej

more options

The bright white pages of most web sites hurt my eyes and I really enjoy making pages a grey color. After changing Preferences/Content/Color/Background to a dark grey I really love how everything looks especially search pages, google calendar, gmail etc.

The problem is that many buttons have disappeared. These buttons are icons I believe so I do not understand why the background color would make them dissapear.

inspection of a gmail button that is now just an outline with no text or icon as follows:

//inner html
//outer html

منتخب شدہ حل

so I believe much of the problem lies in the fact that many icons and graphics use transparency and that may be why they cannot render when I force a dark background using FireFox preferences for color.

I did find a good solution = Color Transfrom by Peter Sloetjes, UPDATE "colorific" is even better and by the same developer.

somehow this extension is able to give me color control AND still render graphics correctly!

Cheers!

اس جواب کو سیاق و سباق میں پڑھیں 👍 0

تمام جوابات (7)

more options

This happens if you disable the website colors. The settings here affect background images.

  • Edit > Preferences > Content : Fonts & Colors > Colors :
    [X] "Allow pages to choose their own colors, instead of my selections above"

See also:

You can use the NoSquint extension to set font size (text/page zoom) and text color on web pages.

more options

This totally defeats the purpose of me choosing to have a grey background.

My goal is to have a grey background and still see buttons. Other than losing the buttons google voice and gmail look great so there must be a workaround here.

jjmk1 کی جانب سے میں ترمیمکی گئ

more options

Did you look at the NoSquint extension?

more options

i did just now try squinty and it is very glitchy it does show more of the icons but not pretty. see attached image.

more options

"[ ] Allow pages to choose their own colors" toggles also background images, and the icons are created using background-image (as you can see using Inspector's Computed view).

See "cant change color on visited sites without changing background /foreground colors that hide options on the sitec" for some suggestions, one of them chosen by the question author.

Aleksej کی جانب سے میں ترمیمکی گئ

more options

منتخب شدہ حل

so I believe much of the problem lies in the fact that many icons and graphics use transparency and that may be why they cannot render when I force a dark background using FireFox preferences for color.

I did find a good solution = Color Transfrom by Peter Sloetjes, UPDATE "colorific" is even better and by the same developer.

somehow this extension is able to give me color control AND still render graphics correctly!

Cheers!

jjmk1 کی جانب سے میں ترمیمکی گئ

more options

jjmk1 said

so I believe much of the problem lies in the fact that many icons and graphics use transparency and that may be why they cannot render when I force a dark background using FireFox preferences for color.

It is because, when you force a dark background using the checkbox, you also prohibit use of background images. There is no meaningful HTML except for an id or a class to which the CSS attaches a "background" image (which is probably a simply bad practice).

Aleksej کی جانب سے میں ترمیمکی گئ