Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

My hhomepage and Search Engine has been hijacked by Speedbit How do i remedy

  • 6 відповідей
  • 54 мають цю проблему
  • 5 переглядів
  • Остання відповідь від Bongoboy

more options

I need to have Mozilla as my homepage and Google for my search engine. Every time I load Firefox after resetting the above it has recerted to Speedbit home and Speedbit search. I have even tried deleting Speedbit search from my search engines but it always comes back as the default search engine and /speedbit home always comes back as the homepage!

Усі відповіді (6)

more options

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

more options

Xircal , Your identified change for the search bar using 'about:config' and 'keyword.url' has worked a treat. However the attempt to control the homepage is only partially correct. When I close and re-open firefox, the homepage remains correcly set in options but Speedbit home comes up as the URL address. When I click the home button I then get the correct homepage. A step forward but still being hijacked to a lesser extent. Regard

more options

Please check the value in about:config for browser.startup.page

See: http://kb.mozillazine.org/Browser.startup.page

more options

I have posted the solution here. Goto the last of the page and you shall find the solution.

https://support.mozilla.com/en-US/questions/797953#answer-169330

more options

Nothing seems to work.

I have (a) Done precisely what upk_singhm said above

           (b) Used Regedit to get rid of all references to speedbit
           (c) Uninstalled anything and everything to do with Speedbit     

I even used speedbit's own utility - THAT WAS a disaster - should have known better - it actually renamed the Google search in the search bar to speedbit.com ... very nasty indeed.

STILL COMES BACK!

This is evil stuff ..... will never, ever have anything to do with DAP or speedbit again. Strongly suggest everyone ditches it pronto.

Змінено Andrewajw

more options

I'm up the wall with speed bit. However, I may have dropped lucky. I've not put this to the test because I don't want to reboot my PC. Try this go to DAP download accelerator and on the right hand side of home page there is a paragraph saying new speed bit home page, I've just unchecked it and will see if its done the trick.