Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Yahoo has hijacked my browser.

  • 4 відповіді
  • 1 має цю проблему
  • 19 переглядів
  • Остання відповідь від jscher2000

more options

Yahoo has hijacked my browser. I googled how to fix it, and I reset the default on the left hand side, actually I didn't have to reset it already had my default as firefox. On the right hand menu bar I don't have an 'options' icon, add-ons and themes brings up a blank page. Please advise... Thank you!

Усі відповіді (4)

more options

Apparently, Yahoo hides itself so it can't be removed...


more options

Hello Cindi,

When you say "hijack" what comes to mind is an old app called "HiJack This".

While i do not know if you double checked all of your FF settings and preferences, and then removed all references to Yahoo, you could try the above app.

Just be advised that the app will give you lots of lines items. But do not remove them because some hijacks are actually helpers.

So just look for Yahoo and feel free to delete those entries.

Keep us appraised


more options

I checked all of the preferences. Yahoo is not even listed as an option. My default was already on Firefox. I tried all of the other default options, Ebay, amazon, etc, each time it still goes back to Yahoo, which isn't even listed as an option. I'll try hijack this... Thank you, I'll let you know how it goes.


more options

Usually this kind of hijack is caused by an add-on or by external malware. Let's start with the add-on angle:

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search or privacy? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

If that section of the Add-ons page is blank or inaccessible:

Try accessing the page in Firefox's Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the option/alt key when starting Firefox. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Can you regain control of your default search setting?



Щоб відповідати на повідомлення, ви повинні увійти в свій обліковий запис. Задайте нове питання, якщо ви ще не маєте облікового запису.