Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

mutiple firefox sessions running, yet I only opened one.

  • 2 відповіді
  • 1 має цю проблему
  • 119 переглядів
  • Остання відповідь від cor-el

more options

I am running Windows 10 and I use firefox for internet access as my browser. Things drag on when I open Firefox. And then I check Task manager and I see, 4, 5 sessions running, all dragging down memory in a big way. Slows the my PC. I am on the latest update and also have done resets. But that does not fix it. Any idea of how to only have Firefox run a session only when opened? And not fire up multiple sessions even though I only started one browser session? Thanks very much

I am running Windows 10 and I use firefox for internet access as my browser. Things drag on when I open Firefox. And then I check Task manager and I see, 4, 5 sessions running, all dragging down memory in a big way. Slows the my PC. I am on the latest update and also have done resets. But that does not fix it. Any idea of how to only have Firefox run a session only when opened? And not fire up multiple sessions even though I only started one browser session? Thanks very much

Обране рішення

It is quite normal to see more Firefox processes running.

  • process for the main Firefox thread (user interface)
  • one or more content processes, see:
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • process for the compositor thread
  • process for extensions
  • process for WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information"
    "Application Basics": Multiprocess Windows
    "Remote Processes" further down

See also the about:memory page for information about the process IDs.

You can possibly set the number of content processes to 1.

Читати цю відповідь у контексті 👍 0

Усі відповіді (2)

more options

Read this www.ghacks.net/2016/07/22/multi-process-firefox/

If you want to disable multi sessions then try going to <about:config> and make sure you have these values set. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

more options

Вибране рішення

It is quite normal to see more Firefox processes running.

  • process for the main Firefox thread (user interface)
  • one or more content processes, see:
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • process for the compositor thread
  • process for extensions
  • process for WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information"
    "Application Basics": Multiprocess Windows
    "Remote Processes" further down

See also the about:memory page for information about the process IDs.

You can possibly set the number of content processes to 1.