Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

hi, i am trying to debug remotely. its almost there. i can see the title of my application under tabs. but i get an empty page when i click inspect?

  • 6 відповідей
  • 3 мають цю проблему
  • 11 переглядів
  • Остання відповідь від Seburo

more options

i am , of course using the firefox browser on my phone and on my laptop.

my phone firefox browser is 68.5.0 and my laptop firefox browser is 74.0b9 64 bit. is this correct? (see image "has old version") i can even see my web application on my laptop displaying its home page on my phone, and, in the debugging runtime page, i see the url to my web application, which again resides on my laptop. (see image "my project shows up and my projects url show") i am using visual studio. but when i click inspect, i get a new blank browser page? (see image "the blank page on inspect"

thanks for any advice

Прикріплені знімки екрана

Усі відповіді (6)

more options

As an addendum, i only mention visual studio to say that this is where i do my development for this phone web application.

The title of my home page has "Feel Free to register"

this is the url on the blank page, but this time it showed me an error:

the URL - about:devtools-toolbox?type=tab&id=13&remoteId=4200a18106de56c1%7C%40org.mozilla.firefox%2Ffirefox-debugger-socket-usb

The verbiage for the error is : ERROR TypeError: this.topWindow is null

thanks again.

more options

Another addendum - this is a fuller print screen.

this shows another url and description that belongs to my application: '''Mobile Log in - My Body Science Analysis Mobile http://192.168.1.6:51700/Account/Login'''

sorry, just want you folks to get as much info about my issue as possible.

more options

LAST ONE - I have been through the about:debugging several times.

more options

Been getting the same if you figure out your own please pass on my thanks to all

more options

FreeDaReal,

  i have two things for you. 

1) Got this from kbronsnan, as an answer to another post i made: Firefox for Android is getting a rewrite. As part of that work Firefox for Android is locked on Gecko version 68. To use the remote debugging tools use Firefox Preview.

https://play.google.com/store/apps/details?id=org.mozilla.fenix

2) and this is the answer i found myself:

https://bugzilla.mozilla.org/show_bug.cgi?id=1594477 

I always test things with firefox first, then chrome. ok, so, this will crack you up or piss you off, or both. Apparently , the lastest desktop firefox version 74.0 is NOT the one to use with the latest firefox for android 68.5.0. read below and start using the WebIDE. Still not as good as chrome remote debugging IMO.

Maciej Jaros

Comment 4 • 5 days ago

I get exactly the same problem, but with latests Firefox Developer Edition. Connecting to: Mozilla Firefox (68.5.0) on Android 10. Connecting from: Firefox Developer Edition (74.0) on Windows 10. Trying to connect from "Mozilla Firefox (72.0.2)" results in the same error. The connection with this device used to work fine last time I checked. Maciej Jaros

Comment 5 • 5 days ago

Similar when connecting from Firefox Nightly (75.0a1)... So I don't think this is just a problem with a debugger not being fresh-enough. Unless you mean that Firefox on Android ("debuggee"?) should be only 7 days old... And I really hope you don't mean that

more options

Hi

Apologies for the delay in responding, but I agree that you should look to use Firefox Preview for any work you are doing in this area.