Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Gmail Password invalid but only for IMAP

  • 7 відповідей
  • 3 мають цю проблему
  • 515 переглядів
  • Остання відповідь від Boltnut

more options

I'm attempting to set up my primary Gmail using IMAP in Thunderbird. Whenever I attempt the set up, the password registers as invalid. If I switch the configuration to POP, I can connect. I'm not sure what else to try

I have 2 factor authentication I have IMAP turned on in Gmail I have created an app password for Thunderbird Per the Gmail suggested troubleshooting I allowed outside apps

Обране рішення

First, you should be using OAuth2 authentication when adding an IMAP gmail account (which is the default in the setup wizard), and use your normal account password. Second, you should have TB 60.9.1 or 68.2.1, which include a fix for google OAuth2 changes. An app password is only necessary if you use 'normal password' authentication, instead of OAuth2 (or use POP, which can't apply OAuth in TB).

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

Читати цю відповідь у контексті 👍 1

Усі відповіді (7)

more options

Вибране рішення

First, you should be using OAuth2 authentication when adding an IMAP gmail account (which is the default in the setup wizard), and use your normal account password. Second, you should have TB 60.9.1 or 68.2.1, which include a fix for google OAuth2 changes. An app password is only necessary if you use 'normal password' authentication, instead of OAuth2 (or use POP, which can't apply OAuth in TB).

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

more options

Ah, I was running 60.8.0. I was certain I had just run an update earlier today, but I suppose not.

Once I updated I was able to log in successfully though, thank you!

more options

I am running 60.9.0 and I don't see any location where I can get 60.9.1 - is that in any repository?

more options

winickjr said

I am running 60.9.0 and I don't see any location where I can get 60.9.1 - is that in any repository?

If you're on Windows or OS X, 60.9.0 should update to 60.9.1 from Help/About TB. If you're on Linux and your distro hasn't released 60.9.1, there is a TB version. Or, you can apply the workaround in Edit/Preferences/Advanced/General/Config. editor.

more options

I'm attempting to change my Gmail password and its original ones are SSL/TLS/OAuth2 authentication in Thunderbird v68.3.1. It can NOT work. Therefore I had removed and added it, but the result is same.

more options

Boltnut said

I'm attempting to change my Gmail password and its original ones are SSL/TLS/OAuth2 authentication in Thunderbird v68.3.1. It can NOT work. Therefore I had removed and added it, but the result is same.

If you changed the password, make sure the old ones for imap:// and smtp:// are deleted from Options/Security/Passwords/Saved Passwords, then restart TB and enter the new one when adding the account. Also, check your TB version is 60.9.1 or 68.3.1.

more options

Thanks. It can work now after removing the old one from Options/Security/Passwords/Saved Passwords.