Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Spell checker stopped working when I upgraded to 61.0.2

  • 9 відповідей
  • 1 має цю проблему
  • 57 переглядів
  • Остання відповідь від nancygal

more options

I just upgarded to 61.0.2. Spell checker has stopped working. The check my spelling box is still ticked and the dictionaries still installed.

Обране рішення

nancygal said

Thank you all for your help. Here's what I did. I tried in safe mode as instructed. No change. I then to install the English (GB) Language Pack. I got this error message “This add-on requires a newer version of Firefox (at least version 62.0). You are using Firefox 61.0.”. Which is strange as I can find no trace of version 62 to install. So I re-installed Firefox and the British Dictionary as suggested by cor-el. The problem is now resolved. Thanks again.

The Language pack is for the language of the User Interface or UI of Firefox. It is Dictionaries you need for spellchecker as they add a pack of words for the spellchecker to use much like a dictionary book.

Only a few locales at most comes with a Dictionary due to license reasons as the en-GB locale does not come with a dictionary.

Mozilla updated most of the Language Packs as of Aug 27 for Firefox 62.0 even though it is not scheduled for Release until September 5th. You can scroll down to the Versions link and install the previous version of a Language Pack for 61.*

Читати цю відповідь у контексті 👍 1

Усі відповіді (9)

more options

It could be that one of your add-ons (if you have any) is causing this, like e.g. 'English (GB) Language Pack'.

Let's try Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

more options

^A language pack doesn't have anything to do with the spelling checker.

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Note that you need a dictionary and not a language pack that provides string translations for the user interface.

You can check the layout.spellcheckDefault pref on the about:config page.

more options

cor-el said

^A language pack doesn't have anything to do with the spelling checker. Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.
  • open the "Add Dictionaries" link to install a dictionary if you do not have one.
The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can enable or disable spell checking globally:
  • Options/Preferences -> General: Browsing: "Check my spelling as I type"
You can look here for dictionaries: Note that you need a dictionary and not a language pack that provides string translations for the user interface. You can check the layout.spellcheckDefault pref on the about:config page.

You seem to have not read the question . . .

more options

McCoy said

It could be that one of your add-ons (if you have any) is causing this, like e.g. 'English (GB) Language Pack'. Let's try Safe Mode : If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !) See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

The problem only started when I upgraded to the latest version of Firefox. It was fine till then.

more options

nancygal said

The problem only started when I upgraded to the latest version of Firefox. It was fine till then.

I see your point. Add-ons get updated as well (or they should be) and things do change (as you have noticed, unfortunately). But Safe Mode does not just disable add-ons - would you give it a try, just to make sure  ?

more options

What I should have asked you before :

Would you mind telling us which dictionaries you have installed  ?

more options

Thank you all for your help. Here's what I did. I tried in safe mode as instructed. No change. I then to install the English (GB) Language Pack. I got this error message “This add-on requires a newer version of Firefox (at least version 62.0). You are using Firefox 61.0.”. Which is strange as I can find no trace of version 62 to install. So I re-installed Firefox and the British Dictionary as suggested by cor-el. The problem is now resolved. Thanks again.

more options

Вибране рішення

nancygal said

Thank you all for your help. Here's what I did. I tried in safe mode as instructed. No change. I then to install the English (GB) Language Pack. I got this error message “This add-on requires a newer version of Firefox (at least version 62.0). You are using Firefox 61.0.”. Which is strange as I can find no trace of version 62 to install. So I re-installed Firefox and the British Dictionary as suggested by cor-el. The problem is now resolved. Thanks again.

The Language pack is for the language of the User Interface or UI of Firefox. It is Dictionaries you need for spellchecker as they add a pack of words for the spellchecker to use much like a dictionary book.

Only a few locales at most comes with a Dictionary due to license reasons as the en-GB locale does not come with a dictionary.

Mozilla updated most of the Language Packs as of Aug 27 for Firefox 62.0 even though it is not scheduled for Release until September 5th. You can scroll down to the Versions link and install the previous version of a Language Pack for 61.*

Змінено James

more options

Thanks for explaining, James. Much appreciated!