Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

32 and 64 bit in Win 7 w/all addons disabled uses up to 3.8 GB RAM, but OK in Safe mode

  • 13 відповідей
  • 3 мають цю проблему
  • 6 переглядів
  • Остання відповідь від OldWilly

more options

I run add-ons that always worked well for me before upgrading from 32 bit to 64 bit (64 bit forced on me when I tried to update). The add-ons seem to work properly in the 64 bit version after checking compatibility and updating as needed. When I run video (mostly from YouTube, but also other sites) the memory usage grows until the system locks up (starting at about 1.7 GB and max out around 3.8 GB or better). When I disable ALL add-ons I still get the same problem, but when I restart in safe mode it runs well. I emphasize this occurs with both the 64 bit and the 32 bit versions 56.0.2. I have also tried setting the video hardware acceleration with no effect. Please also note that I had uninstalled the 32 bit version after installing the 64 bit version. I also uninstalled the 64 bit version before re-installing the 32 bit version. An example of the video that causes a problem is: https://www.youtube.com/watch?v=PdysW4Pw_SE

I run add-ons that always worked well for me before upgrading from 32 bit to 64 bit (64 bit forced on me when I tried to update). The add-ons seem to work properly in the 64 bit version after checking compatibility and updating as needed. When I run video (mostly from YouTube, but also other sites) the memory usage grows until the system locks up (starting at about 1.7 GB and max out around 3.8 GB or better). When I disable ALL add-ons I still get the same problem, but when I restart in safe mode it runs well. I emphasize this occurs with both the 64 bit and the 32 bit versions 56.0.2. I have also tried setting the video hardware acceleration with no effect. Please also note that I had uninstalled the 32 bit version after installing the 64 bit version. I also uninstalled the 64 bit version before re-installing the 32 bit version. An example of the video that causes a problem is: https://www.youtube.com/watch?v=PdysW4Pw_SE

Обране рішення

Sorry to disagree a bit ;) , but you should click the Show more link or OS selector drop-down on that page to see other OS drivers, so you should land here or here. I’m absolutely sure 15.17.19.64.2869 is the latest one for 32-bit - the .2993 one may be suitable for 64-bit only and is what you would need, regardless of Firefox being 32-bit. Intel does not even list a .1840 version, probably because it’s rather old.

Side note: the .2869 version is the only one supporting hardware acceleration in Firefox, though that (or at least part of it) was blocked as of Firefox 38, unfortunately.

A new profile contains no settings, bookmarks or history from any other profile (that’s what profiles are intended for), but you could import/copy them nevertheless. The point however is just to work with a clean profile temporarily in order to see if the issue occurs, so I would import as little as possible. When done properly, you could create a new profile and play the affected video within 3 minutes.

Читати цю відповідь у контексті 👍 1

Усі відповіді (13)

more options

A suggestion since your video card is so old that last drivers for it where for XP in 2009 is to move to the Extended Release Version 52.4.1 Is a thought as it would preform much better for you but of course has limitations as it only gets security updates.

Should have had your Extensions enabled when you sent this as would have been able to tell things instead of having you hunt.

Ok......Mozilla experiment, called 'Shield Studies'. Without even knowing it, you may have volunteered for this Mozilla experiment. Would you go to : Options => Privacy & Security => under 'Data Collection and Use' : Did you uncheck : 'Allow Firefox to install and run studies ' or is it checked  ?

To check if you are enrolled in these studies : Type in the address bar about:studies

Any extensions that you see listed there, you can either disable or remove, just like Safe Browsing version 4 (at the end of the experiment they will be disabled anyway). See for further information : https://support.mozilla.org/en-US/kb/shield

and

You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://kb.mozillazine.org/about:config Also can reverse everything this tells you to enable it. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow: Firstly, I should have explained what I have as a PC: Dell Inspiron 560 Minitower, Genuine Windows 7 Home Premium, 64bit, English Sysinfo: OS Name Microsoft Windows 7 Home Premium Version 6.1.7601 Service Pack 1 Build 7601 Other OS Description Not Available OS Manufacturer Microsoft Corporation System Name BILL-PC System Manufacturer Dell Inc. System Model Inspiron 560 System Type x64-based PC Processor Pentium(R) Dual-Core CPU E6700 @ 3.20GHz, 3203 Mhz, 2 Core(s), 2 Logical Processor(s) BIOS Version/Date Dell Inc. A06, 12/1/2010 SMBIOS Version 2.6 Windows Directory C:\Windows System Directory C:\Windows\system32 Boot Device \Device\HarddiskVolume2 Locale United Kingdom Hardware Abstraction Layer Version = "6.1.7601.17514" User Name Bill-PC\Bill Time Zone Pacific Daylight Time Installed Physical Memory (RAM) 4.00 GB Total Physical Memory 3.96 GB Available Physical Memory 2.28 GB Total Virtual Memory 7.93 GB Available Virtual Memory 6.13 GB Page File Space 3.96 GB Page File C:\pagefile.sys (Ignore the reference to United Kingdom - I use it in the U.S. with English U.S. on the west coast - it was purchased by me to support my cusromer in the UK)

The video is: Intel G45/G43 Express Chipset (but yes - the driver is dated 2009)

I do also run XP on another platform with ESR 52, but this is not where I have the problem.

All three options under Firefox Data Collection and use are checked. (Allow Firefox to automatically send technical and interaction data to Mozilla Allow Firefox to install and run studies Allow Firefox to send crash reports to Mozilla)

The only item under about:studies is the safe browser and I had already disabled it in the Add ons settings.

I had already done this a few days ago: dom.ipc.processCount to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

I had already visited that site: http://www.ghacks.net/2016/07/22/multi-process-firefox/

Let me be clear - if I restart in safe mode thereby disabling all add ons, then I have NO problem. If I start FF with having first disabled ALL add ons, then I have a problem.

more options

Try the 32-bit Firefox version in case some drivers aren't working properly with 64-bit Firefox.

You can also try to disable hardware acceleration in Firefox.

You need to close and restart Firefox after toggling this setting.

more options

cor-el: Thank you for your attempt. At the end of my initial post I wrote: "I also uninstalled the 64 bit version before re-installing the 32 bit version. An example of the video that causes a problem is: https://www.youtube.com/watch?v=PdysW4Pw_SE" Which means, of course, the problem persists with either the 32bit or 64bit versions.

Regarding the hardware acceleration - I only enabled it AFTER I first encountered the memory run away problem.

Since, so far, there appears to be no viable solution yet presented, I will just go ahead and manipulate what settings seem to be involved all over again. Yes, I will try to remember to restart Firefox after the changes.

Thank you for your attempts.

more options

The video you mentioned causes no issue here on a similar setup (32-bit G41 chipset), and uses less memory.

First thought: in Safe Mode, any additional themes are also disabled and some default settings are used. Do you have any other than the default themes, and left it enabled? Have you ever changed some preferences for graphics in about:config perhaps?

For the same reason, can you reproduce the issue in a clean profile?

Note that Firefox needs a restart after disabling hardware acceleration. With regard to that, I know the Intel G41 graphics chipset can suffer some issues in when hwa is enabled - I’m not sure if that applies to the G43/45 too.

Your video driver version is 8.15.10.1840 and seems a bit outdated (unless provided by Dell?). You can try to install newer ones from Intel.

more options

Tonnes: Thank you for your efforts. Regarding the HWA, I did not enable that until after experiencing the memory problem

The driver for the G43/G45 Intel chipset is the latest, 3 April 2009. Intel has ended support for this. I will check with Dell to see if they have anything later (I have been using this PC since 2011, bought new from Dell).

I do not believe I have any additional themes enabled. I am a "get the job done" type of person and prefer as close to the "classic" style I can get.

I do not recall having made any changes to the config settings for graphics other than the HWA, which I set through the standard options setup.

I currently have disabled the HWA.

Perhaps I can attempt the "clean profile" you suggest and then post my results here.

more options

Odd, I’m pretty convinced the latest driver offered by Intel should be 8.15.10.2869/15.17.19.2869 dated November 2012 (same as for the G41/G43), and even a newer one for 64-bit (only; 15.22.58.64.2993) - note the yellow bar on its page. I did submit a wrong link above - this is the proper one - but they’re similar and I see no 2009 version listed as latest either, unless you referred to the one provided by Dell that may be newer, but it would be better to check there based on computer’s ID. Your current version date also seems to point to a version as provided by Microsoft (check the file properties to whose are used), and they appear to offer newer ones too. Nevertheless, you should be able to install the latest one from Intel.

Of course, a thought might be that "this driver caused no issues before", but chances are Firefox had something changed that started to affect a particular driver version at some point, as you may understand. In my experience, computer / mainboard manufacturers also offer updates later than chipset manufacturers, or not even at all if there are no complaints.

I’m eager to see what a new profile does, so it may be better to try that first.

more options

Tonnes: I was wrong about the driver date, memory glitch, it is dated 7/3/2009 (version 8.15.10.1840). I did note the yellow bar on the update page and this led me to believe there was no update available. I also installed the Intel Driver & Support Assistant, which told me there was no update available.

Your first driver link is to a driver for WinXP 64 bit, but I am running Win 7 64 bit.

Per you suggestion, I will try a new profile (hopefully, my history and bookmarks will be preserved).

If the new profile does not solve the problem, then I will attempt the driver offered by Dell from your second link.

(This problem is all due to my being forced to the 64 bit version of FF by the FF installer when the online update of the 32 bit version of FF failed. Perhaps my not first uninstalling the 32 bit version before launching the 64 bit version introduced this problem. I did uninstall the 32 bit version, but the problem did not go away. I AM CURRENTLY RUNNING THE 32 bit version. of FF, which I reverted to when I could not solve the problem)

more options

Вибране рішення

Sorry to disagree a bit ;) , but you should click the Show more link or OS selector drop-down on that page to see other OS drivers, so you should land here or here. I’m absolutely sure 15.17.19.64.2869 is the latest one for 32-bit - the .2993 one may be suitable for 64-bit only and is what you would need, regardless of Firefox being 32-bit. Intel does not even list a .1840 version, probably because it’s rather old.

Side note: the .2869 version is the only one supporting hardware acceleration in Firefox, though that (or at least part of it) was blocked as of Firefox 38, unfortunately.

A new profile contains no settings, bookmarks or history from any other profile (that’s what profiles are intended for), but you could import/copy them nevertheless. The point however is just to work with a clean profile temporarily in order to see if the issue occurs, so I would import as little as possible. When done properly, you could create a new profile and play the affected video within 3 minutes.

more options

Tonnes: "You da man" - Yes, I failed to show more and find the correct driver. Before trying to update the driver, I did create a new profile with no addons. I still had the same problem.

I then downloaded the new driver (Win7Vista_64_151719). As usual, a generic update package throws my desktop into the cement mixer and comes out looking like garbage. (I love shortcuts - being a computer professional, I have scads of processes I run and shortcuts are the essence of hypertext). The driver update appears to be successful and does seem to solve the problem - at least it keeps the total RAM usage around 2.5 GB or less testing with the same video I described in my initial post.

I am mystified why the video had no problem when in safe mode with the latest FF and the previous version of FF had no problem until installing the 64 bit version (of course, I am still running the 32 bit version, since both had this problem).

My next step is to return to the 64 bit FF version in hopes that the problem will remain solved. It may be a day or two before I try that.

Thanks again for your help.

more options

Thanks to Pkshadow, cor-el and Tonnes for your prompt and erudite assistance. I am back on the 64 bit version and the memory problem is resolved. Who would have thought the video driver would be "the culprit" without enabling the hardware acceleration?

Let's set this problem to bed. :)

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

more options

As Pkshadow suggests, here is the solution: My system: OS Name Microsoft Windows 7 Home Premium Version 6.1.7601 Service Pack 1 Build 7601 Other OS Description Not Available OS Manufacturer Microsoft Corporation System Manufacturer Dell Inc. System Model Inspiron 560 System Type x64-based PC Processor Pentium(R) Dual-Core CPU E6700 @ 3.20GHz, 3203 Mhz, 2 Core(s), 2 Logical Processor(s) BIOS Version/Date Dell Inc. A06, 12/1/2010 SMBIOS Version 2.6 Windows Directory C:\Windows System Directory C:\Windows\system32 Boot Device \Device\HarddiskVolume2 Hardware Abstraction Layer Version = "6.1.7601.17514" Installed Physical Memory (RAM) 4.00 GB Total Physical Memory 3.96 GB Available Physical Memory 2.28 GB Total Virtual Memory 7.93 GB Available Virtual Memory 6.13 GB Page File Space 3.96 GB Page File C:\pagefile.sys

The solution was to update the video driver for the Intel G45/G43 Express Chipset. What I had when the problem was detected was the 2009 version. The solution was to install the Win7Vista_64_151719 dated 2012 from Intel ( link https://downloadcenter.intel.com/downloads/eula/22167/Intel-Graphics-Media-Accelerator-Driver-Windows-7-64-Windows-Vista-64-exe-?httpDown=https%3A%2F%2Fdownloadmirror.intel.com%2F22167%2Fa08%2FWin7Vista_64_151719.exe ),