Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Sul mio dispositivo non riesco a visualizzare in versione mobile alcuni siti, tra cui Vogue.it. Un mio amico che ha la stessa versione di Firefox, sì.

  • 4 відповіді
  • 8 мають цю проблему
  • 19 переглядів
  • Остання відповідь від pEnTiCtOn

more options

I cannot display some mobile-friendly web sites (p.e. Vogue.it) on my Android Smartphone. A friend of mine, having the same Firefox version for Android, can!

I cannot display some mobile-friendly web sites (p.e. Vogue.it) on my Android Smartphone. A friend of mine, having the same Firefox version for Android, can!

Усі відповіді (4)

more options

That particular site doesn't seem to have a mobile version, I tried loading it with both a desktop and mobile useragent string and there was no difference that I could see.

You can set a default useragent string to view ALL sites in mobile mode if available by typing in about:config then click the plus sign to add a new value.

Add general.useragent.override to the NAME field. Change the type from BOOLEAN to STRING. Add Mozilla/5.0 (Android 4.4.2; rv:42.0) Gecko/42.0 Firefox/45.0.1 to the STRING field.

This will tell every site you visit that you want to view it in mobile mode if available.

You can also set it up to be site specific by adding general.useragent.override.SITEADDRESSHERE.COM

And for each site specific one you add you can either use a desktop string or a mobile string to suit your preference.

Here are a couple of strings;

Desktop View/Mode: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/45.0.1

Mobile View/Mode: Mozilla/5.0 (Android 4.4.2; rv:42.0) Gecko/42.0 Firefox/45.0.1

Oh, also make sure you enable general.useragent.site_specific_overrides by setting it to TRUE.

I hope this helps.

Змінено pEnTiCtOn

more options

Hi There, Thanks for your tips. I did your first suggestion and set general.useragent.site_specific_overrides to True, but it didn't work. Moreover vogue.it actually has a mobile version, in fact, my friend can correctly display it on his phone and I did the same when I used Chrome on my mobile device.

more options

Is it possible your friend was using the vogue.it app instead of a browser page? I was unable to find any difference between viewing the vogue.it page in mobile mode or in desktop mode, but I was able to find they have an app in the apple store, which displays all its sites pages inside the mobile app: https://itunes.apple.com/us/app/vogue-italia/id592704749?mt=8

But then again, you said it worked for you in Chrome. Could you post screen shots of both versions so I can see the differences?

Normally I wouldn't go this much in depth, but now it's bothering me too! Hehe.

Below is a screen shot of how the pages look in the app:

Змінено pEnTiCtOn

more options

I think I figured it out!

I loaded the site with my smartphone instead of my tablet & I see now that it displays a less robust site when I use a smaller screen device.

I'm assuming the site somehow knows the users screensize and displays the page accordingly. This still doesn't explain how you were able to see the mobile version on chrome but not in Firefox, maybe someone else can weigh in on this?