Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Firefox crashes

  • 10 відповідей
  • 3 мають цю проблему
  • 45 переглядів
  • Остання відповідь від mozillaboy

more options

Good morning,

I’ve been struggling with a crash issue for a long time now and finally had to give up on Firefox and go to Safari. Still would like to get back to firefox, but can’t afford having my computer lock up after 5 minutes of having firefox open. The problem began a good six months ago and I stopped using the English version of Firefox and used a Swedish version which gave me no problems. Then recently, I started trying to trouble shoot the EN version and, after having no success I tried going back to the SV version and it too began to lock up my machine.

I’m running the most current version of FF.

I've gone through the Refresh process.

I have no extensions, plugins, add-ons etc. that I’m aware of.

OSX is current (10.9.5)

Drivers don’t need updating that I’m aware of - all I have is standard Macbook Pro - no customized hardware, etc.

I have no internet security software.

The problem occurs in Safe Mode.

Check my hardware?

I’ve run the Rember program which showed that my memory is fine.

Hardware acceleration is disabled.

Don’t know if there’s anything that can be done. I run Firefox from Applications > Firefox > enFirefox (I have about 12 other versions of Firefox, e.g., heFirefox, elFirefox, cyFirefox, ruFirefox) svFirefox was the only one I was able to use for the longest time and then after trying to troubleshoot my EN version, I went back to the SV and it caused crashes as well.

Last crash ID (9/2/15) bp-617703b2-943c-4c9a-8b99-a083f2150902

Усі відповіді (10)

more options

Seems to be a graphics problem, try to disable Hardware Acceleration in FF preferences > Advanced > uncheck 'Use Hardware Acceleration When Available'.

more options

I'm amazed that you have so many different languages of Firefox; I feel very monolingual now...

Since you already disabled hardware acceleration, you might try turning off a couple features that were added in recent versions to see whether those make any difference:

(Warp GL - Firefox 37)

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.d3d11.disable-warp preference to switch it from false to true

I don't know whether this takes effect immediately or after you exit and start Firefox up again.

(OMTC - Firefox 33)

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false

I don't know whether this takes effect immediately or after you exit and start Firefox up again.

Note: I read in a bug report that this change causes problems with the HTML5 player on YouTube, if hardware acceleration is also disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

more options

Thank you l3v147h4n for your suggestion. I've made sure that hardware acceleration is deactivated and

jscher2000 I went ahead and followed your suggestions, though I was unable to find “layers.d3d11…” I did find and change to false “layers.offmainthread…”

Now rather than locking up my machine, FF simply won’t load pages (the tabs show “connecting…” whether it’s to google, or craigslist or Facebook… Then, when I try to close FF it won't respond and when I use Activity Monitor to try to shut it down, the whole computer locks up. :-/

more options

Sorry, the d3d11 must be for Windows only. Can you find another preference that refers to "warp"?

more options

I was actually unable to find anything that refers to "warp". :-/

more options

Sorry, I am not familiar with Mac-specific graphics stuff.

Do you have any other recent crash report IDs that might point to specific things?

more options

Thanks for your help all the same. I actually don't have any more recent crash reports.

more options

You can try to disable WebGL and set webgl.disabled to true on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


more options

Hi cor-el, Thanks for making the suggestion. I was finally able to attempt it (full course-load at college is kicking my butt!) and I made the webgl.disabled change you suggested and not long after making the change the thing locked up and I had to restart my computer. Doesn't seem to have helped.

more options

Over the weekend I upgraded to El Capitan (the most current version of OSX) and I thought it might make a difference in Firefox's performance. It didn't. :-/ Firefox still caused my computer to lock up.