Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Can only install on Windows 7 in Administrator Mode, then doesn't receive links clicked in other programmes

  • 2 відповіді
  • 1 має цю проблему
  • 3 перегляди
  • Остання відповідь від dancapp

more options

I had Firefox installed on my Windows 7 system fine, but the automatic update never worked ("The partial update could not be completed...") until I manually started firefox in administrator mode. The solution I found (on this forum) was to simply reinstall firefox.

So I downloaded the latest stub file and uninstalled my existing firefox install. Then I click the stub exe and literally nothing happens - no error message, just nothing. The solution I find to this is to download the full non-stub exe, turn off my anti-virus and try installing that. I click the non-stub exe, get asked to confirm 'Run', then it unpackages and... does nothing. Again. No error, the process just disappears and I'm left back at square one.

I know from experience with problems installing other programmes that I can usually solve it by running the install exe in administrator mode, but I wanted to avoid this for the reason I'm about to explain:

I installed firefox in administrator mode and it worked just fine. Problem is, when I use firefox now it seems to automatically be an 'elevated', 'administrator' version of the program and does not communicate properly with the rest of my system. For example, if I click a link in an email (in Thunderbird), even though firefox is my default browser, nothing happens - the link doesn't get sent to firefox. I have to manually copy and paste it into the browser. This is exactly what would happen on my last installation of firefox when I would sometimes start the program in administrator mode in order to let the auto update work properly.

I've not had any firefox updates since this latest install but I suspect I may have the very same problem that caused me to do all this in the first place - auto updates failing every time. Even if not there's still a big problem here.

Any suggestions?

PS: My account is an admin account, on Windows 7, and I've googled for hours and found similar issues reported but no cast iron solution.

I had Firefox installed on my Windows 7 system fine, but the automatic update never worked ("The partial update could not be completed...") until I manually started firefox in administrator mode. The solution I found (on this forum) was to simply reinstall firefox. So I downloaded the latest stub file and uninstalled my existing firefox install. Then I click the stub exe and literally nothing happens - no error message, just nothing. The solution I find to this is to download the full non-stub exe, turn off my anti-virus and try installing that. I click the non-stub exe, get asked to confirm 'Run', then it unpackages and... does nothing. Again. No error, the process just disappears and I'm left back at square one. I know from experience with problems installing other programmes that I can usually solve it by running the install exe in administrator mode, but I wanted to avoid this for the reason I'm about to explain: I installed firefox in administrator mode and it worked just fine. Problem is, when I use firefox now it seems to automatically be an 'elevated', 'administrator' version of the program and does not communicate properly with the rest of my system. For example, if I click a link in an email (in Thunderbird), even though firefox is my default browser, nothing happens - the link doesn't get sent to firefox. I have to manually copy and paste it into the browser. This is exactly what would happen on my last installation of firefox when I would sometimes start the program in administrator mode in order to let the auto update work properly. I've not had any firefox updates since this latest install but I suspect I may have the very same problem that caused me to do all this in the first place - auto updates failing every time. Even if not there's still a big problem here. Any suggestions? PS: My account is an admin account, on Windows 7, and I've googled for hours and found similar issues reported but no cast iron solution.

Усі відповіді (2)

more options

hello dancapp, since this can sometimes be caused by malware active on a system, please run a scan with different security tools like the free version of malwarebytes, adwcleaner & microsoft safety scanner.

Troubleshoot Firefox issues caused by malware

more options

Thanks Philip. I tried that before installation and it didn't help. However, I can now click into Firefox from external links, but am yet to receive an auto update so not sure if the entirety of my problem is fixed yet or not.