Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

advertising-support hyjack Firefox linux, How?

  • 3 відповіді
  • 1 має цю проблему
  • 11 переглядів
  • Остання відповідь від kcredden

more options

Guys: Just reciently I started getting all sorts of popups, popunders, and re-directs when I go to some websites such as CNN.com. It seems to be going though 'Advertising-support.com' described by this web site: http://malwaretips.com/blogs/advertising-support-removal/

I need to know:

a) How did this happen? b) How to get rid of it?

I run Firefox 31 ESR, on Linux. I don't have mono installed. But I just yesterday got Flash, and Java working on this. So I'm thinking it came though Java or Flash. Both are now set to 'ask to activate' but it's not solving the problem.

Also since Flash is marked to ask to active, what is the reason every single site bounces with the question. Allow <site> to run 'Adobe Flash"? and how can I turn that off for good? I want it on, only IF it's used (like Youtube) not on every site.

Усі відповіді (3)

more options


Did you download these applications from their official sites? You can download a 32-bit Firefox ESR for Linux here:

Adobe Flash:


If you downloaded any of the above from a third party, sometimes they bundle the installer with PUP (potentially unwanted programs). It might be a good idea to remove Firefox and reinstall these applications. Otherwise, check your add-ons in:

  • Tools > Add-ons, or New Fx Menu > Add-ons
  • Remove any suspicious add-ons in Extensions

If that still doesn't help, then in the MalwareTips link you read, have you tried their suggestion of resetting Firefox?

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences. To Reset Firefox do the following:

  1. Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information.Now, a new tab containing your troubleshooting information should open.
  2. At the top right corner of the page, you should see a button that says "Reset Firefox"Button reset. Click on it.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Also, if you need a tool to scan for possible exploits in Linux, try

Did this fix your problems? Please report back to us!

Thank you.

more options

It could be the work of one of your add-ons, or even add / mal-ware.

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Make sure you know what each one is and what it does.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

more options

Guys: I just saw something new.

I use Superstart 7.2 add on. The last time I was hit with a re-direct, it appeared on the left tab, where superstart was.

Then now I remember that a day before, noscript was asking permission to run several scripts on that page as well. When it shouldn't Has has anyone heard of problems with Superstart?

(This is kcredden, I'mhaving login problems.)

Змінено kcredden