Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Firefox autocomplete redirects me to wrong website

  • 4 відповіді
  • 34 мають цю проблему
  • 1 перегляд
  • Остання відповідь від cor-el

more options

Occasionally, when I type a website URL into the address bar, it autocompletes the website URL, but then after I press Enter, it goes to the wrong website (the website which appears first on the drop-down list).

My specific example is when typing, "tw", into the address bar, it autocompletes to, "twitch.tv", but when pressing Enter, it goes to, "twitter.com".

Occasionally, when I type a website URL into the address bar, it autocompletes the website URL, but then after I press Enter, it goes to the wrong website (the website which appears first on the drop-down list). My specific example is when typing, "tw", into the address bar, it autocompletes to, "twitch.tv", but when pressing Enter, it goes to, "twitter.com".

Обране рішення

Use these steps to remove data from a drop-down list:

  1. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  2. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

There are two prefs related to auto-fill on the location/address bar that you can inspect and modify on the about:config page.

  • browser.urlbar.autoFill
  • browser.urlbar.autoFill.typed

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Читати цю відповідь у контексті 👍 2

Усі відповіді (4)

more options

Вибране рішення

Use these steps to remove data from a drop-down list:

  1. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  2. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

There are two prefs related to auto-fill on the location/address bar that you can inspect and modify on the about:config page.

  • browser.urlbar.autoFill
  • browser.urlbar.autoFill.typed

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

The solution offered is a handy way to remove unwanted addresses but the root of the problem is that if your mouse pointer moves within that entire area (address bar and drop down menu), it will focus on a different address and then even if you click on the address you were typing, so as to clear the unwanted address off the screen, it will still go to the unwanted one instead of the one you typed!

Naturally we're likely to have more than one bookmark under each letter of the alphabet so you're still going to have this problem. I think the drop down suggestions should be controlled by clicking, not pressing enter (unless the user pressed the down key on the keyboard to trigger the menu).

more options

I confirm that I'm experiencing exactly the same issue as OP described.

more options

There might be a problem (bug) that Firefox automatically selects the first entry in the drop-down list. Should be fixed in Firefox 36 (currently beta).

  • bug 1043584 - Enter/return key opens entries from drop down menu without pressing arrow keys first on FF 31+

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html