Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Why won't Firefox keeped me logged in to anything after I close and reopen it?

  • 17 відповідей
  • 9 мають цю проблему
  • 16 переглядів
  • Остання відповідь від dmnd

more options

When I was running an older version of Firefox, when I would close a firefox window and later reopen it, I would stay logged in to everything: facebook, hotmail, gmail with multiple sign in, etc. It would also reload all the tabs I had open without me having to click "restore previous session" I liked this as I could close the window, but keep everything that I was working on or wanted open in Firefox without having to pull it all up again. I have since upgraded to the newest version after installing a new hard drive (Windows 7 still), but whenever I close Firefox, I am logged out of everything and my previous tabs don't restore unless I click "restore previous session" (that still will keep me logged out of everything, even if I click it).

How do I set up Firefox to not log me out whenever I close the browser and to automatically restore my previous session?

browser.sessionstore.privacy_level is set to 0 and I do not have "Clear history when Firefox closes" checked.

Please help! Thanks!

When I was running an older version of Firefox, when I would close a firefox window and later reopen it, I would stay logged in to everything: facebook, hotmail, gmail with multiple sign in, etc. It would also reload all the tabs I had open without me having to click "restore previous session" I liked this as I could close the window, but keep everything that I was working on or wanted open in Firefox without having to pull it all up again. I have since upgraded to the newest version after installing a new hard drive (Windows 7 still), but whenever I close Firefox, I am logged out of everything and my previous tabs don't restore unless I click "restore previous session" (that still will keep me logged out of everything, even if I click it). How do I set up Firefox to not log me out whenever I close the browser and to automatically restore my previous session? browser.sessionstore.privacy_level is set to 0 and I do not have "Clear history when Firefox closes" checked. Please help! Thanks!

Змінено Supersox

Усі відповіді (17)

more options

Check your security settings. Make sure cookies are not removed. Also check your virus scanners. Some of them also have that option.

Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy.

more options

Keeps until they expire. Avast! isn't set to delete them.

more options

Also, check if you have set Firefox to always run in private browsing mode.

You can check that you aren't running Firefox in permanent Private Browsing mode (Never remember history)?

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"


Private Browsing - Use Firefox without saving history

more options

It's not checked.

more options

You can check for problems with the places.sqlite database file in the Firefox profile folder.


Note that you will lose all history if you delete the places.sqlite file.

If necessary then try to drag (copy/paste) history items to a bookmarks folder and try to export the bookmarks to an HTML file. Be sure to verify that the HTML file has the history items.


ALso see: https://support.mozilla.org/en-US/questions/980789?

https://support.mozilla.org/en-US/questions/986585?

more options

It's not my bookmarks or history I'm having problems with, I'm having problems with firefox not keeping me logged into sites after closing the window, but leaving the tab open for the logged in site

more options

There is also the browser.sessionstore.privacy_level_deferred pref that is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values.

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

You can check browser.sessionstore.* prefs including browser.sessionstore.resume_from_crash on the about:config page and reset browser.sessionstore prefs that are user set (bold) via the right-click context menu to the default value to make sure that Session Restore is enabled and working properly.

more options

previous session is set to open automatically...still doesn't save logins

I don't want websites to remember me, I want it to keep the same login session going, so the "remembering me" suggestion isn't applicable.

Could you further explain the last suggestion with the browser.sessionstore.* thing? Would uninstalling and reinstalling firefox have the same effect?

more options

You still need to keep these cookies across a session, so your Firefox setting must be such that you keep them and that can include having an allow exception and even that might not work with some websites.

more options

So what are you suggesting I do? It sounds great in theory, but how do I do that?

The three articles you linked don't seem to address the issue. Your suggestion of going to about:config and going to browser.sessionstore.* only had browser.sessionstore.upgradeBackup.latestBuildID with a user set value.

What do I need to do to get this back up and working?

more options

You could make sure that your anti-spyware is not clearing cookies, and if it is, disable that behaviour. Superantispyware used to do that, and I had to turn it off. Did you check Options > Privacy > Settings to make sure that cookies are not being deleted?

more options

Options > Privacy > Settings is not available...the settings button is grayed out unless I click "Clear History When Firefox closes" (it's not clicked)

As I said above, avast! is not clearing cookies.

more options

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder Linux:

  • Ubuntu Unity {web link}
  • Xfce: Applications Menu category sections
  • options depends on the package manager and the desktop environment

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

more options

Brand-new hard drive received on Monday. No malware. Ran scanners to verify. Only extension being run is AdBlock.

more options

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

more options

I have this problem only today after updating to the new version. it;s not about the cookies or anything, something is wrong with FireFox itself.. it is disappointing T_T

more options

and also the download icon stopped showing me the download progress since the last 2 updates and they are not fixing it. i can't stop any download i start. no one seems to answer or do anything about it.