Чому я повинен активовувати плагіни?

Mozilla планує закінчити підтримку всіх плагінів NPAPI, окрім Flash, у березні 2017 року, коли вийде Firefox версії 52. Докладніше у цій статті та у цьому дописі.

У минулому, для захисту від плагінів, що мають вразливості безпеки чи стабільності, Firefox міг лише вимикати їх. Зараз же, Firefox може запобігати автоматичному запуску плагінів (що унеможливлює більшість проблем) та потім надавати вам можливість вирішувати, запустити чи оновити проблемний плагін.

Примітка: Ця стаття описує що робити, коли плагін був заблокований від автоматичного запуску по причині вразливості безпеки чи стабільності. Більшість плагінів потребують активації, навіть якщо вони відзвітовані як оновлені на сторінці перевірки плагінів від Mozilla, тому що зараз Firefox відразу позначає всі плагіни як такі, що потребують активації в менеджері плагінів (за виключенням Adobe Flash). Докладніше про таку поведінку, дивіться у цьому дописі.

Як працює активація

  1. Коли Firefox блокує плагін, ви побачите наступне повідомлення:
    Click to play 1 new_uk
  2. Ви можете запустити плагін чи оновити його (якщо оновлення доступне).
    • Якщо ви клацнете "активувати" та дозволите плагін, відсутній вміст буде довантажено (якщо ж ні, натисніть кнопку оновлення сторінки FxReloadButton в панелі адрес та спробуйте знову). Наступного разу при відвідуванні цього сайту чи будь-якого іншого, що використовує даний плагін, ви знову побачите таке саме повідомлення.
    Click to play 2 new_uk
    • Якщо оновлення доступне і ви клацнете "Перевірити оновлення..."
    Click to play 3 new_uk
    • Відкриється сторінка перевірки плагінів, де вам буде надано посилання для оновлення застарілих плагінів.
    AdobeFlash-plugincheck_uk

Коли доречно активовути плагіни замість їх оновлення?

Оновлення плагіна завжди являється найкращим варіантом, проте, інколи виконати оновлення не є можливим. Наприклад, вам не дозволено оновлювати програмне забезпечення на комп'ютері, що знаходиться на роботі чи в школі. У подібних ситуаціях, ви можете обрати наступне:

  • Якщо ви довіряєте сайту. Це може бути спеціалізований сайт для вашої роботи чи школи, особливо якщо ви його використовували вже довгий час - тоді ви можете активувати вразливий плагін для перегляду вмісту такого сайту.
  • Якщо ви не довіряєте сайту цілком. Наприклад, ви перейшли на нього по посиланню з іншого сайту, тоді краще не активовуйте плагін.

Як назавжди активувати плагін для сайтів, що я довіряю

Якщо ви не можете оновити плагін і користуєтесь довіреним веб-сайтом, тоді налаштуйте автоматичний запуск плагіна на цьому сайті:

  1. Клацніть по червоній піктограмі плагіна в панелі адрес, з'явиться панель з повідомленням.
  2. В ній натисніть Дозволити та запам'ятати.
    Blocklisted-ActivateFlash_uk

Відтепер, плагін автоматично запускатиметься при відвідуванні цього сайту і ви більше не побачите повідомлення про необхідність його активації.

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.