Firefox не запитує зберегти вкладки та вікна при виході

Ця стаття можливо застаріла.

Були внесені важливі зміни в англійську версію цієї сторінки. Якщо хочете, перегляньте її, доки триває переклад внесених змін: How do I restore my tabs from last time?

Якщо у вас перестало з’являтися повідомлення "Чи хочете ви щоб Firefox зберігав ваші вкладки при наступному запуску" при виході з Firefox, то це може бути спричинено специфічними налаштуваннями, проблемами з розширеннями чи пошкодженими файлами компонентів Firefox.


Налаштування можуть бути виставленими некоректно

  1. Відкрийте вікно Налаштування
  2. Перейдіть на панель Головна та встановіть При запуску Firefox в Показувати домашню сторінку.
  3. Перейдіть на панель Вкладки, відмітьте Видавати попередження, коли я намагаюся закрити вікно з декількома вкладками.
  4. Перейдіть на панель Приватність та зніміть галочку з Завжди очищати мої особисті дані коли я закриваю Firefox.
  5. Закрийте вікно Налаштування
  1. Відкрийте вікно Налаштування
  2. Перейдіть на панель Загальне (у Firefox 3.5 ця панель називається Головна) та встановіть При запуску Firefox в Показувати домашню сторінку.
  3. Перейдіть на панель Вкладки та відмітьте Видавати попередження, коли я намагаюся закрити вікно з декількома вкладками.
  4. Перейдіть на панель Приватність та впевніться, що Firefox буде: встановлено або в Пам’ятати історію або Використовувати власні налаштування історії.
    • Якщо Firefox буде: встановлено в Використовувати власні налаштування історії, зніміть галочку з Очищати історію, коли Firefox закривається.
  1. Закрийте вікно Налаштування


Розширення

Відомо, що деякі розширення (наприклад, Tab Mix Plus) спричиняють дану проблему. Щоб зрозуміти, чи це із-за розширення, прочитайте статтю Вирішення проблем пов`язаних з розширеннями та темами.


Пошкоджені файли

Firefox зберігає інформацію користувача в окремій теці на вашому комп’ютері. Один, або більше файлів цієї теки можуть бути пошкодженими.

  1. Відкрийте теку свого профілю:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. Зверху вікна Firefox натисніть кнопку Firefox (меню Файл у Windows XP), потім ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл, потім оберіть ВийтиЗверху вікна Firefox натисніть меню Файл та оберіть ВийтиВ панелі меню натисніть Firefox та оберіть Вийти з FirefoxЗверху вікна Firefox натисніть меню Файл та оберіть Вийти.
    • Переконайтесь, що Firefox не працює в даний момент.
  1. У вашій теці профілю перейменуйте наступні файли:
    • formhistory.sqlite в formhistory.sqlite.bak.
    • sessionstore.js в sessionstore.js.bak.
Примітка: Якщо вам потрібно буде відновити старі версії файлів - просто вилучіть нові, а в старих вилучіть .bak з кінця назви файлів.

Ця стаття допомогла? Зачекайте...

Цю статтю допомогли написати такі гарні люди: Bogdancev. Ви теж можете допомогти - дізнайтесь як.