X
Sitenin mobil sürümüne gitmek için buraya dokunun.
Firefox'unuz eskimiş ve güvenlik riski taşıyor olabilir! Firefox'u yükseltin

Destek Forumu

Bu başlık kapatıldı ve arşivlendi. Yardıma ihtiyacınız varsa lütfen yeni bir soru sorun.

I updated Firefox to 22.0 then went into about: config to change font size. Well I set it to .005 then firefox went completely blank with white screen

Tarih

It also has what looks like possibly a asian symbol up in the left corner, and I can't do a thing at all. Very frustrating cause I can't find anything online to help.... Thanks. Let me know if you need more info.

Seçilen çözüm

You can also consider to temporarily create a user.js file to initialize the layout.css.devPixelsPerPx pref to a more reasonable value.

user_pref("layout.css.devPixelsPerPx", "1.0");

That should make it possible to start Firefox.
After you have closed Firefox you should remove the user.js file, otherwise you won't be able to make lasting changes on the about:config page.


Note that 0.005 is considered as zero, the pref only accepts two decimals (percentage) and even 0.05 would be too small.
You should always start with 1 and increase or decrease the value in 0.1 steps and fine tune with 0.05.

Bu yanıtı konu içinde okuyun 1

Ek sistem ayrıntıları

Application

  • Kullanıcı istemcisi: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article. _________________________________________________________________________

After you do this if you see Firefox larger than normal

refer to

Waka_Flocka_Flame tarafından tarihinde düzenlendi

jscher2000
  • Top 10 Contributor
2344 solutions 20788 answers

What size were you changing, the layout.css.devPixelsPerPx? Using such a small value will make the text unreadable, as you discovered.

If a full Reset is too drastic for you, you could try this:

Start menu > Search type or paste the following and press Enter

%APPDATA%\Mozilla\Firefox\Profiles

In that folder, look for the most recently edited profile folder. It may have "default" in the name. If you open that folder, you should find time stamps from around the time you exited Firefox.

Look for the file named prefs.js and rename it to something like prefs.txt.

Open the file in a text editor, which might take a while if it's large. Search for the line containing layout.css.devPixelsPerPx and delete it. Then Save As "prefs.js" (using the quotation marks should prevent Notepad from adding .txt to the file name).

Then restart Firefox. Any luck?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Seçilen çözüm

You can also consider to temporarily create a user.js file to initialize the layout.css.devPixelsPerPx pref to a more reasonable value.

user_pref("layout.css.devPixelsPerPx", "1.0");

That should make it possible to start Firefox.
After you have closed Firefox you should remove the user.js file, otherwise you won't be able to make lasting changes on the about:config page.


Note that 0.005 is considered as zero, the pref only accepts two decimals (percentage) and even 0.05 would be too small.
You should always start with 1 and increase or decrease the value in 0.1 steps and fine tune with 0.05.

Sorunun sahibi

jscher, yeah I set it to .005 after I saw that suggested when I googled this issue. Not a good idea. I'm not gonna do that ever again. And before I saw your guys replies, I just restored my pc back to last update. That's all I could do. I really appreciate the help guys, thanks. My last problem now is if I decide to update FF to 22.0 I'm gonna be back in the same boat trying to fix the crazy fucking font sizes.

Did you have any problems with the size of font on this new update? If so, what did you change it to?

Thanks again Waka, Jscher and cor-el for your responses.

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Sorry to say, i havent touched FIrefox 22 beacause im not using my own computer but a good value (if you dont mess with windows DPI) is 1.0 i guess.

jscher2000
  • Top 10 Contributor
2344 solutions 20788 answers

Hi Aterhall, if you right-click and Reset the setting to default in Firefox 21 before you update, then Firefox 22 should pick up your Windows DPI settings automatically.

As for how it affects me, I think this affects different people differently based on their screen size.

On my laptop I set Windows to 125% so the content area in Firefox is now 25% larger by default. On most sites I was using zoom to enlarge the page, so this difference (e.g., 120% vs. 125%) is not noticeable most of the time. However, on sites where the fonts already are large, I might now need to use Ctrl- to reduce the size so more fits on the screen.

In another thread, a user with a huge 27" monitor is finding it annoying because he didn't need to use zoom before and he wants to see as much content as possible. Since he already found the content area readable, there is no benefit to him, only inconvenience.

With that in mind, ideally, Firefox should consider both your windows resolution and the physical size of the screen (i.e., physical pixel size) in deciding how much to zoom the content area. I don't know whether Windows programs actually can do that...

Sorunun sahibi

Yes Firefox needs to get on the ball with this.

So I have a 20" lcd and have my DPI at 144, and NoSquint set at Full Page-120% Text only- 105%.

Just wondering, when you said right click and reset the setting... How exactly do I do that?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

What is meant is to open the about:config page and find the layout.css.devPixelsPerPx pref.
You can right-click this pref to reset the value to the default.
That will make the real value 1 in Firefox 21 and -1 in Firefox 22 and later.

See line 1686 in:

  • resource://gre/greprefs.js
jscher2000
  • Top 10 Contributor
2344 solutions 20788 answers

Hi Aterhall, DPI 144ppi is equivalent to 150% zoom in Windows and therefore in the content area of Firefox 22. When combined with your NoSquint setting, that's going to be pretty huge.

I think this is the math to get the size you like in Firefox 22 with the default setting:

Fx 21 100% x NoSquint 120% = 120%

Fx 22 150% x NoSquint 80% = 120%

NoSquint is likely going to be updated to take better account of this feature so you might not need to do this in the future, but I'm not sure how soon.

rroxanne 0 solutions 2 answers

Please help! Due to the blurry font on Mozilla Firefox 22.0 I followed the about:config (layout.css.devPixelsPerPx). I played around w/ the font sizing, but i accidentally typed 0.5. Now everything is too small, I can't do anything.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

İşe yarayan yanıt

hello rroxanne, you can perform the following steps to change the value again "blindly":

  1. open firefox and press ctrl +L (this will put the focus into the location bar)
  2. type about:config
  3. press enter twice
  4. type devpix
  5. press the tab key
  6. press enter
  7. type 1.0
  8. press enter again & hopefully you should be back to normal visibility now
Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

good values for layout.css.devPixelsPerPx are between 1.0 and 1.5. Also create a user.js file with this text in it as cor-el said.

user_pref("layout.css.devPixelsPerPx", "1.0");

  1. Copy and paste the bold text above into notepad and save as user.js
  2. Hit WIndows button + R
  3. A new window should now show
  4. Copy and paste %APPDATA%\Mozilla\ and find a folder named xxxxxxxx.default , x's are random letters.
  5. In that folder paste the user.js file you have created.
  6. Open Firefox and open about:config
  7. Change layout.css.devPixelsPerPx to 1.0
  8. Repeat Steps 2-5 but delete user.js
  9. You should be all good now.
rroxanne 0 solutions 2 answers

Hi philipp & Waka_Flocka_Flame. I really appreciate all the help. I will definitely keep it for future reference. I didn't get to try your suggestions because I recently restored my previous computer update, I was in desperate measure. With Mozilla Firefox 22.0 both 1.0 & -1.0 were still giving me blurry text/font. It was bothersome. I like the older version. If it needs to be updated to 22.0, I hope there's a way to fix the blurry text. A million thanks!

the-edmeister
  • Top 10 Contributor
  • Moderator
3193 solutions 24375 answers

Locking this thread. There are too many similar threads where the user seeking help actually followed the provided help.