X
Sitenin mobil sürümüne gitmek için buraya dokunun.

Destek Forumu

HTML5 video doesn't play in Firefox 10

Tarih

Firefox 10 does not play video using the HTML5 video tag.

My page

Firefox 10 does not play video using the HTML5 video tag. [http://home.comcast.net/~s.oravec/index.html My page]

Seçilen çözüm

@cor-el - Yes I know Thank you, but I have no control over server setting for Comcast, I have tried to point that out to them 50 times.

@willkg - Thanks for showing me how to use Developer Tools.

Thanks for you input it was very useful.

Bu yanıtı konu içinde okuyun 1

Ek sistem ayrıntıları

Bu ne zaman oldu?

Firefox'u her açtığımda

Uygulama

  • Kullanıcı istemcisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.46 Safari/535.11

Daha fazla bilgi

willkg
  • Administrator
1 çözüm 3 yanıt

Hi!

What's going on is that when Firefox does the GET request to both the ogv and webm versions of the video, the web-server is serving it with a mime-type of text/plain which doesn't match the mime-type in the source tag. Pretty sure this mismatch is why it's not showing.

I'm not sure how you can fix this problem since I think it's a problem with the web server configuration. I think it needs to know that .ogv files are video/ogg and .webm files are video/webm.

As an aside, Firefox 10 has a web console that makes it easier to see what's going on--it's what I used just now. If you go to the Tools menu, then choose Web Developer, then choose Web Console, you get a console at the top of Firefox that shows you a lot of information including HTTP requests/responses. If you reload the page, you can see the two GET requests that are problematic. If you click on the url of the GET request in the Web Console, it'll open a window where you can see the full request and response headers.

Hi! What's going on is that when Firefox does the GET request to both the ogv and webm versions of the video, the web-server is serving it with a mime-type of text/plain which doesn't match the mime-type in the source tag. Pretty sure this mismatch is why it's not showing. I'm not sure how you can fix this problem since I think it's a problem with the web server configuration. I think it needs to know that .ogv files are video/ogg and .webm files are video/webm. As an aside, Firefox 10 has a web console that makes it easier to see what's going on--it's what I used just now. If you go to the ''Tools'' menu, then choose ''Web Developer'', then choose ''Web Console'', you get a console at the top of Firefox that shows you a lot of information including HTTP requests/responses. If you reload the page, you can see the two GET requests that are problematic. If you click on the url of the GET request in the Web Console, it'll open a window where you can see the full request and response headers.

İşe yarayan yanıt

So would this be a server issue or Firefox issue ?

So would this be a server issue or Firefox issue ?
willkg
  • Administrator
1 çözüm 3 yanıt

İşe yarayan yanıt

I think it's a problem with the web server configuration. It needs to know that .ogv files are video/ogg and .webm files are video/webm. Currently the web server is saying that both are text/plain and that's wrong.

Given that you probably have no control over the server configuration, I think you need to work around the issue. It's possible that if you don't specify a type attribute that that might work.

I think it's a problem with the web server configuration. It needs to know that .ogv files are video/ogg and .webm files are video/webm. Currently the web server is saying that both are text/plain and that's wrong. Given that you probably have no control over the server configuration, I think you need to work around the issue. It's possible that if you don't specify a type attribute that that might work.

Sorunun sahibi

No that didn't work either....I've even tried the videojs script also, but if the server doesn't support ogg or webm its just not going to work .

No that didn't work either....I've even tried the videojs script also, but if the server doesn't support ogg or webm its just not going to work .
cor-el
  • Top 10 Contributor
  • Moderator
13070 çözüm 119681 yanıt
See: * https://developer.mozilla.org/en/Configuring_servers_for_Ogg_media * https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements

Seçilen çözüm

@cor-el - Yes I know Thank you, but I have no control over server setting for Comcast, I have tried to point that out to them 50 times.

@willkg - Thanks for showing me how to use Developer Tools.

Thanks for you input it was very useful.

@cor-el - Yes I know Thank you, but I have no control over server setting for Comcast, I have tried to point that out to them 50 times. @willkg - Thanks for showing me how to use Developer Tools. Thanks for you input it was very useful.
cor-el
  • Top 10 Contributor
  • Moderator
13070 çözüm 119681 yanıt

Did you try to add a .htaccess file to the root of your home page?

AddType audio/ogg oga ogg
AddType video/ogg ogv

You can use the object tag instead if you can't make the server send the correct MIME type.
Firefox is not so restrictive with the object tag.

<video controls="controls" width="720" preload="auto" height="480" poster="toMy/toMy.jpg">
<source src="toMy/toMy.webm" type='video/webm' />
<source src="toMy/toMy.mp4" type='video/mp4' />
<source src="toMy/toMy.theora.ogv" type='video/ogg' />
</video>

Code like this should work (I've tested it with camping.theora.ogv) if you have a player that can handle video/ogg, but I don't know about buffering and preloading.

<object width="720" height="480" data="toMy/toMy.theora.ogv" type="video/ogg"></object>
Did you try to add a .htaccess file to the root of your home page? AddType audio/ogg oga ogg AddType video/ogg ogv ---- You can use the object tag instead if you can't make the server send the correct MIME type.<br /> Firefox is not so restrictive with the object tag.<br /> <br /> <pre><nowiki><video controls="controls" width="720" preload="auto" height="480" poster="toMy/toMy.jpg"> <source src="toMy/toMy.webm" type='video/webm' /> <source src="toMy/toMy.mp4" type='video/mp4' /> <source src="toMy/toMy.theora.ogv" type='video/ogg' /> </video> </nowiki></pre> ---- Code like this should work (I've tested it with camping.theora.ogv) if you have a player that can handle video/ogg, but I don't know about buffering and preloading. <pre><nowiki><object width="720" height="480" data="toMy/toMy.theora.ogv" type="video/ogg"></object> </nowiki></pre>

Sorunun sahibi

Not sure if I'm correct here but, I don't have control of the helm captain.

Not sure if I'm correct here but, [http://home.comcast.net/~s.oravec/index.html I don't have control of the helm captain.]
cor-el
  • Top 10 Contributor
  • Moderator
13070 çözüm 119681 yanıt

Did you try it anyway with an FTP program or can't you upload files that way?

Coded with only a video tag will leave out users with older browsers (e.g. Firefox 3.6.x) that do not support the video tag.


data:text/html,<object data="http://home.comcast.net/~s.oravec/video/camping.webm" type="application/ogg" width="100%" height="100%"></object>
Did you try it anyway with an FTP program or can't you upload files that way? *http://home.comcast.net/~s.oravec/.htaccess *http://home.comcast.net/~s.oravec/video/.htaccess Coded with only a video tag will leave out users with older browsers (e.g. Firefox 3.6.x) that do not support the video tag. ----- <pre><nowiki>data:text/html,<object data="http://home.comcast.net/~s.oravec/video/camping.webm" type="application/ogg" width="100%" height="100%"></object></nowiki></pre>

cor-el tarafından tarihinde düzenlendi

Sorunun sahibi

Comcast doesn't allow htaccess to be used on PWP

Comcast doesn't allow htaccess to be used on PWP
ruruskyi 0 çözüm 1 yanıt

Try different converter, for instance, Miro Video Converter.

I've used AVS Converter and that video didn't on Firefox 10. Then I convert again and it gets working.

Symptoms: Video is loaded successfully. When trying to play it jumps to the end of the video file and never comes back whatever you do.

Note: Before you started check your MIME-type. In your response header you should be able to find: Content-Type: video/webm

Note: If you are using Apache just one line should be added: AddType video/webm .webm Just FYI, there is no difference if you have dot (.) or not. And do not add application/webm MIME-type. Firefox will not accept that.

Note: I've checked also that there is no difference if your video is cached or not. So if you've got "304 Not Modified" that's OK. If you still want to exclude everything that may cause the problem you can set your header to do not cache. Example for Apache, this will force browser to never cache webm files:

<filesMatch "\.(webm)$">
ExpiresActive Off
Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
Header set Pragma "no-cache"
</filesMatch>
Try different converter, for instance, Miro Video Converter. I've used AVS Converter and that video didn't on Firefox 10. Then I convert again and it gets working. '''Symptoms:''' Video is loaded successfully. When trying to play it jumps to the end of the video file and never comes back whatever you do. '''Note:''' Before you started check your MIME-type. In your response header you should be able to find: Content-Type: video/webm '''Note:''' If you are using Apache just one line should be added: AddType video/webm .webm Just FYI, there is no difference if you have dot (.) or not. And do not add application/webm MIME-type. Firefox will not accept that. '''Note:''' I've checked also that there is no difference if your video is cached or not. So if you've got "304 Not Modified" that's OK. If you still want to exclude everything that may cause the problem you can set your header to do not cache. Example for Apache, this will force browser to never cache webm files: <pre> <filesMatch "\.(webm)$"> ExpiresActive Off Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform" Header set Pragma "no-cache" </filesMatch> </pre>

ruruskyi tarafından tarihinde düzenlendi