Mozilla Destek’te Ara

Destek dolandırıcılığından kaçının. Mozilla sizden asla bir telefon numarasını aramanızı, mesaj göndermenizi veya kişisel bilgilerinizi paylaşmanızı istemez. Şüpheli durumları “Kötüye kullanım bildir” seçeneğini kullanarak bildirebilirsiniz.

Learn More

After upgrading Firefox on Mac, my address bar no longer displays the http:// in front of web address

  • 2 yanıt
  • 23 kişi bu sorunu yaşıyor
  • 45 gösterim
  • Son yanıtı yazan: amandascookin

more options

I upgraded Firefox by clicking "About Firefox". After the upgrade I restarted the browser. Now, no matter what web page I go to, the http:// is missing from the address field. The only time it shows is if it's a secure webpage, such as https://

How do I get this back?

For example, when I go to http://amandascookin.com the site loads but the address bar only displays amandascookin.com

Seçilen çözüm

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Bu yanıtı konu içinde okuyun 👍 22

Tüm Yanıtlar (2)

more options

Seçilen çözüm

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

more options

Thank you SO much! Such a quick reply too :)