Mozilla Destek’te Ara

Destek dolandırıcılığından kaçının. Mozilla sizden asla bir telefon numarasını aramanızı, mesaj göndermenizi veya kişisel bilgilerinizi paylaşmanızı istemez. Şüpheli durumları “Kötüye kullanım bildir” seçeneğini kullanarak bildirebilirsiniz.

Learn More

Memory usage renders my computer useless for other programs

  • 1 yanıt
  • 1 kişi bu sorunu yaşıyor
  • 1 gösterim
  • Son yanıtı yazan: cor-el

more options

Sometimes even when I have a few tabs open (four), Firefox eats up my memory. The attached memory showed what happened to me earlier: 3.1 GB of RAM used on only four tabs. This hogs my computer and I can't do anything else, had to close Firefox from the taskbar.

I know may people think that RAM not used is RAM wasted, but that's a simplistic way of putting things. At work, I'm constantly firing up applications, so if Firefox decides to not waste my RAM and goes nearly 100% then I can't open any new program. And other programs stop eventually. For example, if I want to open Microsoft Word's Online Art feature, I can't because memory is at 100%. Or if I want to fire a debugging process with Visual Studio, can't because memory is at 100%.

I've tried the solution on using less memory, as depicted by the article found in Mozilla Support (enabling config flags) to no avail. What can be done?

Tüm Yanıtlar (1)

more options

Does the about:memory page show what is taking up this memory?


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to modify multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • disable multi-process windows in Firefox