Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove arrows beside folders in bookmark toolbar?

  • 6 replies
  • 6 have this problem
  • 49 views
  • Last reply by route

more options

Years ago, I found out how to remove the space-wasting arrows from beside the many folders on my bookmark toolbar. I did this by adding a line to userChrome.css (see http://ubuntuforums.org/showthread.php?t=912026 )

Today, I have Ubuntu 11.10 with FF 7.0.1 & there does not seem to be a userChrome.css....

So please let me know how to remove the irritating arrows!

Maybe you could also publish the method, for other sufferers?

Thanks!

2CV67

Years ago, I found out how to remove the space-wasting arrows from beside the many folders on my bookmark toolbar. I did this by adding a line to userChrome.css (see [http://ubuntuforums.org/showthread.php?t=912026 http://ubuntuforums.org/showthread.php?t=912026] ) Today, I have Ubuntu 11.10 with FF 7.0.1 & there does not seem to be a userChrome.css.... So please let me know how to remove the irritating arrows! Maybe you could also publish the method, for other sufferers? Thanks! 2CV67

Modified by 2CV67

Chosen solution

Add code to userChrome.css in the chrome folder below the @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item[container] > .toolbarbutton-menu-dropmarker { display:none!important; }
Read this answer in context 👍 0

All Replies (6)

more options

Chosen Solution

Add code to userChrome.css in the chrome folder below the @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item[container] > .toolbarbutton-menu-dropmarker { display:none!important; }
more options

Thanks very much for your reply, cor-el.

I think I followed your instructions, but without success yet...

Let me clarify what I did, in case there is some obvious error.

I went to my FF profile folder & there was no chrome folder.

I made a new empty folder called "chrome".

I opened a new document in text editor & called it "userChrome.css".

I copy/pasted everything below the line in your reply into userChrome.css.

i.e. ............................................................

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */


  1. personal-bookmarks .bookmark-item[container] > .toolbarbutton-menu-dropmarker { display:none!important; }

............................................................

I saved userChrome.css into chrome.

I opened FF, but no change - arrows still present.

I rebooted, but no change.

In addition, I looked at the userChrome.css file in my main PC (FF 7.0.1 in Ubuntu 11.04) & that was slightly different:

.............................................................

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */


  1. PersonalToolbar .toolbarbutton-menu-dropmarker { display: none !important; }

............................................................

& tried copy/pasting that instead of the first version, but that produced no change either.

Thanks for any further suggestions!

more options

Make sure the the file userChrome.css doesn't have a hidden .txt file extension. Windows does that if you save the file as a text file and haven't selected all files.

See also:

more options

Thanks for your patience, cor-el !

After careful checking, I found a typo in a file name... With that fixed, your initial suggestion now works perfectly!

Thanks again!

more options

You're welcome.

Glad that you got it working.

more options

Thanks it worked