Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to avoid auto opening sites when browser starts

  • 5 replies
  • 0 have this problem
  • 25 views
  • Last reply by cor-el

more options

Whenever I open Firefox, there are some sites that are opened itself. This is very annoying. Everytime I have to close all that tabs.

Kindly tell me how can I avoid this annoying thing. Else I have to switch to another browser.

Thanks

Whenever I open Firefox, there are some sites that are opened itself. This is very annoying. Everytime I have to close all that tabs. Kindly tell me how can I avoid this annoying thing. Else I have to switch to another browser. Thanks

All Replies (5)

more options

Hello,

Thank you for your inquiry!

Below I describe what I believe the scenario to be, along with information on how to resolve and a link to more information, should you need it. If my understanding of the scenario is incorrect, please let me know.

Auto-Opening Previously Open Tabs Scenario: You have Site A, Site B, and Site C open and you are finished using Firefox for the moment, so you exit Firefox. The next time you start Firefox, it starts up with Site A, Site B and Site C open.

How to Resolve If you wish, you can configure Firefox to no longer open the windows and tabs from your previous session:

  • Click the menu ('hamburger') button in the upper right and select Settings.
  • Select the General panel.
  • Below Startup deselect Open previous windows and tabs.

More information: https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings#firefox:win10:fx107

Please let us know if this solves the issue. Thank you for reaching out.

Helpful?

more options

Are that always website that you visited during the previous session or from an old session you visited in the past ?

You can check that those pages aren't set as multiple homepages.

You can check the homepage setting in "Settings -> Home".

Firefox supports multiple homepages separated by '|' (pipe) symbols.

You can check for problems with the sessionstore.jsonlz4 file in the Firefox profile folder that stores session data.

  • rename/remove sessionstore.jsonlz4 and sessionstore.js

You may also have to rename the sessionstore-backups folder.

When sessionstore.jsonlz4 is deleted you lose pinned-tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them. sessionstore.jsonlz4 is only present in the Firefox profile folder when Firefox is closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

Hi,

Thanks for your response. I really appreciate that. Actually these are not my previously opened tabs. I guess these are some extensions or like some ads that appears whenever I start my browser.

I neither visited that sites nor I installed that extensions. Kindly see the screenshots attached for better understanding.

You can see the first three tabs on the screenshot. These three always opens auto whenever I open firefox.

Thanks

Helpful?

more options

Another if you want to try is Clear cache/history this will clear everything out and possibly logins so be sure you have those written or saved somewhere safe before doing this action to see if this helps.

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

So read these before just doing to be sure it's what your will help you here.

Helpful?

more options

If always the same tabs open when you start Firefox then there can be only a few causes like I mentioned above. I assume that already checked the homepage settings and a possible sessionstore file.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.

It is possible that other software or malware injects itself in Firefox and tries to open some webpages.

You can do a malware scan just to be sure.

You can boot the computer in Windows Safe Mode with network support to see if that has effect.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.