Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Embedded YouTube-videos work locally, but not after FTP-publishing. Works locally and on the web in all other browsers. Using FF 17.0.1 and Adobe Flash 11.5.502

  • 10 การตอบกลับ
  • 1 คนมีปัญหานี้
  • 688 ครั้งที่ดู
  • ตอบกลับล่าสุดโดย Stringence

more options

Found a Tube-video, which I've embedded on one of my website pages. Using FF 17.0.1 and Adobe Flash 11.5.502, YouTube-videos work locally, but not after FTP-publishing.

I works perfectlly locally and on the web in all other browsers.

Silly FF?

The code in HTML is as follows:

<table WIDTH="770" CELLPADDING="0" CELLSPACING="0">
  <tr VALIGN="TOP">
    <td VALIGN="top" ALIGN="left" width="463">
<object WIDTH="340" HEIGHT="193">
      <param name="movie" value="http://www.youtube.com/v/N6GvuO_9tLY?fs=1?amp;hl=de_DE">
      <param name="allowFullScreen" value="true">
      <param name="allowscriptaccess" value="always"><embed SRC="http://www.youtube.com/v/N6GvuO_9tLY?fs=1?amp;hl=de_DE" TYPE="application/x-shockwave-flash" WIDTH="340" HEIGHT="193">
    </object>
</td>
    <td VALIGN="top" ALIGN="left" width="403"></td>
    </tr>
</table>

I've experimented on using <iframe> instead of <object>. No change. Cache cleared on every try.

Any thoughts?

เปลี่ยนแปลงโดย cor-el เมื่อ

วิธีแก้ปัญหาที่เลือก

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

You can also try to disable hardware acceleration in Firefox.

อ่านคำตอบนี้ในบริบท 👍 0

All Replies (10)

more options

Firefox may be using the object (doesn't have an ActiveX classid for IE that would prevent this) instead of the embed and the object doesn't have a data attribute and a mime type.

This should work:

<table WIDTH="770" CELLPADDING="0" CELLSPACING="0">
  <tr VALIGN="TOP">
    <td VALIGN="top" ALIGN="left" width="463">
<object WIDTH="340" HEIGHT="193" DATA="http://www.youtube.com/v/N6GvuO_9tLY?fs=1?amp;hl=de_DE" TYPE="application/x-shockwave-flash">
      <param name="movie" value="http://www.youtube.com/v/N6GvuO_9tLY?fs=1?amp;hl=de_DE">
      <param name="allowFullScreen" value="true">
      <param name="allowscriptaccess" value="always">
    </object>
</td>
    <td VALIGN="top" ALIGN="left" width="403"></td>
    </tr>
</table>
more options

Sorry to say, it does not work. Same as before: works locally, but not when published.

More ideas?

more options

This does works for me.

Do you have a web page with this code?


data:text/html;charset=utf-8;base64,PHRhYmxlIFdJRFRIPSI3NzAiIENFTExQQURESU5HPSIwIiBDRUxMU1BBQ0lORz0iMCI+CiAgPHRyIFZBTElHTj0iVE9QIj4KICAgIDx0ZCBWQUxJR049InRvcCIgQUxJR049ImxlZnQiIHdpZHRoPSI0NjMiPgo8b2JqZWN0IFdJRFRIPSIzNDAiIEhFSUdIVD0iMTkzIiBEQVRBPSJodHRwOi8vd3d3LnlvdXR1YmUuY29tL3YvTjZHdnVPXzl0TFk/ZnM9MT9hbXA7aGw9ZGVfREUiIFRZUEU9ImFwcGxpY2F0aW9uL3gtc2hvY2t3YXZlLWZsYXNoIj4KICAgICAgPHBhcmFtIG5hbWU9Im1vdmllIiB2YWx1ZT0iaHR0cDovL3d3dy55b3V0dWJlLmNvbS92L042R3Z1T185dExZP2ZzPTE/YW1wO2hsPWRlX0RFIj4KICAgICAgPHBhcmFtIG5hbWU9ImFsbG93RnVsbFNjcmVlbiIgdmFsdWU9InRydWUiPgogICAgICA8cGFyYW0gbmFtZT0iYWxsb3dzY3JpcHRhY2Nlc3MiIHZhbHVlPSJhbHdheXMiPgogICAgPC9vYmplY3Q+CjwvdGQ+CiAgICA8dGQgVkFMSUdOPSJ0b3AiIEFMSUdOPSJsZWZ0IiB3aWR0aD0iNDAzIj48L3RkPgogICAgPC90cj4KPC90YWJsZT4=
more options

No. I've got:

<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">

Check my website at http://www.varf.se/s11urania.htm in various browsers.

เปลี่ยนแปลงโดย Stringence เมื่อ

more options

That page work fine here on Linux with Firefox and Google Chrome with the current code.
I can't test with IE, but it should work in IE as well.

<object WIDTH="340" HEIGHT="193" DATA="http://www.youtube.com/v/N6GvuO_9tLY?fs=1?amp;hl=de_DE" TYPE="application/x-shockwave-flash">
  <param name="movie" value="http://www.youtube.com/v/N6GvuO_9tLY?fs=1?amp;hl=de_DE">
  <param name="allowFullScreen" value="true">
  <param name="allowscriptaccess" value="always">
</object>

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)
more options

No, no success. FF refuses to show the video. I'm lost.

Is there perhaps a conflict involving Silverlight, and Adobe Flash?

I know getting frustrated never helps, but why can't every browser present every webpage as it should be presented? I have little time for stupid problems like this.

เปลี่ยนแปลงโดย Stringence เมื่อ

more options

Do you at least see an image of the video or is it entirely blank (black)?


Did you try this in Safe mode?

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":


more options

Safe mode worked. Video showed up on the black bottom where I want it.

All Add-ons are inactivated, all Plug-ins are still active.

So, all I can do is to turn add-ons on/off one by one to se which one causes the problem?

Need I worry that other users have the same problem?

more options

วิธีแก้ปัญหาที่เลือก

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

You can also try to disable hardware acceleration in Firefox.

more options

Success! Baaad add-ons.

The villain IS Google Disconnect.

Anyone who knows why this baby effect embedded videos from YouTube?

เปลี่ยนแปลงโดย Stringence เมื่อ