X
Tap here to go to the mobile version of the site.

Support Forum

I cannot update Firefox and update any plugin. Message prompt: "This links need to be opened with an application". What should I do?

Posted

I have problem downloading application files including updating Firefox and Adobe plugin and any online games. There is always this message prompt as below:

This link needs to be opened with an application. Send to: "c:\Program Files (x86)\Media Finder\MF.exe" "%1"


Please advise what to do.

I have problem downloading application files including updating Firefox and Adobe plugin and any online games. There is always this message prompt as below: This link needs to be opened with an application. Send to: "c:\Program Files (x86)\Media Finder\MF.exe" "%1" Please advise what to do.

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Default Plug-in
  • Shockwave Flash 10.3 r183
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.22) Gecko/20110902 Firefox/3.6.22

More Information

Question owner

looks like no one can solve this issue. I am now using internet explorer instead, at least I could get the software and other applications downloaded.

looks like no one can solve this issue. I am now using internet explorer instead, at least I could get the software and other applications downloaded.
ramikhashan 0 solutions 1 answers

Helpful Reply

i have this problem too!!!

just remove / uninstall add-on Media finder or remove it from extensions :)

in C:\Users\MyUser\AppData\Roaming\Mozilla\Extensions


good luck

i have this problem too!!! just remove / uninstall add-on Media finder or remove it from extensions :) in C:\Users\MyUser\AppData\Roaming\Mozilla\Extensions good luck
Swarnava Sengupta 482 solutions 3206 answers

upgrade your browser to Firefox 8 and check

upgrade your browser to Firefox 8 and check * getfirefox.com