ค้นหาฝ่ายสนับสนุน

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Anyway I can continue to use Firefox with my MAC OS X 10.4.11 system?

  • 2 การตอบกลับ
  • 9 คนมีปัญหานี้
  • 21 ครั้งที่ดู
  • ตอบกลับล่าสุดโดย georgeleach

more options

I have a MAC OS X 10.4.11 operating system. I am using Firefox 3.6.6. I can't upgrade to Firefox 4 because of my operating system. I have just found that I can't even upgrade to 3.6.22 (the download will not complete itself). Does this mean that in the near future I will not be able to use Firefox securely? Is there any way I can be a secure Firefox user in the future with my OS X 10.4.11 system?

Thank you

การตอบกลับทั้งหมด (2)

more options

Firefox 3.6.22 is the latest version available for Mac OSX 10.4 and PPC Macs.
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in Firefox 4 / 5 / 6, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 - which is a "community" version based on Firefox.
http://www.floodgap.com/software/tenfourfox/
http://code.google.com/p/tenfourfox/downloads/list

more options

Thank you. I was finally able to complete the download of 3.6.22; but I am glad to know about TenFourFox, since it sounds like all 3.6 versions will be insecure pretty soon.