Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! ปรับรุ่น Firefox

Support Forum

Please help me uninstall Blekko- Thanks!


every time I open firefox- Blekko appears

Additional System Details

This happened

Every time Firefox opened

This started when...

approximately 4 wks ago

Installed Plug-ins

  • Garmin Communicator Plug-In
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60310.0
  • Panda ActiveScan 2.0 Plugin for Firefox
  • Yahoo! activeX Plug-in Bridge
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object


  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

  • Top 10 Contributor
  • Moderator
3197 solutions 24403 answers

Are you saying that Blekko is your homepage now?

Or that on the default homepage - about:home - that Blekko is the Search Engine in the top part of the window?

Hasan 477 solutions 5600 answers

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select Restart with Add-ons Disabled

Firefox will close then it will open up with just basic Firefox. Now do this:

-> go to View Menu -> Toolbars -> unselect All Unwanted/Incompatible Toolbars

-> go to Tools Menu -> Clear Recent History -> Time range to clear: select "EVERYTHING" -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> go to Tools Menu -> Options -> General -> in Startup section click Reset to Default button

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Privacy -> History section -> Firefox will: select "Remember History"

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries

-> go to Tools Menu -> Options -> Advanced -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons)

-> go to Tools Menu -> Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona)

-> Restart Firefox

You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.

Mickee 0 solutions 3 answers

My issues, is that when I open a new tab I have this giant search box for blekko in the middle of the page. When I type in my search box all I get is blekko for a search engine. I hate blekko and want my normal search engines back. I just went through this with Babylon and almost never got that off my computer. I did not download this and do not want it. PLEASE HELP!!!!

Mickee 0 solutions 3 answers

I did it!!! I just hit tools on the top in the menu and then add-ons and it let me disable the one I needed to disable and now blekko is gone. YEAH!!!

rfaitel 0 solutions 1 answers

The newest release of the "Ad-Aware" Antivirus program has blekko included as part of its toolbar. You can go to the uninstall programs in Windows and remove it from there.

sandyl007 0 solutions 1 answers

Brilliant bye bye blekko

ahora 0 solutions 7 answers

I removed Blekko ok via the control panel 'add or remove programmes' I followed the instructions of 'mha007' above

BUT BLEKKO is still there

Also, Blekko does not appear in my list of 'Add-ons' when I go to the 'tools' option for add-ons

Any ideas PLEASE?

Hasan 477 solutions 5600 answers

-> Start Firefox in -> Troubleshoot Firefox issues using Safe Mode to check if your add-ons/extensions are causing the problems.

Check and tell if its working normally while using Firefox in Troubleshoot Firefox issues using Safe Mode.

Also if your search results are being displayed in some other search engine, try this extension to reset Google as your default search engine in Firefox -> SearchReset

Modified by Hasan

ahora 0 solutions 7 answers

This add-on seemed to work. On re-starting, It had changed the startup page to Mozilla Firefox's own page, with a search box. I clicked on 'history' and back to my familiar 'igoogle' set up page, and ' Blekko' had gone from the upper righthand box, and it was back to good old Google.

But when I decided to put an item in the search box on the Mozilla Firefox startup page - it went straight to a Blekko searchpage of results!  ??

As 'Blekko' is some sort of virus, I've no way of knowing what it is doing as it's still hidden in some way within the pc, even though my 'free' scans show no threats are present.

So I am going to return the computer to its factory settings and spend an hour or so setting it up again. And I'll do this every time I want to buy something. Otherwise I won't ever dare buy anything over the net again, in case my card details are being read by these clever malware hackers.

Thank you for all your help. I will follow this thread, and hope someone can find a cure for this nuisance.

Modified by ahora

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned below:

-> Do a MALWARE check with these Malware Scanning programs. You need to scan with all programs because each program detects different malware. Make sure that you UPDATE each program to get the latest version of their Databases before doing a Scan. Also, Close All other Applications (softwares) before Starting to Run Scans.

Check and tell if its working.

ahora 0 solutions 7 answers

OK, I will give all these a go tomorrow. Thanks.

targenti 0 solutions 1 answers

yes...I uninstalled Firefox and reinstalled latest version but still get BLEKKO search engine window

dmr14120 0 solutions 1 answers

Helpful Reply

Blekko is not virus, you agreed to install it when you installed some other program. I needed to download something from CNET (very safe, verified downloads), and I had to agree to d/l at least some part of Blekko for it to proceed.

On Blekko's website (blekko.com), you will find all of the instructions on how to get rid of the toolbar, reset your search engine, etc, (or there are instructions posted in this thread if you don't trust the site).

I did all these by myself, but had one hell of a time changing it so when I simply typed a search term in the header bar it didn't automatically search via Blekko.

Here are the instructions via the site. (CAUTION: messing up your registry is not a good thing. If you are a novice, PLEASE let someone else do this for you!!!)

o change your address bar search:

   Type about:config in the address bar and click “Enter”.
   This brings up a warning. Click on “I’ll be careful, I promise!”
   Type “keyword” in the Search: section and hit enter.
   Double-click on the Preference Name keyword.URL.
   This will bring up a pop-up. Enter the value of the search engine you would like to use. For Google, enter this exact text in the text field: http://www.google.com/search?q=
   Click OK and close and re-open your browser. This should fix your address bar search.
comgeek888 0 solutions 12 answers

Dont panic if you got the nasty blekko redirect malware. before telling the uninstall proccess, i ould like to tell about blekko virus that what it is.

It is a browser hijacker that comes to your computer from malicious websites. When you brows through some malicious domains or download some untrusted program from internet, it may bring malwares and viruses like Blekko.com redirector. Once it has been installed in your computer, it will hijack your browser and change its configuration. So when you search anything on Google or Bing or even some other populer search engine, the blekko.com will appear or it will lead you to wrong websites instead of the proper search results. The purpose of its redirection is to gain traffic for spam websites. It drives people to spam websites containing advertisements and promotions of scamware products. It may ask the user to pay some dollars (random prices) for some useless products shown in fake websites.

to uninstall blekko virus:::::::::

do the following steps.

Check and remove any malicious registry entry at these locations:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run “.exe”
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run “”
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings “CertificateRevocation” = ’0′
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings “WarnonBadCertRecving” = ’0′
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop “NoChangingWallPaper” = ’1′
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations “LowRiskFileTypes” = ‘/{hq:/s`s:/ogn:/uyu:/dyd:/c`u:/bnl:/ble:/sdf:/lrh:/iul:/iulm:/fhg:/clq:/kqf:/`wh:/lqf:/lqdf:/lnw:/lq2:/l2t:/v`w:/rbs:’
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments “SaveZoneInformation” = ’1′
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System “DisableTaskMgr” = ’1′
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system “DisableTaskMgr” = ’1′
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Download “CheckExeSignatures” = ‘no’
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main “Use FormSuggest” = ‘yes’
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced “Hidden” = ’0′
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced “ShowSuperHidden” = 0′ 

Blekko.com files to delete:

%AllUsersProfile%\Application Data\~
%AllUsersProfile%\Application Data\~r
%AllUsersProfile%\Application Data\.dll
%AllUsersProfile%\Application Data\.exe
%AllUsersProfile%\Application Data\
%AllUsersProfile%\Application Data\.exe
%UserProfile%\Start Menu\Programs\Blekko.com\
%UserProfile%\Start Menu\Programs\Blekko.com\Uninstall Blekko.com.lnk
%UserProfile%\Start Menu\Programs\Blekko.com\Blekko.com.lnk

For auto removal and more help,, see the source of this guide: Blekko Redirect virus removal instructions and free tools

jhogsett 0 solutions 1 answers

After going through all of this, restarting the computer, opening firefox, there it was. Blekko laughed at it. I can't uninstall it the normal way because it does not appear in my programs, control panel, or anywhere you would expect it to be. how is THAT possible?

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned below:

1) Uninstall Firefox as described in this article -> Uninstall Firefox from your computer

  • Restart your system

2) Download latest Firefox version from the following link using some other Web Browser:

3) Install Firefox 13 as described in this article -> How to download and install Firefox on Windows


4) Create a New Profile as described in this article -> Make a New Profile

  • Now start Firefox using this newly created profile.

Check and tell if its working.

-> IF that New Profile works then you can recover your History, Bookmarks, Passwords,etc. from the Old Profile, as described in this article -> Recovering important data from an old profile

Modified by Hasan

MozillaFirefox911 0 solutions 129 answers

go to about:config, type in search bar Blekko, then change values to false and make link paths to your preferred homepage. if you want make values 0. i had same problem with babylon and it worked.

  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

If there is a problem with the about:home Home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

If that didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Awesome_Aaron 0 solutions 1 answers

1. Type about:config in the address bar and click “Enter”.

   2. This brings up a warning. Click on “I’ll be careful, I promise!”
   3. Type “keyword” in the Search: section and hit enter.
   4. Double-click on the Preference Name keyword.URL.
   5. This will bring up a pop-up. Enter the value of the search engine you would     like to use. For Google, enter this exact text in the text field: http://www.google.com/search?q=
   6. Click OK and close and re-open your browser. This should fix your address bar search.