ค้นหาฝ่ายสนับสนุน

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get a Greek font to work?

  • 9 การตอบกลับ
  • 1 คนมีปัญหานี้
  • 395 ครั้งที่ดู
  • ตอบกลับล่าสุดโดย cor-el

more options

I have spent an entire day trying to get Firefox to display some new Greek fonts to no avail. Some but not all other browsers seem to work but not Firefox which is my main browser. To make is specific. I cannot get any font from this set:

http://www.greekfontsociety.gr/pages/en_typefaces19th.html

to display this page:

http://mercure.fltr.ucl.ac.be/Hodoi/concordances/demostene_philippiques_09/texte.htm

If I have the web page choose the font then I get their (nice) font.

If I don't let the web page choose, then I get a rather ugly almost hybrid font.

Those are the only two results despite changing every possible setting under Tools>Options>Content>Advanced>Greek

Help!

Thanks

การตอบกลับทั้งหมด (9)

more options

That website specifies font face="palatino linotype"

You can force a specific font with the Stylish extension or code in userContent.css

Add quotes ("") around the font name if there are spaces in it.


@-moz-document domain(mercure.fltr.ucl.ac.be){
font[face="palatino linotype"]{
 font-family: "GFS Goschen" !important;
 font-style: italic !important;
 }
}
more options

Thanks cor-el. Making progress, but not out of the woods yet.

0) I am using GFS Porson rather than GFS Goschen. I am sorry that I didn't specify that at the outset.

1) I used the Stylish extension. The font definitely changed (yeah!) but the letters are tilted as if they were Greek italics or something.

2) Every fifth line or so is closer together than the others.

3) Why does the code that you gave me have italic! rather than greek! (I know nothing about these codes I just found that curious.)

4) I still get no change at the two other sites that I use despite creating styles for both:

http://artflx.uchicago.edu/perseus-cgi/citequery3.pl?dbname=GreekFeb2011&query=Dem.%209.1&getid=0

http://www.perseus.tufts.edu/hopper/text?doc=Perseus%3Atext%3A1999.01.0069%3Aspeech%3D9%3Asection%3D1

เปลี่ยนแปลงโดย fster เมื่อ

more options

You can leave out that line ( font-style: italic !important;) and only specify the font-family.
The GFS Porson font looks italic, at least the lower case characters.

Each site will require its own code if you only want to use it for the greek text or you can try to use the font for everything by using;

body, body *{ font-family: "GFS Porson" !important; }

@-moz-document domain(mercure.fltr.ucl.ac.be){
font[face="palatino linotype"] { font-family: "GFS Porson" !important; }
}

@-moz-document domain(www.perseus.tufts.edu){
.greek { font-family: "GFS Porson" !important; }
}

@-moz-document domain(artflx.uchicago.edu){
#perseuscontent { font-family: "GFS Porson" !important; }
}
more options

Wow. That's great. I am amazed. I am blown away. You are so great. I should have come here right away. I would wash your car for you. Honestly! If you ever need any help with Ancient Greek or guitar, lemme know! Thank you, thank you, thank you.

เปลี่ยนแปลงโดย fster เมื่อ

more options

I am still having one last problem. When I go to a chicago page like this:

http://perseus.uchicago.edu/perseus-cgi/citequery3.pl?dbname=GreekTexts&getid=0&query=Polyb.%201

Everthing is nice and the font looks great.

But if you click on a word and do a couple more quick clicks you get a dictionary entry in a pop up window.

http://artflx.uchicago.edu/cgi-bin/philologic/getobject.pl?c.20:5:6.LSJ

But this doesn't have the Porson font. (You click on the word a couple of times and any of the dictionaries but I used LSJ.)

I have tried altering the domain names somewhat to no avail.

more options

There is no #perseuscontent ID on that page, so you need to look at the page source to see which selector(s) to use.


This seems to working good enough on that page.

@-moz-document domain(artflx.uchicago.edu){
.foreign, quote[lang="greek"] {
 font-family: "GFS Porson" !important;
 font-size: 14pt !important;
}
}
more options

Once again. Thank you very much.