On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

ค้นหาฝ่ายสนับสนุน

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The line "body{ margin-bottom: 1000px !important; }" in userConent.css (enables correct scrolling with PageDown at the end of a webpage) does not work in some sites, e.g. en.wikipedia.org. How can I get this work?

  • 6 การตอบกลับ
  • 9 คนมีปัญหานี้
  • 32 ครั้งที่ดู
  • ตอบกลับล่าสุดโดย cor-el

more options

At the end of a webpage, scrolling with PageDown can cause unexpected motion of the text lines, if the number of the "screens" do not divide the height of the webpage. Adding extra space at the end of the page solves this. This can be done with the line

body{ margin-bottom: 1000px !important; }

in userContent.css. However, some sites (e.g. Wikipedia) are not affected.

At the end of a webpage, scrolling with PageDown can cause unexpected motion of the text lines, if the number of the "screens" do not divide the height of the webpage. Adding extra space at the end of the page solves this. This can be done with the line body{ margin-bottom: 1000px !important; } in userContent.css. However, some sites (e.g. Wikipedia) are not affected.

วิธีแก้ปัญหาที่เลือก

In case you do not know...

If you want to limit css to specific sites you can do, e.g.

@-moz-document url-prefix(http://www.example.com/example_dir/)

{
css for this site/directory
}

(There are other varieties of this construction too.

Even easier is to use the Stylish addon. https://addons.mozilla.org/en-US/firefox/addon/2108/

อ่านคำตอบนี้ในบริบท 👍 0

การตอบกลับทั้งหมด (6)

more options

It seems to be because there is also this:

html, body {
...
height:100%;


If you add

body { height : auto  ! important ; }

it works

เปลี่ยนแปลงโดย DaveRo เมื่อ

more options

วิธีแก้ปัญหาที่เลือก

In case you do not know...

If you want to limit css to specific sites you can do, e.g.

@-moz-document url-prefix(http://www.example.com/example_dir/)

{
css for this site/directory
}

(There are other varieties of this construction too.

Even easier is to use the Stylish addon. https://addons.mozilla.org/en-US/firefox/addon/2108/

more options

This is very interesting! Thank you very much!

more options

[The solution is the first reply, I don't know how to set this, but that's ok]