ค้นหาฝ่ายสนับสนุน

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Re-enable searching from the New Tab page

  • 4 การตอบกลับ
  • 1 คนมีปัญหานี้
  • 9 ครั้งที่ดู
  • ตอบกลับล่าสุดโดย jscher2000 - Support Volunteer

more options

For ages I've had it set up that when I open a new tab, I get a bunch of my frequently visited sites and a search bar I have set up to do searches on Google. But a recent update messed this up. If I try typing in a search, it moves over to the search bar. Now, for me, searching from the address bar is ABSOLUTELY UNEXCEPTABLE. I never do searches from the address bar, it is for ADDRESSES and nothing else. I want it to be clear that if I enter something there, it's an address, to attempt to go to this address (I've had a few times where Firefox made this mistake, tried searching for something entered as an address). I just looked up how to disable the search in about:config, great. But this behaviour continues! STILL if I try entering text in the search bar it moves to the address bar anyway!

Is there any way to stop Firefox from moving my cursor? To accept text in the bar in the page? It didn't used to work this way, as recently as a few weeks ago. Because of this idiocy I've had to enable the separate search bar, but I still want to be able to search in the page.

For ages I've had it set up that when I open a new tab, I get a bunch of my frequently visited sites and a search bar I have set up to do searches on Google. But a recent update messed this up. If I try typing in a search, it moves over to the search bar. Now, for me, searching from the address bar is ABSOLUTELY UNEXCEPTABLE. I never do searches from the address bar, it is for ADDRESSES and nothing else. I want it to be clear that if I enter something there, it's an address, to attempt to go to this address (I've had a few times where Firefox made this mistake, tried searching for something entered as an address). I just looked up how to disable the search in about:config, great. But this behaviour continues! STILL if I try entering text in the search bar it moves to the address bar anyway! Is there any way to stop Firefox from moving my cursor? To accept text in the bar in the page? It didn't used to work this way, as recently as a few weeks ago. Because of this idiocy I've had to enable the separate search bar, but I still want to be able to search in the page.
ภาพหน้าจอที่แนบมา

วิธีแก้ปัญหาที่เลือก

There is a preference for this but it does take a bit of work to find it because of the unusual name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

อ่านคำตอบนี้ในบริบท 👍 1

การตอบกลับทั้งหมด (4)

more options

OMG, I mis-spoke and now I can't edit or delete to correct it, WTF???!?!? "If I try typing in a search, it moves over to the ADDRESS bar."

more options

วิธีแก้ปัญหาที่เลือก

There is a preference for this but it does take a bit of work to find it because of the unusual name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

more options

Ah, yes, that did it jscher2000! Perfect! Thanks!

AwesomeBar? LOL!

more options

(That name comes from the launch of Firefox 3.0, but isn't used much in recent years.)