Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Email address link on websites generating errors

  • 5 การตอบกลับ
  • 1 คนมีปัญหานี้
  • 17 ครั้งที่ดู
  • ตอบกลับล่าสุดโดย england1966

more options

On several sites, when I click on what is a link to an email address, it generates the following error: "The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (mailto) isn’t associated with any program or is not allowed in this context."

The same webpage when viewed on another browser simply opens a pop-up email.

Any suggestions as to what is going on?

Thank you.

All Replies (5)

more options

It looks like the link you are trying is a mail address, not a web page.

Right-click on the link and select Copy Link Location and paste it here.

If it is an e-mail address, check out: https://support.mozilla.org/en-US/search?q=mailto

more options

To clarify, when using the chrome browser, if I click a 'mailto:' link, it opens a Microsoft Outlook email. When I click on a 'mailto:' link in Firefox, it generates the error noted above. In Firefox preferences, mailto is associated with Outlook.

more options

The program or the website? Try right-clicking the Mailto entry and reselecting your choice.

more options

If you didn't find it already, could you check whether this article helps with the setting: Change the program used to open email links.

Edit:

After reading your further reply, it sounds as though you are familiar with that setting.

Sometimes the settings file that stores download handling preferences becomes corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows/File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, it is obsolete and you can delete it.

Start Firefox back up again and it should rebuild the default setting for mailto: links. Any improvement?

เปลี่ยนแปลงโดย jscher2000 เมื่อ

more options

I tried this, and some sites work, others generate the same error (ss1.jpg screenshot). I've had someone in our other office check out the mailto links on their firefox, and the ones that don't work for me do work for them, so clearly it's in my settings somehow (ss2.jpg screenshot). It appears that Outlook is selected, but on some sites it opens a mail window, others generate the ss1.jpg error.