Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why don't Google fonts render properly?

  • 2 ప్రత్యుత్తరాలు
  • 3 ఈ సమస్యలు కలిగి ఉన్నాయి
  • 2 వీక్షణలు
  • చివరి సమాధానమిచ్చినది springerdesign

more options

I have been working on this site:

https://www.abtusa.com

When I go to the home page, the Google font Lato is rendered properly in Firefox (Mac). When I navigate to any of the other pages using the nav bar, all of the fonts revert to generic sans-serif. This problem does not occur in Safari.

can anyone help me figure this out?

Thanks in advance,

Jesse

I have been working on this site: https://www.abtusa.com When I go to the home page, the Google font Lato is rendered properly in Firefox (Mac). When I navigate to any of the other pages using the nav bar, all of the fonts revert to generic sans-serif. This problem does not occur in Safari. can anyone help me figure this out? Thanks in advance, Jesse

ఎంపిక చేసిన పరిష్కారం

Hi Diego Victor,

Thank you for your reply. Before I had a chance to try your solutions, I fixed a broken image link on the page, and for some reason, that fixed the font problem. I don't know how or why-- I am just thankful that it's fixed.

Thanks again!

- Jesse Springer

ఈ సందర్భంలో ఈ సమాధానం చదవండి 👍 0

ప్రత్యుత్తరాలన్నీ (2)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

ఎంపిక చేసిన పరిష్కారం

Hi Diego Victor,

Thank you for your reply. Before I had a chance to try your solutions, I fixed a broken image link on the page, and for some reason, that fixed the font problem. I don't know how or why-- I am just thankful that it's fixed.

Thanks again!

- Jesse Springer