X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How To Disable Quick Find

Posted

I have Firefox 22 installed on a Windows 8 laptop. Most of the time when I type something the 'Quick Find' bar pops up. Is there any way to disable it? I have no extensions installed except for WOT and McAfee.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • SiteAdvisor
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.20125.0
  • NPWLPG

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • McAfee SiteAdvisor 3.6.2 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WOT 20130515 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6310 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9802
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 384
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 3-13-2013
  • driverDate2:
  • driverVersion: 12.102.4.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6310 Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=937811
  • browser.startup.homepage: https://www.facebook.com/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&ilc=12&type=937811&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1373120508
  • places.history.expiration.transient_current_max_pages: 96529
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npitunes: 0
  • plugins.hide_infobar_for_missing_plugin: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1371846321

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

See:

  • Firefox/Tools > Options > Advanced : General: Accessibility: "Search for text when I start typing"

Helpful Reply

It is already unchecked.

I have the same problem. It started about about 2 weeks ago. Extremely annoying and I am about to go back to IE ugh :-(

I am using FireFox 23 on Linux Mint and the same thing happened within the past 4 hours.

Nothing has been updated or installed.

What happens is that any time I try to type a single quote, the Quick Find opens AND focused is forced to there.

This has completely ruined the ability to use firefox - ability to do drop fast pieces of code into a shared doc, use of contractions in sentences, etc. All now rendered useless and inaccessible when using Firefox.

I have to agree.... so annoying that I am going back to chrome. Firefox, give options not your "good" ideas.

Each of those links report a different bug related directly to this issue. Each bug reported as fixed and Verified for over 5 years.

There are not useful solutions there. The first says to not open windows using a shortcut, which is not related to running the code in linux. It additionally suggests opening then closing a dialog box. The second suggests installing a plugin which remaps the keys.

Despite the fact that I have specifically turned off search, these search bars still show up. The presence of the bugs should point to this being a larger problem, not one "fixed" by remapping to other commonly used keys or by having me be aware that focus has changed after typing a large amount so that I can open and close a dialog.

These solutions are not viable. Remapping keys is not a solution when all keys are possibly necessary. Remapping is not a solution when I specifically turned "search while typing" off in the settings.

I had this problem as well, but I think I discovered a solution.

First go here: Firefox/Tools > Options > Advanced : General: Accessibility: "Search for text when I start typing" Once there, check the box and click OK. Then go back to the same location in options, uncheck the box, and click OK.

That should fix it!

Thanks MintShard,

I have tried it and at least for now it seems to be working. Will let you know if anything changes.

I have the exact same problem and tried - the add-on - checked the Search text when I type and unchecked it again - added searchkeys.disable.all = true to about:config

None of these fix the problem. Does any one know how to entirely and forever disable the quick find? Pressing CTRL+F ought to be quick enough for everyone so I see really no point in having this 'feature' in the first place. This is not only utterly annoying but also prevents usage of some browser based apps. Who ever thought this is a good idea?

Modified by Schoolmaster