Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Many major websites play video frames out of sequence.

  • 8 ప్రత్యుత్తరాలు
  • 0 ఈ సమస్యలు కలిగి ఉన్నాయి
  • 40 వీక్షణలు
  • చివరి సమాధానమిచ్చినది cor-el

more options

The video from most websites plays out of sequence. It appears that approximately every one second plays its frames in reverse order. This occurs with most video streaming services and major sites. For example, all Amazon, Sam's Club, Walmart and other website product videos. Occasionally, Amazon product videos just say not compatible. However, YouTube videos with very rare excepts play fine in Firefox. Those problem sites play the videos fine under Edge for Linux. But, I would much rather use Firefox. I'm sure this a codec related issue. Possibly related to the NVIDIA GeForce GT 1030 video card in this computer running openSUSE 15.5. But after much searching, I'm at a loss on how to resolve the problem.

The video from most websites plays out of sequence. It appears that approximately every one second plays its frames in reverse order. This occurs with most video streaming services and major sites. For example, all Amazon, Sam's Club, Walmart and other website product videos. Occasionally, Amazon product videos just say not compatible. However, YouTube videos with very rare excepts play fine in Firefox. Those problem sites play the videos fine under Edge for Linux. But, I would much rather use Firefox. I'm sure this a codec related issue. Possibly related to the NVIDIA GeForce GT 1030 video card in this computer running openSUSE 15.5. But after much searching, I'm at a loss on how to resolve the problem.

ప్రత్యుత్తరాలన్నీ (8)

more options

What do you have installed for ffmpegs? see screenshot I'm on Tumbleweed and also have another laptop running Leap 15.6 beta with no issues. Can you provide examples of videos not working for you? What driver are you running with that video card? Do you have packman repo installed?

న jonzn4SUSE చే మార్చబడినది

ఉపయోగపడిందా?

more options

I always use this site during installs. https://www.opensuse-community.org/ What version of Firefox? What Desktop? X11 or Wayland?

న jonzn4SUSE చే మార్చబడినది

ఉపయోగపడిందా?

more options

Running fully updated version of latest stable version of openSUSE 15.5 from https://opensuse.org. However, this issue has been present for probably all versions of 15.x on this system.

Running latest standard version of Firefox 115.9.1esr (64-bit). However, other browsers like Chrome also have this issue. Only Edge does not exhibit this behavior.

Running KDE on X11.

Using latest drivers provided by NVIDIA for the GeForce GT 1030 graphics card. Other than NVIDIA and NASM, no other non-standard repositories are configured.

Here is a link to a YouTube video I recorded using my phone https://youtu.be/aqKEbVEV4DA. The left window is Firefox and the right is Edge. They are not in perfect sync. But, are close enough. The longer faster close-up panning makes the out-of sequence issue stand out more.

ఉపయోగపడిందా?

more options

What package formats are you using for Firefox, Chrome and Edge?

Does it still happen with the flatpak package?

You will need to install codecs for flatpak:

flatpak install org.freedesktop.Platform.ffmpeg-full//23.08

ఉపయోగపడిందా?

more options

Edge has always been the flatpak.

I don't use Chrome often. The last time I checked the playback in that browser, I was using the openSUSE package. But, apparently at some point I switched to the flatpak version. It's video seems mostly fine now. It does not have the glitching. It's playback is not as smooth as Edge (or Firefox videos that do not glitch, like on YouTube).

The openSUSE package of Chromium does not play the video at all. The flatpak version plays it ok. Smoother than Chrome, not as smooth as Edge.

I just uninstalled the openSUSE package for Firefox and installed the flatpak using the KDE Discover software utility.

The flatpak version has much improved video playback. But, it is still glitchy. It only seems to play the the first set of frames out of order on major video changes. Possibly only at "I frames".

One of the videos I've been using to test is banner video at the top of the 2024 Polaris Slingshot SLR product page. Just a side note... This brings up a minor annoyance I've experienced with flatpak packages. It seems like anytime there are normal system package updates, the VideoLan flatpak stops working. Requiring me to Uninstall and Reinstall that flatpak.

ఉపయోగపడిందా?

more options

Did you install the ffmpeg-full flatpak package mentioned earlier?

You might need hardware accelerated decoding to get smooth playback with 1080p videos by changing media.ffmpeg.vaapi.enabled to true in about:config then restart the browser.

ఉపయోగపడిందా?

more options

Excluding the glitch at major changes, the Firefox flatpak plays the video butter smooth (like Edge).

Visually assessing the glitch looks like the non-flatpak version plays a frame order something like: 54321 54321 54321 54321 54321 54321, etc.

The flatpak version of Firefox is something like: 54123 12345 12345 12345 12345 12345 12345 (scene change) 54123 12345 12345 12345, etc.

Neither package versions, exhibit any video lag. Nor do they appear to skip any frames. Only simply played out of order.

I switched back to the openSUSE package for now. Mostly because, the flatpak version still had issues and I'd need to go through and configure the browser to be readable on the 4K monitor.

I have not yet tried the ffmpeg-full flatpak out of concern that it would conflict with the pre-existing ffmpeg packages. Not sure what libraries would need uninstalled prior to the flatpak installation.

Although I have been using SuSE/openSUSE for decades, it has been mostly in server type roles and automation. Recently, I have been working on migrating my primary desktop usage over as well. Which is to say, the flatpak sand-boxed package stuff is relatively new to me.

Also, I get concerned about using a flatpak over a standard openSUSE package. That is a result of my experience with VLC flatpak. It appears that every time there are normal system updates from yast/zypper, VideoLAN will stop working. I don't watch much local video on this machine. Each time I go to use VLC, it requires removal and re-installation (until next system package update). But, the occasional reinstall is only a minor annoyance with VLC.

Wouldn't the flatpak version of Firefox bring along everything it needs? That's what seems to happen with Edge and Chrome.

ఉపయోగపడిందా?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

ఉపయోగపడిందా?

ఒక ప్రశ్న అడగండి

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.