Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why won't FireFox save my log in for my home page?

  • 10 ప్రత్యుత్తరాలు
  • 5 ఈ సమస్యలు కలిగి ఉన్నాయి
  • 88 వీక్షణలు
  • చివరి సమాధానమిచ్చినది FredMcD

more options

Until the the most recent upgrade(s), Firefox would automatically save my log in information for my home page. It no longer does. When I start Firefox now, I have to click Sign In, choose my saved password (from Roboform), and I am logged in.

Sometimes I can close Firefox, reopen it and I am still logged in. Most of the time when I close Firefox and reopen it, I have to sign in again. I have the same settings in the current version as I had previously but still have issues.

I have tried all the standard 'stuff' (making sure passwords are saved, etc.) but nothing changes. I have uninstalled Firefox and started 'from scratch,' but it hasn't helped. I'm baffled.

B.T.W. if I use Internet Explorer, my Sign In settings are saved. I want to use Firefox but signing in every time is a pain.


ఎంపిక చేసిన పరిష్కారం

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

ఈ సందర్భంలో ఈ సమాధానం చదవండి 👍 0

ప్రత్యుత్తరాలన్నీ (10)

more options

Some web sites have an auto log out after a time.

Log-in status are stored in cookies on your system.

You may have a corrupt cookies.sqlite file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file. Then rename or delete it. Restart Firefox.

Let us know if there is still a problem.

more options

Thanks for the quick reply. Unfortunately, it didn't resolve the issue. I couldn't delete the file(s) while in Firefox because it said it was open.

I went in through File Explorer and deleted any cookies.sqlite files. I restarted Firefox, logged in, and was connected to my correct home page. I closed down, restarted Firefox and was still logged in. However, I had had the same experience before so I closed Firefox and opened it for the third time and I was no longer logged in.

I repeated the process but rebooted the second time thinking that may make a difference. It worked the same way ... opened Firefox, logged in, closed, opened (still logged in), closed, opened ... no longer logged in.

I think you're on the right track about the cookies. I noticed that my ID for my Bank log in used to be saved by Firefox but no longer is.

This isn't critical but I've used Firefox for a long time and really like it. I hope you can find a solution.


more options

FredMcD said

Now Close Firefox. Locate the cookies.sqlite file. Then rename or delete it. Restart Firefox.

Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

more options

Same results. I did the above. The first time I opened Firefox and put in my sign in information, I was logged in. I closed Firefox, opened it, and I was still logged in. I closed it again, opened it and was no longer logged in.

Looking back, I didn't mention that I'm logging in to my Microsoft Live account. I don't know if that matters but wanted to mention it.

Thanks for your efforts.

more options

I've called the big guys to help you. Good luck.

more options

If you use cleanup software like CCleaner then check the settings for the Firefox application.

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.
  • Clearing Cookies will remove all specified (selected) cookies including cookies with an allow exception that you want to keep.

You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions
more options

How do I completely uninstall Firefox ... settings, etc.? I was running Glary Utilities and, when CCleaner was mentioned above, I thought that might be the problem.

I uninstalled Glary Utilities, then uninstalled Firefox. I rebooted and reinstalled Firefox. Unfortunately, it couldn't have been a clean uninstall as my settings under Privacy were still the same.

If you can tell me how to delete everything so I get a 'new, clean' install, I'll try that.

Thanks again for everyone's help. I've been using Firefox for some time and never had this issue until recently.

న dvdrttr చే మార్చబడినది

more options

You can create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I resolved the problem by formatting my hard drive and then did a fresh install of Windows.

Thanks for the excellent (and quick) help. When the 'experts' solutions didn't work, I figured there must be some other program affecting Firefox.

I don't know what it was but, after the complete re-install, I now have a Firefox that saves my log in. Probably an extreme measure but, with Windows 10 coming, I assumed I should start with as few issues as possible.

Thanks again for the help.

more options

ఎంపిక చేసిన పరిష్కారం

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.